Subject: Re: [Netslices] COMS BoF proposal for IETF100 is uploaded

From: <[email-masked]>
Date: Wed, 4 Oct 2017 07:56:19 +0000

Sheng,
Is there a draft WG Charter yet? Would be good to have one a while before the IETF. From the description below, it sounds like the (only) work item will be a common information model, is that right?
Thanks
phil

From: Netslices [mailto:[email-masked]] On Behalf Of Sheng Jiang
Sent: 27 September 2017 15:36
To: [email-masked]
Subject: [Netslices] COMS BoF proposal for IETF100 is uploaded

Dear all netslices,

The stable version of COMS BoF proposal, as below, has been uploaded onto the IETF BoF WiKi page. Two associated documents are linked. No further modification would be made unless the responsible ADs explicitly ask or made by themselves directly.

A demonstration is also in preparation for the coming IETF100 meeting, Singapore. An implementation of the common netslice template and mapping it into two existing technologies would be showed.

https://trac.tools.ietf.org/bof/

Many thanks and best regards,

Sheng

Common Operation and Management on network Slicing (COMS)

Description:

The dynamic provisioning of customized networking facilities (forwarding and routing, QoS, security, compute, storage capabilities among others) over physical infrastructures can rely upon the so-called network slicing technique. Network slicing is a technique to construct and manage a network slice, which is a collection of network resources and network functions. Customers of such networking facilities would like their service provider to construct network slices accordingly, regardless of the underlay technologies, while network operators have multiple candidate technologies for supporting the network slicing. Between the technology-agnostic service requirements and specific implementation technology, a common information model is missed. This information model could be mapped to any available implementation technology, and supports the operation and management on network slices.

Status: WG-Forming BoF
Responsible AD: Benoit Claise
BoF Chairs: TBD
Number of people expected to attend: 150
Length of session: 1.5 hours
Conflicts to avoid (whole Areas and/or WGs): teas, anima, detnet, sfc, nvo3, opsarea

Mailing List: ​https://www.ietf.org/mailman/listinfo/netslices<https://www.ietf.org/mailman/listinfo/netslices>

Relevant drafts:

  *   ​Problem Statement of Supervised Heterogeneous Network Slicing<https://datatracker.ietf.org/doc/draft-geng-coms-problem-statement/>
  *   ​Technology Independent Information Model for Network Slicing<https://datatracker.ietf.org/doc/draft-qiang-coms-netslicing-information-model/>
  *   YANG Model of the Northbound Interface for Management and Operation on Information Model [TBD]

Agenda (draft)

  *   Admin - 5 mins
  *   Technical Requirement for a common Information Model of slice from Operators - 25 mins
  *   A design for a common Information Model - 20 mins
  *   Mapping the common Information Model to multiple technologies - 15 mins
  *   Charter and Deliverables Discussions Q&A - 25 mins

---

From: Benoit Claise <[email-masked]>
Date: Wed, 4 Oct 2017 15:45:36 +0200

Dear all,

Same questions on my side.
I see on one side a proposal for a WG-Forming BoF, but no proposed 
charter text and no deliverables.

Regards, Benoit.
>
> Sheng,
>
> Is there a draft WG Charter yet? Would be good to have one a while 
> before the IETF. From the description below, it sounds like the (only) 
> work item will be a common information model, is that right?
>
> Thanks
>
> phil
>
> *From:*Netslices [mailto:[email-masked]] *On Behalf Of 
> *Sheng Jiang
> *Sent:* 27 September 2017 15:36
> *To:* [email-masked]
> *Subject:* [Netslices] COMS BoF proposal for IETF100 is uploaded
>
> Dear all netslices,
>
> The stable version of COMS BoF proposal, as below, has been uploaded 
> onto the IETF BoF WiKi page. Two associated documents are linked. No 
> further modification would be made unless the responsible ADs 
> explicitly ask or made by themselves directly.
>
> A demonstration is also in preparation for the coming IETF100 meeting, 
> Singapore. An implementation of the common netslice template and 
> mapping it into two existing technologies would be showed.
>
> *Common Operation and Management on network Slicing (COMS)*
>
> Description:
>
> The dynamic provisioning of customized networking facilities 
> (forwarding and routing, QoS, security, compute, storage capabilities 
> among others) over physical infrastructures can rely upon the 
> so-called network slicing technique. Network slicing is a technique to 
> construct and manage a network slice, which is a collection of network 
> resources and network functions. Customers of such networking 
> facilities would like their service provider to construct network 
> slices accordingly, regardless of the underlay technologies, while 
> network operators have multiple candidate technologies for supporting 
> the network slicing. Between the technology-agnostic service 
> requirements and specific implementation technology, a common 
> information model is missed. This information model could be mapped to 
> any available implementation technology, and supports the operation 
> and management on network slices.
>
> Status: WG-Forming BoF
> Mailing List: ​https://www.ietf.org/mailman/listinfo/netslices
>
> Relevant drafts:
>
>   * ​Problem Statement of Supervised Heterogeneous Network Slicing
>     <https://datatracker.ietf.org/doc/draft-geng-coms-problem-statement/>
>   * ​Technology Independent Information Model for Network Slicing
>     <https://datatracker.ietf.org/doc/draft-qiang-coms-netslicing-information-model/>
>
> _______________________________________________
> Netslices mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netslices

---

From: Sheng Jiang <[email-masked]>
Date: Mon, 9 Oct 2017 10:13:39 +0000

Hi, Benoit & Philip,

Although this is late for the COMS BoF proposal for IETF100 (We are continuing work on this towards a COMS BoF in IETF 101!), here are the  three planned deliverables:
1) Problem statement for information model. Primary version at ​Problem Statement of Supervised Heterogeneous Network Slicing<https://datatracker.ietf.org/doc/draft-geng-coms-problem-statement/>.
2) information model for network slicing. Primary version at ​Technology Independent Information Model for Network Slicing<https://datatracker.ietf.org/doc/draft-qiang-coms-netslicing-information-model/>
3) Yang model—information model describes what a network slice looks like -- a abstracted and technique independent entity. Operator needs a way to describe their management and operation requirements on this entity, and the yang model is used to standardize the requirement description. If the information model is put inside an orchestrator, then yang model will correspond to the north-bound interface.

Many thank and best regards,

Sheng

From: Benoit Claise [mailto:[email-masked]]
Sent: Wednesday, October 04, 2017 9:46 PM
To: [email-masked]; Sheng Jiang <[email-masked]>; [email-masked]
Subject: Re: [Netslices] COMS BoF proposal for IETF100 is uploaded

Dear all,

Same questions on my side.
I see on one side a proposal for a WG-Forming BoF, but no proposed charter text and no deliverables.

Regards, Benoit.
Sheng,

From: Netslices [mailto:[email-masked]] On Behalf Of Sheng Jiang
Sent: 27 September 2017 15:36
To: [email-masked]<mailto:[email-masked]>
Subject: [Netslices] COMS BoF proposal for IETF100 is uploaded

Dear all netslices,

Sheng

Description:

Status: WG-Forming BoF

Relevant drafts:

Agenda (draft)

  *   Admin - 5 mins

Netslices mailing list

[email-masked]<mailto:[email-masked]>