Subject: [Netslices] Netslices/COMS: deliverables? Information Model and then ...

From: Benoit Claise <[email-masked]>
Date: Thu, 5 Oct 2017 12:08:48 +0200

Dear all,

[Trying to focus on one subject per email thread]
I see that the intent is a WG forming BoF 
(https://trac.tools.ietf.org/bof/trac/wiki)

Can you clearly describe what the deliverables are. I understand that 
you guys want an information model.
Christina Qiang mentioned: "I think you may want to have a look at RFC 
3444 https://datatracker.ietf.org/doc/rfc3444/. What we are doing is 
information model not service model and data model."

Let me try to understand, copying the figure 1 in 
https://datatracker.ietf.org/doc/draft-qiang-coms-netslicing-information-model/

          Service Model
     Tenant<---------->Network Slicing Service Provider
                                  ^
                                  |
                                  |
                                  |Management/Operations
            +---------------------v-----------------------+
            | Technology Independent NS Information Model |
            +---------------------^-----------------------+
                                  |Mapping to Specific Technology
                                  |
                                  |
           +----------+-----------+------------+
           |          |           |            |
           |          |           |            | NS-Oriented Extension in
           |          |           |            | Each Specific Technology
           |          |           |            |
       +---v--+    +--v---+    +--v---+    +---v--+       Available
       | ACTN |    |DetNet|    | VPN  |    |  SR  |   ... Implementation
       +------+    +------+    +------+    +------+       Technologies

            Figure 1: Technology Independent NS Information Model

Daniele Ceccarilli asked a question: are you targeting a customer 
service model, a service delivery model, network configuration model?
What I'm missing is how this figure 1 relates to figure 3 in 
draft-ietf-opsawg-service-model-explained? (as Qin Wu asked)

                                                  Customer
                             ------------------   Service  ----------
                            |                  |  Model   |          |
                            |     Service      |<-------->| Customer |
                            |   Orchestrator   |    (a)   |          |
                            |                  |           ----------
                             ------------------
                                .          .
                               .            .        (b)   -----------
                              . (b)          .      ......|Application|
                             .                .     :     |  BSS/OSS  |
                            .                  .    :      -----------
                           .  Service Delivery  .   :
                           .       Model        .   :
                  ------------------    ------------------
                 |                  |  |                  |
                 |     Network      |  |     Network      |
                 |   Orchestrator   |  |   Orchestrator   |
                 |                  |  |                  |
                 .------------------    ------------------.
                .         :                       :        .
               .          : Network Configuration :         .
               .          :        Model          :         .
       ------------     ------------     ------------    ------------
      |            |   |            |   |            |  |            |
      | Controller |   | Controller |   | Controller |  | Controller |
      |            |   |            |   |            |  |            |
       ------------     ------------     ------------    ------------
          :              .       .                 :            :
          :             .         .      Device    :            :
          :            .           . Configuration :            :
          :            .           .     Model     :            :
      ---------     ---------   ---------     ---------      ---------
     | Network |   | Network | | Network |   | Network |    | Network |
     | Element |   | Element | | Element |   | Element |    | Element |
      ---------     ---------   ---------     ---------      ---------

      Figure 3: An Example SDN Architecture with a Service Orchestrator

I guess what I'm missing in the figure 1 is the set of building blocks.
I do understand the two new dimensions you want to add this picture, 
next to networking: compute and storage. It might be worth extending 
this figure btw.

I'm asking all these questions because, in the end, I want to 
understand: what do you want to accomplish with an information model
Simply the mapping of high level properties to existing technologies? 
And since at the IETF, mapping to networking technologies?
As an example: do we have the right technology in SR, ACTN, DetNet, 
you-name-it, for what you expect from a slide in terms of max bandwidth, 
min bandwdith, max packet loss, etc...
Is it the intended goal behind the proposed WG? To do the gap analysis 
for the different IETF networking technologies?
It would be good to provide clarifications.

Btw, looking at your information model 
<https://tools.ietf.org/html/draft-qiang-coms-netslicing-information-model-00#section-3>, 
it sure looks like the output of a well data model tool :-)
So do also plan to deliver a data model?

Regards, Benoit

---

From: "qiangli (D)" <[email-masked]>
Date: Wed, 11 Oct 2017 08:00:36 +0000

Hi Benoit and All,

Combined considering the figure 1 in draft-qiang-coms-netslicing-information-model<https://tools.ietf.org/html/draft-qiang-coms-netslicing-information-model-00> and figure 3 in draft-ietf-opsawg-service-model-explained,  I have painted the following figure:

     +-----------+   Customer    +-----------+
     |NS Tenant/ +---------------+NS Operator|
     |Customer   |   Service     |BSS        |
     +-----------+   Model       +------+----+
                                        |
                                        |Service Delivery
                                        |Model
                                        |
                     +------------------+---------------+
                     | NS Management System/Orchestrator|
                     |                                  |
                     |   ****************************   |
                     |   *Technology Independent NS *   |
                     |   *   Information Model      *   |
                     |   ****************************   |
                     |                                  |
                     +--------+-------------------+-----+
                              |                   |
                           Network Configuration Model
     ~~~~~~~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~|~~~~~~~~~~~~~~~~~~~~
      Available Implementation|Technologies       |
                              |                   |
      +-----------------------+-+    +------------+------------+
      |Controller/Orchestrator/ |    |Controller/Orchestrator/ |
      |Manager of Implementation|    |Manager of Implementation|
      |Technology A             |    |Technology B             |  .....
      +---------------+---------+    +-------------+-----------+
                      |                            |
                      | Device Configuration Model |
                      |                            |
      +---------------+----------------------------+-----------------+
      |                                                              |
      |             Underlying Network Resources/Functions           |
      |                                                              |
      +--------------------------------------------------------------+

According to the Information model’s definition in RFC 3198 (“Information model—An abstraction and representation of the entities in a managed environment, their properties, attributes and operations, and the way that they relate to each other. It is independent of any specific repository, software usage, protocol, or platform.), NS information model tries to describe what the network slice looks like.

Different from data models/service models on interfaces, NS information model is “modeling managed objects at a conceptual level” (RFC 3444) insides an NS management system like the ACTN-information model. Describing the NS information model in Yang (maybe need other description tools e.g., UML) makes it look like a data model, however NS information model will be more abstract and implementation independent.

NS information model is the start point of common management and operation on network slice:
At first, design an implementation technology independent information model.
Then considering how to deliver the common management and operation requirements/commands from operators/providers/customers to the information model (data model on north-bound interface of NS management system ).
Furthermore, how to support OAM, inter-slice management, etc.
There will be a series of deliverables during this process – use case, problem statement, information model design, data model, etc.

There is no doubt that the information model must be a comprehensive description of network slice, even if operators may selectively support and expose portion of the whole as needed. Similarly, some properties or attributes may not be supported in some technologies, but that does not mean these properties should not exist in network slice.

Best regards,

Cristina QIANG

From: Netslices [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Thursday, October 05, 2017 6:09 PM
To: [email-masked]
Subject: [Netslices] Netslices/COMS: deliverables? Information Model and then ...

Dear all,

[Trying to focus on one subject per email thread]
I see that the intent is a WG forming BoF (https://trac.tools.ietf.org/bof/trac/wiki)

Can you clearly describe what the deliverables are. I understand that you guys want an information model.
Christina Qiang mentioned: "I think you may want to have a look at RFC 3444 https://datatracker.ietf.org/doc/rfc3444/. What we are doing is information model not service model and data model."

Let me try to understand, copying the figure 1 in https://datatracker.ietf.org/doc/draft-qiang-coms-netslicing-information-model/

         Service Model

                                 ^

                                 |

                                 |

                                 |Management/Operations

                                 |

                                 |

          |          |           |            |

          |          |           |            |

Daniele Ceccarilli asked a question: are you targeting a customer service model, a service delivery model, network configuration model?
What I'm missing is how this figure 1 relates to figure 3 in draft-ietf-opsawg-service-model-explained? (as Qin Wu asked)

                                                 Customer

                            ------------------   Service  ----------

                           |                  |  Model   |          |

                           |   Orchestrator   |    (a)   |          |

                           |                  |           ----------

                            ------------------

                               .          .

                              .            .        (b)   -----------

                            .                .     :     |  BSS/OSS  |

                           .                  .    :      -----------

                          .  Service Delivery  .   :

                          .       Model        .   :

                |                  |  |                  |

                |     Network      |  |     Network      |

                |                  |  |                  |

               .         :                       :        .

              .          :        Model          :         .

     |            |   |            |   |            |  |            |

     |            |   |            |   |            |  |            |

         :              .       .                 :            :

         :             .         .      Device    :            :

         :            .           . Configuration :            :

         :            .           .     Model     :            :

I guess what I'm missing in the figure 1 is the set of building blocks.
I do understand the two new dimensions you want to add this picture, next to networking: compute and storage. It might be worth extending this figure btw.

I'm asking all these questions because, in the end, I want to understand: what do you want to accomplish with an information model
Simply the mapping of high level properties to existing technologies? And since at the IETF, mapping to networking technologies?
As an example: do we have the right technology in SR, ACTN, DetNet, you-name-it, for what you expect from a slide in terms of max bandwidth, min bandwdith, max packet loss, etc...
Is it the intended goal behind the proposed WG? To do the gap analysis for the different IETF networking technologies?
It would be good to provide clarifications.

Btw, looking at your information model<https://tools.ietf.org/html/draft-qiang-coms-netslicing-information-model-00#section-3>, it sure looks like the output of a well data model tool :-)
So do also plan to deliver a data model?

Regards, Benoit