Subject: [Netslices] Summary of Open Issues

From: "qiangli (D)" <[email-masked]>
Date: Wed, 13 Dec 2017 08:25:58 +0000

Hi All,

Before we carry out the next stage work, we would like to hear your opinion on future possible directions. We have preliminarily listed the following 6 potential work items for discussion, is there anything missing or inappropriate?

COMS (Common Operation and Management on network Slices) - a concrete topic narrowed down from NetSlicing, focuses on resource-oriented (including connectivity, computing, storage and other potential resources) common management plane, be able to shield the differences of multiple implementation techniques.

1.       The COMS Architecture - provides common terminology, basic architecture elements, resource abstractions and the inter-actions.

2.       The COMS Use Cases - provides the motivating use cases as a basis for the work.

3.       The COMS Problem Statement - clearly provides the requirements from management work item.

4.       The COMS Information Model/Template - Identifies managed objects needed to implement a network slice instance in a network slice aware system.

5.       The COMS Data Model - date models of northbound and southbound/mapping interfaces of a network slice aware system.

6.       The COMS Service Model - a service model mapping to an instance of a slice and its management.

Best regards,

Cristina QIANG

---

From: Xavier de Foy <[email-masked]>
Date: Thu, 21 Dec 2017 12:30:07 -0500

Hi Cristina,

  Thanks for bringing this to the list. I agree with this narrowed down
approach, and would only have suggestions to simplify and shorten the work
item list. For example 4-5-6 could be limited to 2: (4) model(s) describing
a slice or slice subnet instance and operations on a slice instance; (5)
mapping operation to underlying technologies. Also, I would suggest
limiting the architecture effort as much as possible before IETF101, maybe
even using the problem statement document for this effort for now.

  Best Regards,

Xavier

On Wed, Dec 13, 2017 at 3:25 AM, qiangli (D) <[email-masked]> wrote:

> Hi All,
>
>
>
> Before we carry out the next stage work, we would like to hear your
> opinion on future possible directions. We have preliminarily listed the
> following 6 potential work items for discussion, is there anything missing
> or inappropriate?
>
>
>
> COMS (Common Operation and Management on network Slices) – a concrete
> topic narrowed down from NetSlicing, focuses on resource-oriented
> (including connectivity, computing, storage and other potential resources)
> common management plane, be able to shield the differences of multiple
> implementation techniques.
>
>
>
> 1.       The COMS Architecture - provides common terminology, basic
> architecture elements, resource abstractions and the inter-actions.
>
> 4.       The COMS Information Model/Template - Identifies managed objects
> needed to implement a network slice instance in a network slice aware
> system.
>
> 5.       The COMS Data Model - date models of northbound and
> southbound/mapping interfaces of a network slice aware system.
>
> 6.       The COMS Service Model – a service model mapping to an instance
> of a slice and its management.
>
>
>
> Best regards,
>
>
>
> Cristina QIANG
>
>
>
>
>
> _______________________________________________
> Netslices mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netslices
>
>

---

From: "qiangli (D)" <[email-masked]>
Date: Fri, 22 Dec 2017 13:41:40 +0000

Hi Xavier and others,

Thank you for your comments. According to your suggestions, I have re-organized the potential work items as follows. Since the BoF proposal cut-off date is on early February, I guess it’s time to carry out action ASAP on some items without too many disagreements:

1.      The COMS Problem Statement - clearly provides the requirements from management work item, and the architecture of COMS.

2.      The COMS Use Cases - provides the motivating use cases as a basis for the work. [need a COMS focused use case draft? Any volunteers for new draft?  Has discussed under thread entitled “Open Issue III” ]

3.      Model(s) describing a slice or slice subnet instance and operations on a slice instance. [Any volunteers for new Service Model draft?—discussed under thread entitled “Open Issue II”; Any volunteers for new northbound interface data model draft?]

4.      The COMS mapping operation/interface to underlying technologies. [Has discussed under thread entitled “Open Issue I”]

Best regards,

Cristina QIANG

From: Xavier de Foy [mailto:[email-masked]]
Sent: Friday, December 22, 2017 1:30 AM
To: qiangli (D) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netslices] Summary of Open Issues

Hi Cristina,

  Thanks for bringing this to the list. I agree with this narrowed down approach, and would only have suggestions to simplify and shorten the work item list. For example 4-5-6 could be limited to 2: (4) model(s) describing a slice or slice subnet instance and operations on a slice instance; (5) mapping operation to underlying technologies. Also, I would suggest limiting the architecture effort as much as possible before IETF101, maybe even using the problem statement document for this effort for now.

  Best Regards,

Xavier

On Wed, Dec 13, 2017 at 3:25 AM, qiangli (D) <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

COMS (Common Operation and Management on network Slices) – a concrete topic narrowed down from NetSlicing, focuses on resource-oriented (including connectivity, computing, storage and other potential resources) common management plane, be able to shield the differences of multiple implementation techniques.

6.       The COMS Service Model – a service model mapping to an instance of a slice and its management.

Best regards,

Cristina QIANG

_______________________________________________
Netslices mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netslices

---

From: Xavier de Foy <[email-masked]>
Date: Fri, 22 Dec 2017 12:15:37 -0500

Thanks Cristina, to answer some of your questions, I am interested to work
with you and others on this, especially on #3 items. In particular the work
we started on the COMS model (model and interconnection drafts) may be a
starting point for some of the work there.

One thing I would like to understand better is the difference between
service model and northbound interface data model. Is it fair to say that
the service model would include for example the template (or blueprint) of
a network slice, which would be used in a instantiation request, while the
northbound data model would include the description of the actual instance
of a network slice? If we foresee strong interrelations between those
models, it could be useful to work jointly on them. In any case, it could
be useful to provide more information to clarify their role and the
relation between them in the charter text.

Best Regards,
Xavier.

On Fri, Dec 22, 2017 at 8:41 AM, qiangli (D) <[email-masked]> wrote:

> Hi Xavier and others,
>
>
>
> Thank you for your comments. According to your suggestions, I have
> re-organized the potential work items as follows. Since the BoF proposal
> cut-off date is on early February, I guess it’s time to carry out action
> ASAP on some items without too many disagreements:
>
>
>
> 1.      The COMS Problem Statement - clearly provides the requirements
> from management work item, and the architecture of COMS.
>
> 2.      The COMS Use Cases - provides the motivating use cases as a basis
> for the work. [need a COMS focused use case draft? Any volunteers for new
> draft?  Has discussed under thread entitled “Open Issue III” ]
>
> 3.      Model(s) describing a slice or slice subnet instance and
> operations on a slice instance. [Any volunteers for new Service Model
> draft?—discussed under thread entitled “Open Issue II”; Any volunteers for
> new northbound interface data model draft?]
>
> 4.      The COMS mapping operation/interface to underlying technologies.
> [Has discussed under thread entitled “Open Issue I”]
>
>
>
>
>
> Best regards,
>
>
>
> Cristina QIANG
>
>
>
> *From:* Xavier de Foy [mailto:[email-masked]]
> *Sent:* Friday, December 22, 2017 1:30 AM
> *To:* qiangli (D) <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [Netslices] Summary of Open Issues
>
>
>
> Hi Cristina,
>

---

From: Kiran.Makhijani <[email-masked]>
Date: Fri, 22 Dec 2017 18:21:11 +0000

Apologies for coming in late to the discussion.

Hi Xavier,
In terms of service model, what should be of interest is to describe a particular “type of network slice as a service” (NSaaS). An instance of it would deploy 1 or more tenant/end user services. For example, I am thinking “how can we deploy existing L2SM or L3SM model on a slice?” this is a valid question (or a use case).

In this regard “Service Model” is an overloaded term. One approach could be not to worry about service models. But focus work on NBI. NSaaS will bring operations & monitoring (we need NBI for this) plus some automation (??? how we don’t know yet…).

Another question we should clarify, does model imply only YANG representation or more than that? I believe it should be “more than that” to capture real-time operational aspects.

Personally, I thought template were out of scope.

Also, I’d encourage to continue refining these 3 documents to capture what Christina’s is asking for, rather than producing new set.
       https://www.ietf.org/internet-drafts/draft-qiang-coms-netslicing-information-model-01.txt
       https://tools.ietf.org/id/draft-defoy-coms-subnet-interconnection-01.txt
        https://tools.ietf.org/html/draft-geng-netslices-architecture-02

-Kiran

From: Netslices <[email-masked]> on behalf of Xavier de Foy <[email-masked]>
Date: Friday, December 22, 2017 at 9:16 AM
To: "qiangli (D)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Netslices] Summary of Open Issues

Thanks Cristina, to answer some of your questions, I am interested to work with you and others on this, especially on #3 items. In particular the work we started on the COMS model (model and interconnection drafts) may be a starting point for some of the work there.

One thing I would like to understand better is the difference between service model and northbound interface data model. Is it fair to say that the service model would include for example the template (or blueprint) of a network slice, which would be used in a instantiation request, while the northbound data model would include the description of the actual instance of a network slice? If we foresee strong interrelations between those models, it could be useful to work jointly on them. In any case, it could be useful to provide more information to clarify their role and the relation between them in the charter text.

Best Regards,
Xavier.

On Fri, Dec 22, 2017 at 8:41 AM, qiangli (D) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Xavier and others,

Best regards,

Cristina QIANG

From: Xavier de Foy [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Friday, December 22, 2017 1:30 AM
To: qiangli (D) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] Summary of Open Issues

Hi Cristina,

  Best Regards,

Xavier

Hi All,

Best regards,

Cristina QIANG

---

From: "qiangli (D)" <[email-masked]>
Date: Sun, 24 Dec 2017 11:32:34 +0000

Hi Kiran,

I agree with you that we do not need to worry about terms but focus work on NBI. I also share the same opinion with you that the current 3 documents (Problem Statement, Interconnection, Information Model ) need to be further refined, and I would like to suggest we make revision based on current NetSlicing use case draft so as to concentrate on COMS.

Best regards,
Cristina QIANG

From: Kiran.Makhijani
Sent: Saturday, December 23, 2017 2:21 AM
To: Xavier de Foy <[email-masked]>; qiangli (D) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netslices] Summary of Open Issues

Hi Xavier,
In terms of service model, what should be of interest is to describe a particular "type of network slice as a service" (NSaaS). An instance of it would deploy 1 or more tenant/end user services. For example, I am thinking "how can we deploy existing L2SM or L3SM model on a slice?" this is a valid question (or a use case).

In this regard "Service Model" is an overloaded term. One approach could be not to worry about service models. But focus work on NBI. NSaaS will bring operations & monitoring (we need NBI for this) plus some automation (??? how we don't know yet...).

Another question we should clarify, does model imply only YANG representation or more than that? I believe it should be "more than that" to capture real-time operational aspects.

Also, I'd encourage to continue refining these 3 documents to capture what Christina's is asking for, rather than producing new set.
       https://www.ietf.org/internet-drafts/draft-qiang-coms-netslicing-information-model-01.txt
       https://tools.ietf.org/id/draft-defoy-coms-subnet-interconnection-01.txt
        https://tools.ietf.org/html/draft-geng-netslices-architecture-02

-Kiran

From: Netslices <[email-masked]<mailto:[email-masked]>> on behalf of Xavier de Foy <[email-masked]<mailto:[email-masked]>>
Date: Friday, December 22, 2017 at 9:16 AM
To: "qiangli (D)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netslices] Summary of Open Issues

Best Regards,
Xavier.

Hi Xavier and others,

Thank you for your comments. According to your suggestions, I have re-organized the potential work items as follows. Since the BoF proposal cut-off date is on early February, I guess it's time to carry out action ASAP on some items without too many disagreements:

2.      The COMS Use Cases - provides the motivating use cases as a basis for the work. [need a COMS focused use case draft? Any volunteers for new draft?  Has discussed under thread entitled "Open Issue III" ]

3.      Model(s) describing a slice or slice subnet instance and operations on a slice instance. [Any volunteers for new Service Model draft?-discussed under thread entitled "Open Issue II"; Any volunteers for new northbound interface data model draft?]

4.      The COMS mapping operation/interface to underlying technologies. [Has discussed under thread entitled "Open Issue I"]

Best regards,

Cristina QIANG

Hi Cristina,

  Best Regards,

Xavier

Hi All,

Best regards,

Cristina QIANG