Subject: [Netslices] COMS: next steps?

From: Benoit Claise <[email-masked]>
Date: Tue, 5 Dec 2017 16:45:24 +0100

Dear COMS proponents,

We had multiple netslices or COMS-related discussions during the IETF.
Among others, two presentations, in RTGWG and in OPSAREA, coming from 
two different backgrounds.
We also had a COMS demonstration.
So COMS received some interest during this IETF100.

At this point in time, a few weeks after the meeting, it seems that the 
mailing list went silent again.

Maybe the draft authors are working on updating their drafts, based on 
what was learned in the meeting?
Is it time to reopen the discussion on the mailing list?

Regards, Benoit

---

From: "qiangli (D)" <[email-masked]>
Date: Wed, 6 Dec 2017 14:53:02 +0000

Dear Benoit and All,

As you said we've been thinking about the next step since IETF 100. Our COMS proponents have discussed a charter similar thing (written by Kiran) in order to help us straighten our thinking (pasted below). Please give us your feedback and help enhance it, we also sincerely invite more people to contribute to COMS work.

Best regards,
Cristina QIANG

*********************************************************************
The Common Operations and Management on Network Slices (COMS) [a subset of netSlices] standardizes the network slice management for operations and monitoring of resources associated with a slice as a single entity. The resource may comprise of mainly logical connections in access, edge, aggregation and core routers as well as service nodes with compute, and storage. Such resource may be part of different network domains being served by different technologies.

Network Slice is a collection of several mechanisms (a few actively developed and some already mature) spanning across data and control planes. Many aspects of network slices depend on already developed or work in progress technological areas in IETF such as 
* Data plane: DetNET, TE-Tunnels, MPLS, Segment Routing VPNs, NVO3 etc. 
* Controller and/or control plane: ACTN, PCE and RSVP-TE (requiring LDP, BGP, OSPF awareness at level below.
* Management plane: YANG, OAM etc.

[The foundation of the COMS is that a technology independent resource-centric management plane is desired.] There may be more than one way in which provider network topologies are deployed, therefore, it makes no assumption of infrastructure network connectivity. The goal of COMS is to have a common /inter-operable management interface/functions are necessary to take the concept of network slices to any infrastructure. Resource aware isolation of a provider network is essential and assumed to be provided for the management of characteristics of a network slice. COMS is the management of resource-centric network slices. It allows creation and management of a network slice in a uniform manner from an operator's view.

The COMS tries to specify an information model, the associated data models (or protocol) for: 
1. A Northbound interface, between an orchestrator and a NS provider to instruct what resources to use and corresponding metrics to measure, delegate, and how/when to report the measurement results to NS Provider or tenant-entity,
2. An NS management agent that uses Information model and manages mappings from different provider networks.
Information model is a logical (or abstract) representation of what a network slice is supposed to do. A specific instance of it will create a slice. An instantiation happens after the promised resources are offered from different domains and mapped to the information-model. 

The COMS architecture will allow for utilizing existing traffic-engineered or other topologies. Controllers or nodes containing agents may have several interfaces using different link technologies. Multiple address families and interfaces must be considered in the Control and Report protocols.

The COMS will also consider management and mapping of abstract information to managed entities as a core requirement and will ensure that by default management operations and monitoring mechanisms are non-intrusive, for example, ensuring that management traffic is neither visible nor disruptive to another instance of a slice.

The necessary resource assurance capabilities needed in data plane and/or control are out of the scope and any gaps identified will be delegated to respective technology working group.
[maybe something about association, a service in a slice]

End user of a network slice instance is typically an operator as a tenant of the network slice. Standardizing control of such end users is out of scope. Such end users could use northbound interface to run management tasks with in the slice they. This provides for user-initiated on-demand measurement, which is an important component of the ISP use case.

An initial assumption about the work is that the Network slicing infrastructure system is under the control of a single organization (for example, an Internet Service Provider or a regulator). However, the components related COMS can be deployed in administrative domains that are not owned by the slice-provider. Thus, the Network slice system deployed by a single organization constitutes a single COMS management domain which may span ownership or other administrative boundaries.

The COMS will produce the following work items:
1. The Network Slicing Architecture, provides common terminology, basic architecture elements, resource abstractions and the inter-actions. It comprises of high level components of a network slice aware system. 
2. The COMS Use Cases - provides the motivating use cases as a basis for the work
3. The COMS Problem statement - clearly provides the requirements from management work item.
4. The Network Slicing Information Model- the NS slice with abstraction of resources. Identifies managed objects needed to implement a network slice instance in a network slice aware system.
5. Northbound and Mapping interface, the abstract definition of the information carried from the Orchestrator to slice provider to the NS management agents and the information carried from/to the NS management agents to/from the domain controller. 
6. The COMS Service association to a slice instance, a service model mapping to an instance of a slice and its management.

*********************************************************************

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Tuesday, December 5, 2017 11:45 PM
To: [email-masked]
Subject: [Netslices] COMS: next steps?

Dear COMS proponents,

We had multiple netslices or COMS-related discussions during the IETF.
Among others, two presentations, in RTGWG and in OPSAREA, coming from two different backgrounds.
We also had a COMS demonstration.
So COMS received some interest during this IETF100.

At this point in time, a few weeks after the meeting, it seems that the mailing list went silent again.

Maybe the draft authors are working on updating their drafts, based on what was learned in the meeting?
Is it time to reopen the discussion on the mailing list?

Regards, Benoit

_______________________________________________
Netslices mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netslices