Subject: [Netslices] Open Issue I: SouthBound/Mapping Interface

From: "qiangli (D)" <[email-masked]>
Date: Wed, 13 Dec 2017 08:40:56 +0000

Hi All,

This email is want to collect your opinion on the following issue:

Do we need to standardize the Southbound/Mapping interface of a network slice aware system in COMS? Or do you think this work should be carried out in existing WGs/RGs? (e.g., mapping interface between COMS and ACTN, mapping interface between COMS and NFVO)

Best regards,

Cristina QIANG

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Wed, 13 Dec 2017 17:50:10 +0900

Dear Li,

We need to do it in COMS to avoid decentralization and ensure coherence
among solutions. Otherwise, we would get different interface standards
and it will be more difficult for the network slicing to be homogeneous
and thus less usefulness.

Regards,
Pedro

> _______________________________________________
> Netslices mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netslices

-- 
Pedro Martinez-Julia
Network Science and Convergence Device Technology Laboratory
Network System Research Institute
National Institute of Information and Communications Technology (NICT)
4-2-1, Nukui-Kitamachi, Koganei, Tokyo 184-8795, Japan
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 13 Dec 2017 09:02:18 +0000

Hmm... I disagree. I'd prefer to go for mapping specs or profiling (or even direct endorsement) whenever possible. Let's avoid to invent another one-and-only standard.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------
On 13/12/2017, 09:50, "Netslices on behalf of Pedro Martinez-Julia" <[email-masked] on behalf of [email-masked]> wrote:

    Dear Li,

    Regards,
    Pedro

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 13 Dec 2017 09:22:30 -0500

What does that even mean in the context of how software is built today?

	—Tom

> On Dec 13, 2017, at 3:40 AM, qiangli (D) <[email-masked]> wrote:
> 
> Hi All,
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netslices <https://www.ietf.org/mailman/listinfo/netslices>

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Thu, 14 Dec 2017 08:40:36 +0900

On Wed, Dec 13, 2017 at 09:02:18AM +0000, Diego R. Lopez wrote:
> Hmm... I disagree. I'd prefer to go for mapping specs or profiling (or
> even direct endorsement) whenever possible. Let's avoid to invent
> another one-and-only standard.

Dear Diego,

>From my point of view, the "mapping specs" you mention would somehow
be the "one-and-only standard" and it is what I tried to mean: We should
get some kind of homogeneity from an heterogeneous playground, allowing
heterogeneous systems (and standards) interact to each other.

What I am actually proposing is not to develop anything but to specify
the concepts and operations must be there (ontology). Implementers would
interpret the ontology and use it to develop their adapters (bindings).

Regards,
Pedro

---

From: "qiangli (D)" <[email-masked]>
Date: Mon, 18 Dec 2017 07:19:21 +0000

Technically speaking, is it possible to have a uniform/standard mapping interface to adapt to a variety of implementation technologies? 

Best regards,

Cristina QIANG

-----Original Message-----
From: Diego R. Lopez [mailto:[email-masked]] 
Sent: Wednesday, December 13, 2017 5:02 PM
To: Pedro Martinez-Julia <[email-masked]>; qiangli (D) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netslices] Open Issue I: SouthBound/Mapping Interface

Be goode,

Dr Diego R. Lopez
Telefonica I+D

    Dear Li,

    Regards,
    Pedro

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Mon, 18 Dec 2017 17:45:34 +0900

> Technically speaking, is it possible to have a uniform/standard mapping interface to adapt to a variety of implementation technologies? 

Yes, it is.

Regards,
Pedro

---

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Wed, 20 Dec 2017 14:32:33 +0000

Hello Cristina and others,

I would suggest that  COMS/ATCN interface mapping would be developed in the TEAS WG since that is an IETF WG, is also alluding to slicing topics, has related specifications and the expertise of the transport networks.

However, NFVO related work is currently within NVFRG where the slicing work is a minor subset of much larger territory of what the RG is discussing.  Therefore, it would be better to do such focused work in COMS when and if it becomes an IETF WG.

Best regards
Hannu

From: Netslices [mailto:[email-masked]] On Behalf Of qiangli (D)
Sent: Wednesday, December 13, 2017 10:41 AM
To: [email-masked]
Subject: [Netslices] Open Issue I: SouthBound/Mapping Interface

Hi All,

Best regards,

Cristina QIANG

---

From: "qiangli (D)" <[email-masked]>
Date: Thu, 21 Dec 2017 09:02:12 +0000

Hi Hannu and  others,

Thank you for your comments. As you and Diego mentioned, the standardization of southbound interface is a sensitive matter, we'd better avoid infringing other WGs/RGs.

To solve this issue, maybe we should figure out "Is it possible to have a uniform/standard mapping interface to adapt to a variety of implementation technologies?" first. If Pedro is right, such uniform interface does exist, then it's not a big deal to standardize it IMHO. Otherwise, I think we may need to consider which option listed below will be better:
Option 1: No standardization work on southbound interface, at least before IETF 101
Option 2: Separately analyze all specific technologies as you have done -- ACTN [un-checked], NFV [checked], then how about SFC, VPN...?
Option 3: Classify technologies (e.g., providing connectivity, provide VNF....) , then discuss for each classification.

I personally prefer 1 or 3, what's your opinion?

Best regards,

Cristina QIANG

From: Flinck, Hannu (Nokia - FI/Espoo) [mailto:[email-masked]]
Sent: Wednesday, December 20, 2017 10:33 PM
To: qiangli (D) <[email-masked]>; [email-masked]
Subject: RE: [Netslices] Open Issue I: SouthBound/Mapping Interface

Best regards
Hannu

From: Netslices [mailto:[email-masked]] On Behalf Of qiangli (D)
Sent: Wednesday, December 13, 2017 10:41 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Netslices] Open Issue I: SouthBound/Mapping Interface

Hi All,

Best regards,

Cristina QIANG

---

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Thu, 21 Dec 2017 13:42:42 +0000

Hello Cristina

I am not sure I understand the option 3 sufficiently. What would be the use of the classification? Should we identify classes of technologies that can be served by same/similar mapping based on the classification?

Best regards
Hannu

From: Netslices [mailto:[email-masked]] On Behalf Of qiangli (D)
Sent: Thursday, December 21, 2017 11:02 AM
To: Flinck, Hannu (Nokia - FI/Espoo) <[email-masked]>; [email-masked]
Subject: Re: [Netslices] Open Issue I: SouthBound/Mapping Interface

Hi Hannu and  others,

Best regards,

Cristina QIANG

From: Flinck, Hannu (Nokia - FI/Espoo) [mailto:[email-masked]]
Sent: Wednesday, December 20, 2017 10:33 PM
To: qiangli (D) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Netslices] Open Issue I: SouthBound/Mapping Interface

Best regards
Hannu

Hi All,

Best regards,

Cristina QIANG

---

From: "qiangli (D)" <[email-masked]>
Date: Fri, 22 Dec 2017 13:08:58 +0000

Hi Hannu,

You're right. Still that question, If there does not exist a uniform mapping interface between COMS and various implementation technologies, I am afraid we are unable to analyze all possibilities.  That's why I suggested option 3 even I'm also not sure whether we can find out an appropriate classification method.

Best regards,

Cristina QIANG

From: Flinck, Hannu (Nokia - FI/Espoo) [mailto:[email-masked]]
Sent: Thursday, December 21, 2017 9:43 PM
To: qiangli (D) <[email-masked]>; [email-masked]
Subject: RE: [Netslices] Open Issue I: SouthBound/Mapping Interface

Hello Cristina

Best regards
Hannu

From: Netslices [mailto:[email-masked]] On Behalf Of qiangli (D)
Sent: Thursday, December 21, 2017 11:02 AM
To: Flinck, Hannu (Nokia - FI/Espoo) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] Open Issue I: SouthBound/Mapping Interface

Hi Hannu and  others,

Best regards,

Cristina QIANG

Best regards
Hannu

Hi All,

Best regards,

Cristina QIANG

---

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Fri, 22 Dec 2017 14:02:46 +0000

Ok. Think I what you might be after. Probably what you want is to have a set of reference or example mappings for few representative technologies? Such as

-          A slice over the WAN/transport network for a given technology,

-          A slice over VNF infrastructure (SFCs and nvo3),

-          A slice that is a concatenation of the two across different domains (this we know is missing).

Is this what you would like to see? If so, it sounds to me reasonable and motivating work and would be  useful to identify possible gaps and needed additions.

Best regards
Hannu

From: qiangli (D) [mailto:[email-masked]]
Sent: Friday, December 22, 2017 3:09 PM
To: Flinck, Hannu (Nokia - FI/Espoo) <[email-masked]>; [email-masked]
Subject: RE: [Netslices] Open Issue I: SouthBound/Mapping Interface

Hi Hannu,

Best regards,

Cristina QIANG

Hello Cristina

Best regards
Hannu

Hi Hannu and  others,

Best regards,

Cristina QIANG

Best regards
Hannu

Hi All,

Best regards,

Cristina QIANG

---

From: "qiangli (D)" <[email-masked]>
Date: Sun, 24 Dec 2017 11:16:42 +0000

Hi Hannu,

I think we are aligned, it will be more efficient and effective to do the southbound interface standardization work through this way IMHO. Would you like to call some volunteers from this mailing list together, and prepare a related draft as the support draft for IETF 101 BoF proposal?

Thanks a lot and Merry Christmas.
Cristina QIANG

From: Flinck, Hannu (Nokia - FI/Espoo) [mailto:[email-masked]]
Sent: Friday, December 22, 2017 10:03 PM
To: qiangli (D) <[email-masked]>; [email-masked]
Subject: RE: [Netslices] Open Issue I: SouthBound/Mapping Interface

Best regards
Hannu

Hi Hannu,

Best regards,

Cristina QIANG

Hello Cristina

Best regards
Hannu

Hi Hannu and  others,

Best regards,

Cristina QIANG

Best regards
Hannu

Hi All,

Best regards,

Cristina QIANG

---

From: Liang GENG <[email-masked]>
Date: Mon, 25 Dec 2017 08:04:03 +0000

Hi Cristina and Hannu,

I believe that COMS provides OAM models at a level that we call "network slice".

I personally think COMS itself should not include the southbound mapping because there was an assumption that anything below COMS is not aware of "slice" (although in management perspective, COMS may see some of them "Subnets"). Existing WG/technologies may refer to/map with COMS models if they would like to be part of the managed network slice instance. Eventually, it may be us - the people from COMS community, who will be actively progressing these southbound interfaces in various IETF WGs.

In principle, COMS itself provides the capability of inter-operation between different domains. This capability is enabled by common information model/service model and related OAM models/mechanisms. The southbound mapping is implementation-specific in the view of COMS and may be more suitable to be carried out in various technology-specific WGs. A good example would be that for a link from node A to node B requiring 100Mbit/s peak bandwidth and maximum of 5ms latency, one can map this using various type of SD-WAN(VPN) controllers with different underlay data planes. COMS sees them as the same.

And also in terms of the working load of WG, the southbound mapping could be endless, it may not be feasible for COMS WG to deliver a sensible charter on this matter concerning southbound interfaces.

Meanwhile, I think it would be good if we can first of all deliver a/several information models so that the southbound technology domain can chose the materials they need to map with. We can do this by categorizing the resources as Cristina suggested as "classifications" - which may make the model more systematic. However, it is not necessary to limit the southbound to one category - it should be able to pick parameters/components whatever are needed.

Best wishes

Liang

________________________________
From: Netslices <[email-masked]> on behalf of Flinck, Hannu (Nokia - FI/Espoo) <[email-masked]>
Sent: 22 December 2017 22:02:46
To: qiangli (D); [email-masked]
Subject: Re: [Netslices] Open Issue I: SouthBound/Mapping Interface

Best regards

Hannu

Hi Hannu,

You’re right. Still that question, If there does not exist a uniform mapping interface between COMS and various implementation technologies, I am afraid we are unable to analyze all possibilities.  That’s why I suggested option 3 even I’m also not sure whether we can find out an appropriate classification method.

Best regards,

Cristina QIANG

Hello Cristina

Best regards

Hannu

Hi Hannu and  others,

Thank you for your comments. As you and Diego mentioned, the standardization of southbound interface is a sensitive matter, we’d better avoid infringing other WGs/RGs.

To solve this issue, maybe we should figure out “Is it possible to have a uniform/standard mapping interface to adapt to a variety of implementation technologies?” first. If Pedro is right, such uniform interface does exist, then it’s not a big deal to standardize it IMHO. Otherwise, I think we may need to consider which option listed below will be better:

Option 2: Separately analyze all specific technologies as you have done -- ACTN [un-checked], NFV [checked], then how about SFC, VPN…?

Option 3: Classify technologies (e.g., providing connectivity, provide VNF….) , then discuss for each classification.

I personally prefer 1 or 3, what’s your opinion?

Best regards,

Cristina QIANG

Best regards

Hannu

Hi All,

Best regards,

Cristina QIANG

---

From: Liang GENG <[email-masked]>
Date: Mon, 25 Dec 2017 08:07:56 +0000

The beauty of COMS is to provide a common model to be mapped with, not a standard mapping. The actual mapping across different domains should be various and it is the common model inside COMS which enables the inter-operation.

________________________________
From: Netslices <[email-masked]> on behalf of qiangli (D) <[email-masked]>
Sent: 18 December 2017 15:19:21
To: Diego R. Lopez; Pedro Martinez-Julia
Cc: [email-masked]
Subject: Re: [Netslices] Open Issue I: SouthBound/Mapping Interface

Best regards,

Cristina QIANG

-----Original Message-----
From: Diego R. Lopez [mailto:[email-masked]]
Sent: Wednesday, December 13, 2017 5:02 PM
To: Pedro Martinez-Julia <[email-masked]>; qiangli (D) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netslices] Open Issue I: SouthBound/Mapping Interface

Be goode,

Dr Diego R. Lopez
Telefonica I+D

    Dear Li,

    Regards,
    Pedro

---

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Wed, 27 Dec 2017 14:01:04 +0000

Hello Liang

Please find my comments below.

Best regards
Hannu

From: Liang GENG [mailto:[email-masked]]
Sent: Monday, December 25, 2017 10:04 AM
To: Flinck, Hannu (Nokia - FI/Espoo) <[email-masked]>; qiangli (D) <[email-masked]>; [email-masked]
Subject: Re: [Netslices] Open Issue I: SouthBound/Mapping Interface

Hi Cristina and Hannu,

>HFl: Monitoring and ensuring the SLA end to end of a slice is an important aspect. Note that when the slice is crossing a (technology) domain, we might need to stich the end to end slice OAM from different pieces of segments. Can we have such a "technology agnostic" OAM? Is that feasible? Or should we do something what SFC WG is doing?

>HFl: What you say above would be an ideal situation, but I am afraid that in practice the situation is such that also other WGs are working on slicing. See https://www.ietf.org/id/draft-ietf-teas-actn-framework-11.txt

>HFl:  ok.

>HFl: right.

>HFl: this a bit unclear to me. Maybe you can elaborate your thoughts further.

Best wishes

Liang

________________________________
From: Netslices <[email-masked]<mailto:[email-masked]>> on behalf of Flinck, Hannu (Nokia - FI/Espoo) <[email-masked]<mailto:[email-masked]>>
Sent: 22 December 2017 22:02:46
To: qiangli (D); [email-masked]<mailto:[email-masked]>
Subject: Re: [Netslices] Open Issue I: SouthBound/Mapping Interface

Best regards

Hannu

Hi Hannu,

Best regards,

Cristina QIANG

Hello Cristina

Best regards

Hannu

Hi Hannu and  others,

Best regards,

Cristina QIANG

Best regards

Hannu

Hi All,

Best regards,

Cristina QIANG