Subject: Re: [Netslices] Open Issue II: Service Model

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 13 Dec 2017 09:00:08 +0000

Hi,

If we focus on connectivity matters, L2SM/L3SM or similar should be enough. If we start thinking about other resources (storage, compute…) I think we’d need something more. As a starting point, we could use the models being defined by the OSM project:
https://osm.etsi.org/wikipub/index.php/OSM_Information_Model

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------
On 13/12/2017, 09:48, "Netslices on behalf of qiangli (D)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi All,

This email is trying to collect your opinion on the following issue:

Do we need a COMS Service Model? Or do you think current L2SM/L3SM/etc. is enough to support the resource-oriented (including connectivity, computing, storage and other potential resources) common management on network slices?

Best regards,

Cristina QIANG

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Shunsuke Homma <[email-masked]>
Date: Wed, 13 Dec 2017 21:48:06 +0900

Hi,

Have targets of network slicing of COMS/IETF and their concrete 
requirements been already clarified? If they are not clear, I think we 
can't judge whether current WGs' solutions are enough to support 
management on network slices. Why don't we clarify requirements firstly?

Of course, we would be able to refer related works such as L2SM/L3SM or 
OSM for defining service/information models for network slicing.

Thanks,

Shunsuke

On 2017/12/13 18:00, Diego R. Lopez wrote:
> Hi,
> 
> If we focus on connectivity matters, L2SM/L3SM or similar should be 
> enough. If we start thinking about other resources (storage, compute…) I 
> think we’d need something more. As a starting point, we could use the 
> models being defined by the OSM project:
> 
> e-mail: [email-masked] <mailto:[email-masked]>
> 
> Tel:         +34 913 129 041
> 
> Mobile:  +34 682 051 091
> 
> On 13/12/2017, 09:48, "Netslices on behalf of qiangli (D)" 
> <[email-masked] <mailto:[email-masked]> on 
> behalf of [email-masked] <mailto:[email-masked]>> wrote:
> 
> Hi All,
> 
> Do we need a COMS Service Model? Or do you think current L2SM/L3SM/etc. 
> is enough to support the resource-oriented (including connectivity, 
> computing, storage and other potential resources) common management on 
> network slices?
> 
> Best regards,
> 
> Cristina QIANG
> 
> 
> ------------------------------------------------------------------------
> 
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, 
> puede contener información privilegiada o confidencial y es para uso 
> exclusivo de la persona o entidad de destino. Si no es usted. el 
> destinatario indicado, queda notificado de que la lectura, utilización, 
> divulgación y/o copia sin autorización puede estar prohibida en virtud 
> de la legislación vigente. Si ha recibido este mensaje por error, le 
> rogamos que nos lo comunique inmediatamente por esta misma vía y proceda 
> a su destrucción.
> 
> The information contained in this transmission is privileged and 
> confidential information intended only for the use of the individual or 
> entity named above. If the reader of this message is not the intended 
> recipient, you are hereby notified that any dissemination, distribution 
> or copying of this communication is strictly prohibited. If you have 
> received this transmission in error, do not read it. Please immediately 
> reply to the sender that you have received this communication in error 
> and then delete it.
> 
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu 
> destinatário, pode conter informação privilegiada ou confidencial e é 
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa 
> senhoria o destinatário indicado, fica notificado de que a leitura, 
> utilização, divulgação e/ou cópia sem autorização pode estar proibida em 
> virtude da legislação vigente. Se recebeu esta mensagem por erro, 
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e 
> proceda a sua destruição
> 
> 
> _______________________________________________
> Netslices mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netslices
> 

-- 
----------------------------------
Shunsuke Homma
<[email-masked]>
TEL: +81 422 59 3486
FAX: +81 422 60 7460

NTT Network Service Systems Labs.
Musashino city, Tokyo, Japan
----------------------------------

---

From: "qiangli (D)" <[email-masked]>
Date: Thu, 14 Dec 2017 09:15:38 +0000

Hi Shunsuke,

The former email entitled "Summary of Open Issues" is discussing the targets, and charter similar things of COMS. 

Simply speaking, COMS tries to do a resource-centric common management plane upon multiple implementation technologies. We have preliminarily listed 6 potential directions in that email. In addition to these, some technical issues such as how to stitch network slice subnets also have been discussed in COMS. Welcome to reply your opinion under that thread, and help us to enhance it.

Best regards,

Cristina QIANG

-----Original Message-----
From: Shunsuke Homma [mailto:[email-masked]] 
Sent: Wednesday, December 13, 2017 8:48 PM
To: Diego R. Lopez <[email-masked]>; qiangli (D) <[email-masked]>; [email-masked]
Subject: Re: [Netslices] Open Issue II: Service Model

Hi,

Have targets of network slicing of COMS/IETF and their concrete requirements been already clarified? If they are not clear, I think we can't judge whether current WGs' solutions are enough to support management on network slices. Why don't we clarify requirements firstly?

Of course, we would be able to refer related works such as L2SM/L3SM or OSM for defining service/information models for network slicing.

Thanks,

Shunsuke

On 2017/12/13 18:00, Diego R. Lopez wrote:
> enough. If we start thinking about other resources (storage, compute…) 
> I think we’d need something more. As a starting point, we could use 
> the models being defined by the OSM project:
> 
> Este mensaje y sus adjuntos se dirigen exclusivamente a su 
> destinatario, puede contener información privilegiada o confidencial y 
> es para uso exclusivo de la persona o entidad de destino. Si no es 
> usted. el destinatario indicado, queda notificado de que la lectura, 
> utilización, divulgación y/o copia sin autorización puede estar 
> prohibida en virtud de la legislación vigente. Si ha recibido este 
> mensaje por error, le rogamos que nos lo comunique inmediatamente por 
> esta misma vía y proceda a su destrucción.
> 
> confidential information intended only for the use of the individual 
> or entity named above. If the reader of this message is not the 
> intended recipient, you are hereby notified that any dissemination, 
> distribution or copying of this communication is strictly prohibited. 
> If you have received this transmission in error, do not read it. 
> Please immediately reply to the sender that you have received this 
> communication in error and then delete it.
> 
> utilização, divulgação e/ou cópia sem autorização pode estar proibida 
> em virtude da legislação vigente. Se recebeu esta mensagem por erro,

---

From: Shunsuke Homma <[email-masked]>
Date: Fri, 15 Dec 2017 10:59:31 +0900

Hi Christina,

Thank you for your response.

Sorry for confusing you. I meant "targets" are use cases or deployment 
scenarios of network slices. For example, in my understanding, 3GPP is 
focusing on use cases in mobile networks. What use cases is COMS 
considering? (Does the use case draft cover all use cases which 
IETF/COMS should consider?)

Actually, some high level requirements are described in some 
netslicing/coms drafts, but they seem not to be broken down enough to 
judge whether existing technologies can enough support every use case of 
network slicing.

By the way, I'm little bit confused by a word, "common". Do you mean 
that the goal of COMS is providing interfaces for current network 
components? Or defining architecture, information model, and interface 
which can support every network slicing use case?

Regards,

Shunsuke

---

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Mon, 18 Dec 2017 12:46:01 +0000

Hello Shunsuke

"Common" here refers to "common across the multiple implementation technologies".
See more  in https://www.ietf.org/id/draft-geng-coms-problem-statement-01.txt. Figure 2 and 3.

- Hannu

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of Shunsuke Homma
Sent: Friday, December 15, 2017 4:00 AM
To: qiangli (D) <[email-masked]>; Diego R. Lopez <[email-masked]>; [email-masked]
Subject: Re: [Netslices] Open Issue II: Service Model

Hi Christina,

Regards,

Shunsuke

---

From: "qiangli (D)" <[email-masked]>
Date: Mon, 18 Dec 2017 14:23:02 +0000

Hi Shunsuke,

COMS is a concrete topic narrowed from the original NetSlicing, COMS focuses on the scenario/use case that a network slice across multiple technical domains in transport network. The existing use case draft (https://datatracker.ietf.org/doc/draft-netslices-usecases/?include_text=1) studies the whole network slicing use cases rather than COMS only, I think that's why you feel confused. Maybe we can open another thread to discuss whether COMS needs a special use case draft or not. 

"Common" is relative to "distinct" -- "Common" management plane upon "distinct" implementation technologies, which is motivated by operators' requirements. I'm not sure what do you mean by "network components", but In order to support such common management on network slices, some standardization work on architecture/ information model/ interfaces may be necessary IMO.    

Best regards,
	
Cristina QIANG

-----Original Message-----
From: Shunsuke Homma [mailto:[email-masked]] 
Sent: Friday, December 15, 2017 10:00 AM
To: qiangli (D) <[email-masked]>; Diego R. Lopez <[email-masked]>; [email-masked]
Subject: Re: [Netslices] Open Issue II: Service Model

Hi Christina,

Sorry for confusing you. I meant "targets" are use cases or deployment scenarios of network slices. For example, in my understanding, 3GPP is focusing on use cases in mobile networks. What use cases is COMS considering? (Does the use case draft cover all use cases which IETF/COMS should consider?)

Actually, some high level requirements are described in some netslicing/coms drafts, but they seem not to be broken down enough to judge whether existing technologies can enough support every use case of network slicing.

By the way, I'm little bit confused by a word, "common". Do you mean that the goal of COMS is providing interfaces for current network components? Or defining architecture, information model, and interface which can support every network slicing use case?

Regards,

Shunsuke

On 2017/12/14 18:15, qiangli (D) wrote:
> To: Diego R. Lopez <[email-masked]>; qiangli (D) 
> <[email-masked]>; [email-masked]
>> enough. If we start thinking about other resources (storage, 
>> compute…) I think we’d need something more. As a starting point, we 
>> could use the models being defined by the OSM project:
>>
>> computing, storage and other potential resources) common management 
>> on network slices?
>>
>> Best regards,
>>
>> Cristina QIANG
>>
>>
>> ---------------------------------------------------------------------
>> -
>> --
>>
>> destinatario, puede contener información privilegiada o confidencial 
>> y es para uso exclusivo de la persona o entidad de destino. Si no es

---

From: Shunsuke Homma <[email-masked]>
Date: Tue, 19 Dec 2017 20:16:19 +0900

Hi Cristina and Hannu,

Thank you for your answers. I understood the mean of "common", and the 
goal of COMS.

IMHO, at least, we need to consider models for management of vNFs and 
service chains in addition to L2SM/L3SM for making the network slicing 
architecture be more flexible.

As Diego mentioned in the previous email, we would be able to refer the 
models defined in the OSM project for considering VNF management. Also, 
I think that the work on SFC WG would be helpful to define the models 
for service chaining.

Thanks,

Shunsuke

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Wed, 20 Dec 2017 09:03:54 +0900

Dear Homma-san,

I support the idea of integrating COMS within an NFV + SFC ecosystem, in
which all of them would complement to each other. It is the moment to
establish their interrelations and, from my point of view, the help from
the industry, namely vendors and operators, is crucial to ensure that
our outcome would be what the market really needs. Therefore, please let
join together some views or expectations set by such stakeholders of the
mentioned relations, in the form of interfaces and necessary message
exchanges. Thank you very much.

Regards,
Pedro

On Tue, Dec 19, 2017 at 08:16:19PM +0900, Shunsuke Homma wrote:
> Hi Cristina and Hannu,
> 
> Thank you for your answers. I understood the mean of "common", and the goal
> of COMS.
> 
> models defined in the OSM project for considering VNF management. Also, I
> think that the work on SFC WG would be helpful to define the models for
> service chaining.
> 
> Thanks,
> 
> Shunsuke
> 
> 

-- 
Pedro Martinez-Julia
Network Science and Convergence Device Technology Laboratory
Network System Research Institute
National Institute of Information and Communications Technology (NICT)
4-2-1, Nukui-Kitamachi, Koganei, Tokyo 184-8795, Japan
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Wed, 20 Dec 2017 14:21:10 +0000

Hello Shunsuke

I agree that we should also look into SFC aspects. 

Best regards
 Hannu

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of Shunsuke Homma
Sent: Tuesday, December 19, 2017 1:16 PM
To: qiangli (D) <[email-masked]>; Diego R. Lopez <[email-masked]>; [email-masked]; Kiran.Makhijani <[email-masked]>
Subject: Re: [Netslices] Open Issue II: Service Model

Hi Cristina and Hannu,

Thanks,

Shunsuke

---

From: "qiangli (D)" <[email-masked]>
Date: Thu, 21 Dec 2017 09:02:59 +0000

+1

Best regards,

Cristina QIANG

-----Original Message-----
From: Flinck, Hannu (Nokia - FI/Espoo) [mailto:[email-masked]] 
Sent: Wednesday, December 20, 2017 10:21 PM
To: Shunsuke Homma <[email-masked]>; qiangli (D) <[email-masked]>; Diego R. Lopez <[email-masked]>; [email-masked]; Kiran.Makhijani <[email-masked]>
Subject: RE: [Netslices] Open Issue II: Service Model

Hello Shunsuke

Best regards
 Hannu

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of Shunsuke Homma
Sent: Tuesday, December 19, 2017 1:16 PM
To: qiangli (D) <[email-masked]>; Diego R. Lopez <[email-masked]>; [email-masked]; Kiran.Makhijani <[email-masked]>
Subject: Re: [Netslices] Open Issue II: Service Model

Hi Cristina and Hannu,

Thank you for your answers. I understood the mean of "common", and the goal of COMS.

IMHO, at least, we need to consider models for management of vNFs and service chains in addition to L2SM/L3SM for making the network slicing architecture be more flexible.

As Diego mentioned in the previous email, we would be able to refer the models defined in the OSM project for considering VNF management. Also, I think that the work on SFC WG would be helpful to define the models for service chaining.

Thanks,

Shunsuke

On 2017/12/18 23:23, qiangli (D) wrote:
> To: qiangli (D) <[email-masked]>; Diego R. Lopez 
> <[email-masked]>; [email-masked]
>>> mensaje por error, le rogamos que nos lo comunique inmediatamente 
>>> por esta misma vía y proceda a su destrucción.
>>>
>>> destinatário, pode conter informação privilegiada ou confidencial e 
>>> é para uso exclusivo da pessoa ou entidade de destino. Se não é 
>>> vossa senhoria o destinatário indicado, fica notificado de que a 
>>> leitura, utilização, divulgação e/ou cópia sem autorização pode 
>>> estar proibida em virtude da legislação vigente. Se recebeu esta 
>>> mensagem por erro, rogamos-lhe que nos o comunique imediatamente por 
>>> esta mesma via e proceda a sua destruição
>>>
>>>

---

From: Liang GENG <[email-masked]>
Date: Mon, 25 Dec 2017 08:16:01 +0000

Hi all,

It has been the key for netslices/COMS community to consider resources other than just connectivity in the overall model. I think it would be extremely helpful to look at OSM in ETSI and SFC. For example, OSM may be a good reference for COMS information model in VNF respective. And SFC would serve as a base solution for network slice orchestration - it may provide further requirements for COMS.

Best wishes

Liang

________________________________
From: Netslices <[email-masked]> on behalf of qiangli (D) <[email-masked]>
Sent: 21 December 2017 17:02:59
To: Flinck, Hannu (Nokia - FI/Espoo); Shunsuke Homma; Diego R. Lopez; [email-masked]; Kiran.Makhijani
Subject: Re: [Netslices] Open Issue II: Service Model

+1

Best regards,

Cristina QIANG

-----Original Message-----
From: Flinck, Hannu (Nokia - FI/Espoo) [mailto:[email-masked]]
Sent: Wednesday, December 20, 2017 10:21 PM
To: Shunsuke Homma <[email-masked]>; qiangli (D) <[email-masked]>; Diego R. Lopez <[email-masked]>; [email-masked]; Kiran.Makhijani <[email-masked]>
Subject: RE: [Netslices] Open Issue II: Service Model

Hello Shunsuke

Best regards
 Hannu

-----Original Message-----
From: Netslices [mailto:[email-masked]] On Behalf Of Shunsuke Homma
Sent: Tuesday, December 19, 2017 1:16 PM
To: qiangli (D) <[email-masked]>; Diego R. Lopez <[email-masked]>; [email-masked]; Kiran.Makhijani <[email-masked]>
Subject: Re: [Netslices] Open Issue II: Service Model

Hi Cristina and Hannu,

Thanks,

Shunsuke