Subject: Re: [nmrg] IRTF Chair review of draft-irtf-nmrg-ibn-concepts-definitions-05

From: Colin Perkins <[email-masked]>
Date: Fri, 22 Oct 2021 17:17:53 +0100

Hi Jérôme,

Apologies for my slow response. 

The draft is intended as the output of a research group, but the Introduction mentions only how the work relates to standards and developments in industry. Highlighting how the output of a research group might relate to standards activities and the needs of industry is important, of course, but the draft also needs to explain how it relates to research.

That is, how does publishing a document defining these concepts and principles, and the described functionality, relate to, help with, or solve some research questions?

Colin

> On 25 Sep 2021, at 07:19, Jérôme François <[email-masked]> wrote:
> 
> Hi Colin,
> 
> Thanks for your comment. Can you elaborate on the two comments below?
> Especially, do you expect to have more references of recent IBN research regarding the different concepts (as example) or a more detailed "review" of the current research orientations and challenges? In the second case, this will probably change the scope of the draft.
> 
> Best regards
> jerome
> 
>> Comments:
>> 
>> * The structure and focus of the Introduction suggests that this is an IETF document, primarily discussing standards and saying little about the research need for this document. Similarly, there are no conclusions drawn, and no attempt to summarise and relate the work to ongoing research. The definitions and discussion of concepts is good, but the draft needs to better relate it to ongoing research needs and trends.
>> 
>> * Most of the examples are standards-based, and the few that point to research work are to old papers. How does the work relate to current research?

---

From: Colin Perkins <[email-masked]>
Date: Fri, 22 Oct 2021 17:29:47 +0100

Hi,

Right – setting some definitions to create a shared understanding on which to build is entirely reasonable. But – the draft does need to point to some ongoing research and say why defining that understanding is helpful to that research.

Colin

> On 26 Sep 2021, at 00:48, Alexander Clemm <[email-masked]> wrote:
> 
> Hi,
> 
> IMHO I don't think we should be changing the scope of the draft at this point.  The draft specifically states that the articulation of research challenges is outside the scope, which is currently defined as follows: 
> 
>   "This document clarifies the concepts behind intent.  It
>   differentiates intent from related concepts.  It also provides an
>   overview of first-order principles of IBN as well as the associated
>   functionality.  The goal is to contribute to a common and shared
>   understanding that can be used as a foundation to articulate research
>   and engineering problems in the area of IBN.  It should be noted that
>   the articulation of those problems is beyond the scope of this
>   document."
> 
> Assuming the first case applies and the request is to simply present more evidence that IBN is indeed a current topic of ongoing research to underscore the relevance (and for bonus points point to impedance mismatches in the understanding of related concepts), we can certainly add additional references in the next revision.  
> 
> Thanks
> --- Alex
> 
> -----Original Message-----
> From: nmrg <[email-masked]> On Behalf Of Jérôme François
> Sent: Friday, September 24, 2021 11:19 PM
> To: Colin Perkins <[email-masked]>; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [nmrg] IRTF Chair review of draft-irtf-nmrg-ibn-concepts-definitions-05
> 
> Hi Colin,
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 22 Oct 2021 20:37:00 +0200

Colin: Does in your opinion only "research" qualify as references for relevance ?

IMHO, the biggest benefit of this document would be to help the actual industry
(and not other researchers)  to move towards a more sensible nomenclature for Intent.

Including of course IETF with ANIMA WG (and likely other OPS groups doing information
models), which by itself had so far to give up taking next steps on
Intent even though it was in our initial charter, we had to remove it from our current
charter round 2 (for he most part), because the industry is so all over the place
attaching "Intent" with random additional words to whether some marketing people feel will sell more,
that it was impossible to conclude on the first good Intent standardization steps.

As the WG chair for ANIMA i did actually push NMRG a few years back to take
back Intent and work on enough research steps so that ANIMA would ultimately be
able to take back Intent into its charther and standardize. And this concepts definitions
is IMHO the big first helping stone for this, because it would allow to discuss
individual Intent options to take on for possible standardization (aka: helps to
modularize/compartmentalize the solution space).

IMHO, the Introduction section of -05 already captures a lot of what should be
sufficient motivation for this NMRG document work, except that some example
references to various uses of "Intent" in the industry might be useful to
show the confusion and/or the above notion of ANIMA not having been able to
figure out Intent so far and needs this research work output.

Of course, no argument about references to any other research being useful, but
maybe good enough to find some surveys on Intent to reference.  Something
like https://ieeexplore.ieee.org/document/9128422 from 2020 or so..

If any of this makes sense i can try to suggest some additional paragraph
for the introduction with references (after IETF112 deadline ;-).

Cheers
    Toerless

On Fri, Oct 22, 2021 at 05:29:47PM +0100, Colin Perkins wrote:
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg

-- 
---
[email-masked]

---

From: Colin Perkins <[email-masked]>
Date: Tue, 26 Oct 2021 09:54:29 +0100

Toerless,

I’m not so much looking for references, although additional references might be part of the supporting evidence, but for an explanation of how the work relates to research – the Introduction talks about standards and industry, and doesn’t mention research work.

Does the draft build on and synthesise results of prior research? Are the concepts described expected to help organise future research? Is it connected to research in some other way?

I don’t doubt that there’s research work in this area, but the draft needs to show how it connects to that research.

Colin

> On 22 Oct 2021, at 19:37, Toerless Eckert <[email-masked]> wrote:
> 
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 26 Oct 2021 13:03:52 +0200

Thanks, Colin

Personally, i see this work as a proposal for an ontology and taxonomy of
Intent based on examining and coalescing work and concepts from industry, research
and prior standardization known to the authors/RG.

The purpose of course is for this document to be proposed as a linguistic
and organizational framework for future work in research, industry and
standardization, for example to better classify and describe any such work
and to identify adjacencies/dependencies of any such work (given how the
document does describe relationships and interactions).

Not sure if this is the type contextual explanation is what you are looking for.

Maybe more practical using a metphor:

Researchers are working on many isolated Intent trees mostly without understanding
how hey could contribute to an intent forest, Standard bodies (not the IETF, but others ;-)
are declaring various Intent forests without having any idea how to build any such 
forest, and this document explains how an ecosystem of an intent
forest actually does looks like so you can start bring those two together.

Cheers
   Toerlss

-- 
---
[email-masked]