Subject: Re: [nmrg] IRTF Chair review of draft-irtf-nmrg-ibn-concepts-definitions-05

From: Qin Wu <[email-masked]>
Date: Tue, 26 Oct 2021 06:33:24 +0000

Toerless and Colin:
The following academia papers from 2013 to 2018 can be seen as relevant references. Hope this helps.

-Qin
===============================================
[1] R. Cohen, ‘‘An intent-based approach for network virtualization,’’ in Proc.
IFIP/IEEE Int. Symp. Integr. Netw. Manage. (IM), Ghent, Belgium, 2013,
pp. 42–50. 
[2] Y. Han, J. Li, D. Hoang, J. Yoo, and J. W. Hong, ‘‘An intentbased network
virtualization platform for SDN,’’ in Proc. Int. Conf. Netw. Service Manage. 
(CNSM), Montreal, QC, USA, Oct. 2016, pp. 353–358.
[3] M. Pham and D. B. Hoang, ‘‘SDN applications—The intent-based Northbound 
Interface realisation for extended applications,’’ in Proc. IEEE
NetSoft Conf. Workshops (NetSoft), Seoul, South Korea, Jun. 2016,
pp. 372–377.
[4] F. Paganelli, F. Paradiso, M. Gherardelli, and G. Galletti, ‘‘Network service
description model for VNF orchestration leveraging intent-based SDN
interfaces,’’ in Proc. IEEE Conf. Netw. Softwarization (NetSoft), Bologna,
Italy, Jun. 2017, pp. 1–5.
[5] P. Sköldström, S. Junique, A. Ghafoor, A. Marsico, and D. Siracusa,
’’DISMI—An intent interface for application-centric transport network
services,’’ in Proc. Int. Conf. Transparent Opt. Netw. (ICTON), Girona,
Spain, Jul. 2017, pp. 1–4.
[6] F. Callegati, W. Cerroni, C. Contoli, and F. Foresta, ‘‘Performance of 
intentbased virtualized network infrastructure management,’’ in Proc. IEEE Int.
Conf. Commun. (ICC), Paris, France, May 2017, pp. 1–6.
[7] M. Kiran, E. Pouyoul, A. Mercian, B. Tierney, C. Guok, and I. Monga,
‘‘Enabling intent to configure scientific networks for high performance
demands,’’ Future Gener. Comput. Syst., vol. 79, pp. 205–214, Feb. 2018.
[8] A. Mercian, M. Kiran, E. Pouyoul, B. Tierney, and I. Monga, ‘‘INDIRA:
‘Application intent’ network assistant to configure SDN-based high performance 
scientific networks,’’ in Proc. Opt. Fiber Commun. Conf. Exhib.
(OFC), Los Angeles, CA, USA, 2017, pp. 1–3.
[9] D. Schulz, ‘‘Intent-based automation networks: Toward a common reference 
model for the self-orchestration of industrial intranets,’’ in Proc.
Annu. Conf. IEEE Ind. Electron. Soc. (IECON), Florence, Italy, Oct. 2016,
pp. 4657–4664.
[10] E. J. Scheid, C. C. Machado, M. F. Franco, R. L. dos Santos, R. P. Pitscher,
A. E. Schaefer-Filho, and L. Z. Granville, ‘‘INSpIRE: Integrated NFVbased intent 
reinement environment,’’ in Proc. IFIP/IEEE Symp. Integr.
Netw. Service Manage. (IM), May 2017, pp. 186–194.
[11] T. Szyrkowiec, ‘‘Automatic intent-based secure service creation through
a multilayer SDN network orchestration,’’ IEEE/OSA J. Opt. Commun.
Netw., vol. 10, no. 4, pp. 289–297, Apr. 2018.
[12] B. T. Saha, D. Tandur, L. Haab, and L. Podleski, ‘‘Intent-based networks:
An industrial perspective,’’ in Proc. 1st Int. Workshop Future Ind. Commun. Netw. 
(FICN), 2018, pp. 35–40.
[13] D. Comer and A. Rastegatnia, ‘‘OSDF: An intent-based software defined
network programming framework,’’ in Proc. IEEE 43rd Conf. Local Comput. Netw. (LCN), 
Chicago, IL, USA, Oct. 2018, pp. 527–535.
[14] V. Heorhiadi, S. Chandrasekaran, M. K. Reiter, and V. Sekar, ‘‘Intentdriven 
composition of resource-management SDN applications,’’ in
Proc. 14th Int. Conf. Emerg. Netw. Exp. Technol. (CoNEXT), 2018,
pp. 86–97.
[15] B. Lewis, L. Fawcett, M. Broadbent, and N. Race, ‘‘Using P4
to enable scalable intents in software defined networks,’’ in Proc.
IEEE 26th Int. Conf. Netw. Protocols (ICNP), Cambridge, Sep. 2018,
pp. 442–443.
[16] A. Marsico, ‘‘An interactive intent-based negotiation scheme for
application-centric networks,’’ in Proc. IEEE Conf. Netw. Softwarization
(NetSoft), Bologna, Italy, Jul. 2017, pp. 1–2.
[17] Y. Tsuzaki and Y. Okabe, ‘‘Reactive configuration updating for IntentBased 
Networking,’’ in Proc. Int. Conf. Inf. Netw. (ICOIN), Da Nang,
Vietnam, 2017, pp. 97–102.
[18] A. S. Jacobs, ‘‘Deploying natural language intents with Lumi,’’ in Proc.
SIGCOMM Posters Demos ACM Conf. Posters Demos (SIGCOMM),
Beijing, China, 2019, pp. 82–84.
[19] Y. Elkhatib, G. Coulson, and G. Tyson, ‘‘Charting an intent driven network,’’ 
in Proc. Int. Conf. Netw. Service Manage. (CNSM), Tokyo, Japan,
Nov. 2017, pp. 1–5.
[20] A. S. Jacobs, ‘‘Refining network intents for self-driving networks,’’
in Proc. Afternoon Workshop Self-Driving Netw. (SelfDN), Budapest,
Hungary, Jan. 2018, pp. 15–21.
[21] H. Zhang, Y. Wang, X. Qi, W. Xu, T. Peng, and S. Liu, ‘‘Demo abstract:
An intent solver for enabling intent-based SDN,’’ in Proc. IEEE Conf.
Comput. Commun. Workshops (INFOCOM WKSHPS), Atlanta, GA, USA,
May 2017, pp. 968–969.
[22] A. Abhashkumar, J. Kang, S. Banerjee, A. Akella, Y. Zhang, and W. F. Wu,
,’’Supporting diverse dynamic intent-based policies using Janus,’’ in Proc.
13th Int. Conf. Emerg. Netw. Exp. Technol. (CoNEXT), Incheon, South
Korea, 2017, pp. 296–309.
[23] S. Arezoumand, K. Dzeparoska, H. Bannazadeh, and A. Leon-Garcia,
,’’MD-IDN: Multi-domain intent-driven networking in software-defined
infrastructures,’’ in Proc. Int. Conf. Netw. Service Manage. (CNSM),
Tokyo, Japan, 2017, pp. 1–7.
[24] D. Sanvito, D. Moro, M. Gullì, I. Filippini, A. Capone, and A. Campanella,
,’’Enabling external routing logic in ONOS with intent monitor and reroute
service,’’ in Proc. IEEE Conf. Netw. Softwarization Workshops (NetSoft),
Montreal, QC, Canada, Jun. 2018, pp. 332–334.
[25] R. A. Addad, D. L. C. Dutra, M. Bagaa, T. Taleb, H. Flinck, and
M. Namane, ‘‘Benchmarking the ONOS intent interfaces to ease 5G service 
management,’’ in Proc. IEEE Global Commun. Conf. (GLOBECOM),
Abu Dhabi, United Arab Emirates, Dec. 2018, pp. 1–6.
[26] T. Subramanya, R. Riggio, and T. Rasheed, ‘‘Intent-based mobile 
backhauling for 5G networks,’’ in Proc. Int. Conf. Netw. Service Manage.
(CNSM), Montreal, QC, Canada, 2016, pp. 348–352.
[27] F. Aklamanu, S. Randriamasy, E. Renault, I. Latif, and A. Hebbar, ‘‘Intent 
based real-time 5G cloud service provisioning,’’ in Proc. IEEE Globecom
Workshops (GC Wkshps), Abu Dhabi, United Arab Emirates, Dec. 2018,
pp. 1–6.
[28] M. Odini and A. Krichel, ‘‘Intent based modelling key to 5G & ZSM,’’ in
Proc. IEEE Softwarization, 2018, pp. 1–6.
[29] W. Cerroni, ‘‘Intent-based management and orchestration of heterogeneous 
openflow/IoT SDN domains,’’ in Proc. IEEE Conf. Netw. Softwarization (NetSoft), 
Bologna, Italy, Jul. 2017, pp. 1–9.
[30] W. Cerroni, ‘‘Intent-based service management for heterogeneous
software-defined infrastructure domains,’’ in Proc. IEEE NetSoft Special
Issue: Softwarization Sustaining Hyper-Connected World: En Route to 5G,
2018, vol. 29, no. 1, pp. 1–22.
[31] J. Kang, J. Lee, V. Nagendra, and S. Banerjee, ‘‘LMS: Label management 
service for intent-driven cloud management,’’ in Proc. IFIP/IEEE
Symp. Integr. Netw. Service Manage. (IM), Lisbon, Portugal, May 2017,
pp. 177–185.
[32] W. Chao and S. Horiuchi, ‘‘Intent-based cloud service management,’’ in
Proc. 21st Conf. Innov. Clouds, Internet Netw. Workshops (ICIN), Paris,
France, Feb. 2018, pp. 1–5.
======================================================
-----邮件原件-----
发件人: nmrg [mailto:[email-masked]] 代表 Toerless Eckert
发送时间: 2021年10月23日 2:37
收件人: Colin Perkins <[email-masked]>
抄送: [email-masked]; [email-masked]; [email-masked]
主题: Re: [nmrg] IRTF Chair review of draft-irtf-nmrg-ibn-concepts-definitions-05

Colin: Does in your opinion only "research" qualify as references for relevance ?

IMHO, the biggest benefit of this document would be to help the actual industry (and not other researchers)  to move towards a more sensible nomenclature for Intent.

Including of course IETF with ANIMA WG (and likely other OPS groups doing information models), which by itself had so far to give up taking next steps on Intent even though it was in our initial charter, we had to remove it from our current charter round 2 (for he most part), because the industry is so all over the place attaching "Intent" with random additional words to whether some marketing people feel will sell more, that it was impossible to conclude on the first good Intent standardization steps.

As the WG chair for ANIMA i did actually push NMRG a few years back to take back Intent and work on enough research steps so that ANIMA would ultimately be able to take back Intent into its charther and standardize. And this concepts definitions is IMHO the big first helping stone for this, because it would allow to discuss individual Intent options to take on for possible standardization (aka: helps to modularize/compartmentalize the solution space).

IMHO, the Introduction section of -05 already captures a lot of what should be sufficient motivation for this NMRG document work, except that some example references to various uses of "Intent" in the industry might be useful to show the confusion and/or the above notion of ANIMA not having been able to figure out Intent so far and needs this research work output.

Of course, no argument about references to any other research being useful, but maybe good enough to find some surveys on Intent to reference.  Something like https://ieeexplore.ieee.org/document/9128422 from 2020 or so..

If any of this makes sense i can try to suggest some additional paragraph for the introduction with references (after IETF112 deadline ;-).

Cheers
    Toerless

On Fri, Oct 22, 2021 at 05:29:47PM +0100, Colin Perkins wrote:
> Hi,
> 
> Right – setting some definitions to create a shared understanding on which to build is entirely reasonable. But – the draft does need to point to some ongoing research and say why defining that understanding is helpful to that research.
> 
> Colin
> 
> 
> 
> > On 26 Sep 2021, at 00:48, Alexander Clemm <[email-masked]> wrote:
> > 
> > Hi,
> > 
> > IMHO I don't think we should be changing the scope of the draft at this point.  The draft specifically states that the articulation of research challenges is outside the scope, which is currently defined as follows: 
> > 
> >   "This document clarifies the concepts behind intent.  It
> >   differentiates intent from related concepts.  It also provides an
> >   overview of first-order principles of IBN as well as the associated
> >   functionality.  The goal is to contribute to a common and shared
> >   understanding that can be used as a foundation to articulate research
> >   and engineering problems in the area of IBN.  It should be noted that
> >   the articulation of those problems is beyond the scope of this
> >   document."
> > 
> > Assuming the first case applies and the request is to simply present more evidence that IBN is indeed a current topic of ongoing research to underscore the relevance (and for bonus points point to impedance mismatches in the understanding of related concepts), we can certainly add additional references in the next revision.  
> > 
> > Thanks
> > --- Alex
> > 
> > -----Original Message-----
> > From: nmrg <[email-masked]> On Behalf Of Jérôme François
> > Sent: Friday, September 24, 2021 11:19 PM
> > To: Colin Perkins <[email-masked]>; 
> > [email-masked]
> > Cc: [email-masked]; [email-masked]
> > Subject: Re: [nmrg] IRTF Chair review of 
> > draft-irtf-nmrg-ibn-concepts-definitions-05
> > 
> > Hi Colin,
> > 
> > Thanks for your comment. Can you elaborate on the two comments below?
> > Especially, do you expect to have more references of recent IBN research regarding the different concepts (as example) or a more detailed "review" of the current research orientations and challenges? In the second case, this will probably change the scope of the draft.
> > 
> > Best regards
> > jerome
> > 
> >> Comments:
> >> 
> >> * The structure and focus of the Introduction suggests that this is an IETF document, primarily discussing standards and saying little about the research need for this document. Similarly, there are no conclusions drawn, and no attempt to summarise and relate the work to ongoing research. The definitions and discussion of concepts is good, but the draft needs to better relate it to ongoing research needs and trends.
> >> 
> >> * Most of the examples are standards-based, and the few that point to research work are to old papers. How does the work relate to current research?
> >> 
> 
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg

--
---
[email-masked]

_______________________________________________
nmrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nmrg

---

From: Colin Perkins <[email-masked]>
Date: Tue, 26 Oct 2021 09:54:38 +0100

Hi,

My concern was not so much to add references – as you show, it’s straight-forward to find considerable work on the topic – but to show how the draft is relevant to the research community.

Colin

> On 26 Oct 2021, at 07:33, Qin Wu <[email-masked]> wrote:
> 
> Toerless and Colin:
> 发件人: nmrg [mailto:[email-masked] <mailto:[email-masked]>] 代表 Toerless Eckert
> 发送时间: 2021年10月23日 2:37
> 收件人: Colin Perkins <[email-masked] <mailto:[email-masked]>>
> 抄送: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> Of course, no argument about references to any other research being useful, but maybe good enough to find some surveys on Intent to reference.  Something like https://ieeexplore.ieee.org/document/9128422 <https://ieeexplore.ieee.org/document/9128422> from 2020 or so..
> 
>> https://www.irtf.org/mailman/listinfo/nmrg <https://www.irtf.org/mailman/listinfo/nmrg>
> 
> --
> ---
> [email-masked] <mailto:[email-masked]>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/nmrg <https://www.irtf.org/mailman/listinfo/nmrg>

-- 
Colin Perkins
https://csperkins.org/

---

From: Alexander Clemm <[email-masked]>
Date: Tue, 26 Oct 2021 19:17:17 +0000

Hi Qin, 

Thank you for the comprehensive list.  

Hi Toerless, Colin, all, 

We will post a draft with updated text shortly. IMHO the role of this draft is not to provide a survey of academic work, but we will add evidence that this is a topic that is of interest to the research community, but without a common established set of foundational concepts and definitions.  

Best
--- Alex

-----Original Message-----
From: nmrg <[email-masked]> On Behalf Of Qin Wu
Sent: Monday, October 25, 2021 11:33 PM
To: Toerless Eckert <[email-masked]>; Colin Perkins <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [nmrg] IRTF Chair review of draft-irtf-nmrg-ibn-concepts-definitions-05

Toerless and Colin:

-Qin
===============================================
[1] R. Cohen, ‘‘An intent-based approach for network virtualization,’’ in Proc.
IFIP/IEEE Int. Symp. Integr. Netw. Manage. (IM), Ghent, Belgium, 2013, pp. 42–50. 
[2] Y. Han, J. Li, D. Hoang, J. Yoo, and J. W. Hong, ‘‘An intentbased network virtualization platform for SDN,’’ in Proc. Int. Conf. Netw. Service Manage. 
(CNSM), Montreal, QC, USA, Oct. 2016, pp. 353–358.
[3] M. Pham and D. B. Hoang, ‘‘SDN applications—The intent-based Northbound Interface realisation for extended applications,’’ in Proc. IEEE NetSoft Conf. Workshops (NetSoft), Seoul, South Korea, Jun. 2016, pp. 372–377.
[4] F. Paganelli, F. Paradiso, M. Gherardelli, and G. Galletti, ‘‘Network service description model for VNF orchestration leveraging intent-based SDN interfaces,’’ in Proc. IEEE Conf. Netw. Softwarization (NetSoft), Bologna, Italy, Jun. 2017, pp. 1–5.
[5] P. Sköldström, S. Junique, A. Ghafoor, A. Marsico, and D. Siracusa, ’’DISMI—An intent interface for application-centric transport network services,’’ in Proc. Int. Conf. Transparent Opt. Netw. (ICTON), Girona, Spain, Jul. 2017, pp. 1–4.
[6] F. Callegati, W. Cerroni, C. Contoli, and F. Foresta, ‘‘Performance of intentbased virtualized network infrastructure management,’’ in Proc. IEEE Int.
Conf. Commun. (ICC), Paris, France, May 2017, pp. 1–6.
[7] M. Kiran, E. Pouyoul, A. Mercian, B. Tierney, C. Guok, and I. Monga, ‘‘Enabling intent to configure scientific networks for high performance demands,’’ Future Gener. Comput. Syst., vol. 79, pp. 205–214, Feb. 2018.
[8] A. Mercian, M. Kiran, E. Pouyoul, B. Tierney, and I. Monga, ‘‘INDIRA:
‘Application intent’ network assistant to configure SDN-based high performance scientific networks,’’ in Proc. Opt. Fiber Commun. Conf. Exhib.
(OFC), Los Angeles, CA, USA, 2017, pp. 1–3.
[9] D. Schulz, ‘‘Intent-based automation networks: Toward a common reference model for the self-orchestration of industrial intranets,’’ in Proc.
Annu. Conf. IEEE Ind. Electron. Soc. (IECON), Florence, Italy, Oct. 2016, pp. 4657–4664.
[10] E. J. Scheid, C. C. Machado, M. F. Franco, R. L. dos Santos, R. P. Pitscher, A. E. Schaefer-Filho, and L. Z. Granville, ‘‘INSpIRE: Integrated NFVbased intent reinement environment,’’ in Proc. IFIP/IEEE Symp. Integr.
Netw. Service Manage. (IM), May 2017, pp. 186–194.
[11] T. Szyrkowiec, ‘‘Automatic intent-based secure service creation through a multilayer SDN network orchestration,’’ IEEE/OSA J. Opt. Commun.
Netw., vol. 10, no. 4, pp. 289–297, Apr. 2018.
[12] B. T. Saha, D. Tandur, L. Haab, and L. Podleski, ‘‘Intent-based networks:
An industrial perspective,’’ in Proc. 1st Int. Workshop Future Ind. Commun. Netw. 
(FICN), 2018, pp. 35–40.
[13] D. Comer and A. Rastegatnia, ‘‘OSDF: An intent-based software defined network programming framework,’’ in Proc. IEEE 43rd Conf. Local Comput. Netw. (LCN), Chicago, IL, USA, Oct. 2018, pp. 527–535.
[14] V. Heorhiadi, S. Chandrasekaran, M. K. Reiter, and V. Sekar, ‘‘Intentdriven composition of resource-management SDN applications,’’ in Proc. 14th Int. Conf. Emerg. Netw. Exp. Technol. (CoNEXT), 2018, pp. 86–97.
[15] B. Lewis, L. Fawcett, M. Broadbent, and N. Race, ‘‘Using P4 to enable scalable intents in software defined networks,’’ in Proc.
IEEE 26th Int. Conf. Netw. Protocols (ICNP), Cambridge, Sep. 2018, pp. 442–443.
[16] A. Marsico, ‘‘An interactive intent-based negotiation scheme for application-centric networks,’’ in Proc. IEEE Conf. Netw. Softwarization (NetSoft), Bologna, Italy, Jul. 2017, pp. 1–2.
[17] Y. Tsuzaki and Y. Okabe, ‘‘Reactive configuration updating for IntentBased Networking,’’ in Proc. Int. Conf. Inf. Netw. (ICOIN), Da Nang, Vietnam, 2017, pp. 97–102.
[18] A. S. Jacobs, ‘‘Deploying natural language intents with Lumi,’’ in Proc.
SIGCOMM Posters Demos ACM Conf. Posters Demos (SIGCOMM), Beijing, China, 2019, pp. 82–84.
[19] Y. Elkhatib, G. Coulson, and G. Tyson, ‘‘Charting an intent driven network,’’ 
in Proc. Int. Conf. Netw. Service Manage. (CNSM), Tokyo, Japan, Nov. 2017, pp. 1–5.
[20] A. S. Jacobs, ‘‘Refining network intents for self-driving networks,’’
in Proc. Afternoon Workshop Self-Driving Netw. (SelfDN), Budapest, Hungary, Jan. 2018, pp. 15–21.
[21] H. Zhang, Y. Wang, X. Qi, W. Xu, T. Peng, and S. Liu, ‘‘Demo abstract:
An intent solver for enabling intent-based SDN,’’ in Proc. IEEE Conf.
Comput. Commun. Workshops (INFOCOM WKSHPS), Atlanta, GA, USA, May 2017, pp. 968–969.
[22] A. Abhashkumar, J. Kang, S. Banerjee, A. Akella, Y. Zhang, and W. F. Wu, ,’’Supporting diverse dynamic intent-based policies using Janus,’’ in Proc.
13th Int. Conf. Emerg. Netw. Exp. Technol. (CoNEXT), Incheon, South Korea, 2017, pp. 296–309.
[23] S. Arezoumand, K. Dzeparoska, H. Bannazadeh, and A. Leon-Garcia,
,’’MD-IDN: Multi-domain intent-driven networking in software-defined infrastructures,’’ in Proc. Int. Conf. Netw. Service Manage. (CNSM), Tokyo, Japan, 2017, pp. 1–7.
[24] D. Sanvito, D. Moro, M. Gullì, I. Filippini, A. Capone, and A. Campanella, ,’’Enabling external routing logic in ONOS with intent monitor and reroute service,’’ in Proc. IEEE Conf. Netw. Softwarization Workshops (NetSoft), Montreal, QC, Canada, Jun. 2018, pp. 332–334.
[25] R. A. Addad, D. L. C. Dutra, M. Bagaa, T. Taleb, H. Flinck, and M. Namane, ‘‘Benchmarking the ONOS intent interfaces to ease 5G service management,’’ in Proc. IEEE Global Commun. Conf. (GLOBECOM), Abu Dhabi, United Arab Emirates, Dec. 2018, pp. 1–6.
[26] T. Subramanya, R. Riggio, and T. Rasheed, ‘‘Intent-based mobile backhauling for 5G networks,’’ in Proc. Int. Conf. Netw. Service Manage.
(CNSM), Montreal, QC, Canada, 2016, pp. 348–352.
[27] F. Aklamanu, S. Randriamasy, E. Renault, I. Latif, and A. Hebbar, ‘‘Intent based real-time 5G cloud service provisioning,’’ in Proc. IEEE Globecom Workshops (GC Wkshps), Abu Dhabi, United Arab Emirates, Dec. 2018, pp. 1–6.
[28] M. Odini and A. Krichel, ‘‘Intent based modelling key to 5G & ZSM,’’ in Proc. IEEE Softwarization, 2018, pp. 1–6.
[29] W. Cerroni, ‘‘Intent-based management and orchestration of heterogeneous openflow/IoT SDN domains,’’ in Proc. IEEE Conf. Netw. Softwarization (NetSoft), Bologna, Italy, Jul. 2017, pp. 1–9.
[30] W. Cerroni, ‘‘Intent-based service management for heterogeneous software-defined infrastructure domains,’’ in Proc. IEEE NetSoft Special
Issue: Softwarization Sustaining Hyper-Connected World: En Route to 5G, 2018, vol. 29, no. 1, pp. 1–22.
[31] J. Kang, J. Lee, V. Nagendra, and S. Banerjee, ‘‘LMS: Label management service for intent-driven cloud management,’’ in Proc. IFIP/IEEE Symp. Integr. Netw. Service Manage. (IM), Lisbon, Portugal, May 2017, pp. 177–185.
[32] W. Chao and S. Horiuchi, ‘‘Intent-based cloud service management,’’ in Proc. 21st Conf. Innov. Clouds, Internet Netw. Workshops (ICIN), Paris, France, Feb. 2018, pp. 1–5.
======================================================
-----邮件原件-----
发件人: nmrg [mailto:[email-masked]] 代表 Toerless Eckert
发送时间: 2021年10月23日 2:37
收件人: Colin Perkins <[email-masked]>
抄送: [email-masked]; [email-masked]; [email-masked]
主题: Re: [nmrg] IRTF Chair review of draft-irtf-nmrg-ibn-concepts-definitions-05

Of course, no argument about references to any other research being useful, but maybe good enough to find some surveys on Intent to reference.  Something like https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fieeexplore.ieee.org%2Fdocument%2F9128422&amp;data=04%7C01%7Calex%40futurewei.com%7C4e90a6c147dd47cc957608d9984a8c5a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637708268251097142%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Wfhy7iigUsQsb8gUqpZbLy%2Fa6xnxwxUFOYOyfaBjpGY%3D&amp;reserved=0 from 2020 or so..

Cheers
    Toerless

On Fri, Oct 22, 2021 at 05:29:47PM +0100, Colin Perkins wrote:
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> irtf.org%2Fmailman%2Flistinfo%2Fnmrg&amp;data=04%7C01%7Calex%40futurew
> ei.com%7C4e90a6c147dd47cc957608d9984a8c5a%7C0fee8ff2a3b240189c753a1d55
> 91fedc%7C1%7C1%7C637708268251097142%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC
> 4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sd
> ata=xbqjjV2WnAWapYWNSXd%2F%2B5yLybpLlTuk%2BmV5fXYLpeI%3D&amp;reserved=
> 0

--
---
[email-masked]

_______________________________________________
nmrg mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Fnmrg&amp;data=04%7C01%7Calex%40futurewei.com%7C4e90a6c147dd47cc957608d9984a8c5a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637708268251097142%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=xbqjjV2WnAWapYWNSXd%2F%2B5yLybpLlTuk%2BmV5fXYLpeI%3D&amp;reserved=0
_______________________________________________
nmrg mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Fnmrg&amp;data=04%7C01%7Calex%40futurewei.com%7C4e90a6c147dd47cc957608d9984a8c5a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637708268251097142%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=xbqjjV2WnAWapYWNSXd%2F%2B5yLybpLlTuk%2BmV5fXYLpeI%3D&amp;reserved=0