Subject: [nmrg] Review comments on "draft-irtf-nmrg-ibn-intent-classification-05"

From: "JEF" <[email-masked]>
Date: Tue, 7 Dec 2021 09:59:03 +0800

Hi,

I reviewed the draft as a member of IRSG, and below are my comments.

1. It seems that the section 6 is the main contribution from this document, which provides a methodology for classification (in figure 1) , an intent taxonomy (figure 2) and detailed classifications&nbsp;with examples&nbsp;for 3 “solutions” (Carrier, Data Centre, Enterprise networks). This part is written in a very clear way and the content is also helpful at least to me. If this is the main objective of the document, it is achieved very well. Thanks to the authors!

2.&nbsp;But the abstract does't emphasize or focus on this main contribution in my reading, and the sections before Section 6 created some confusion to me. My general feeling after reading the whole document was: why not show me the Section 6 directly :)&nbsp;

When I read it back again, I think maybe the confusion comes from the positioning of section 4 and section 5. Section 4 has a title “abstract intent requirement” and section 5: “functional characteristics and behaviour”. &nbsp;When I read them at the first time, I thought these two sections aimed to discuss some advanced technical designs in an Intent-based system. 

Only after reading Section 6, I realised that the discussion in Section 4 and 5 is following the sequence of steps in figure 1 in Section 6: “intent solution(4.2)”, “intent user types(4.2 and 5.2)", "type of intent(4.4)”, “intent scope(5.3)”, network intent scope(5.4), different intent abstraction(5.5), intent life-cycle(5.6), etc.&nbsp; So maybe it confused me because of the existing of the other subsections: 4.1(what is intent), 4.3(benefit of intents), 5.1(abstracting intent operation), 5.7(autonomous driving levels).

This can be just my personal feeling, maybe it is not necessary to significantly change the structure of this document. But I can't help thinking that, if the main purpose of these two sections are preparing the readers for section 6 (otherwise the focus of this document is lost), maybe they can be organised in a more straightforward way.

3. The discussion in 4.1(what is intent),&nbsp;4.3(benefit of intents) can be more brief. Well, frankly speaking, I personally think they are not necessary in this document. These two issues are "non-trivial", I feel any detailed discussion in this document may create inconsistence with the [Clemm] (the concept&amp;definition document) now or in future versions. We'd better lead the readers to [Clemm] &nbsp;if they are serious about these two issues.&nbsp;

4. The subsection&nbsp;5.1 (abstracting intent operation): I have no technical comments on the content, but it has no connection to the sections before and doesn't contribute to the section 6?

5. The subsection 5.7(autonomous driving levels) seems strange to me. Why does it belong to the section 5 “functional characteristics and behaviour"? 

6. Some more editorial comments:
(1) The "abstract": "intent management system” should be kept consistent with [clemm]: intent-based management system?
(2) page 2: the expire time is not correct, should be "May 10, 2022"?
(3) page3, page 49: should “table of contents” and “author’s addresses” start a new page? I see many drafts don't.
(4) page4 (introduction): last paragraph should be placed at the end of the “abstract”, especially the last sentence: “published for informational purposes”? And, should it be expressed as "The document is sponsored under the IRTF and is not issued&nbsp;by the IETF and is not an IETF standard"?
(5) “reference”: the order of references should not be random.
(6) “reference”: if this document is informational, shall all the references to be “informative references”? no “normative references”?
(7) &nbsp;inconsistence of terms: &nbsp;“Intent-driven networks” at the beginning of section 1, "Intent-based networking" at the beginning of subsection 1.
(8) the second paragraph on page 5: “The document describes…”, means “This document”? The 3rd paragraph on page 5:&nbsp;“IEEE-CNOM”, should have a full name or a link?&nbsp;
(9)&nbsp;subsection 4.4, the format of “types” is unclear, what’s the relationship between those “for” and the type above it. The format implies that each “for” is a sub-type (low level types) in my view. But under the last item “intents that affect other..”, there are some explanations.&nbsp;
(10) page 14: there is “for device replacements”. So I guess “for server replacements”, should be “for service replacements”? “server” is a type of “device”.

(11) page 21: item 5, there is two “then”.

Best,

Jeffrey

Original

From:"Colin Perkins"< [email-masked] &gt;;

Date:2021/12/7 3:58

To:"iMac"< [email-masked] &gt;;

CC:"Internet Research Steering Group"< [email-masked] &gt;;

Subject:Re: Comments on &nbsp;"draft-irtf-nmrg-ibn-intent-classification-05"

Hi Jeffrey,
Thank you for the review! Could you please also send your review comments to the document authors and NMRG mailing list?
Regards,
Colin

On 4 Dec 2021, at 15:52, JEF <[email-masked]&gt; wrote:

Hi IRSG and Colin,

Below are my comments on this draft.

1. It seems that the section 6 is the main contribution from this document, which provides a methodology for classification (in figure 1) , an intent taxonomy (figure 2) and detailed classifications with examples&nbsp;for 3 “solutions” (Carrier, Data Centre, Enterprise networks). This part is written in a very clear way and the content is also helpful at least to me. If this is the main objective of the document, it is achieved very well. Thanks to the authors!

2.&nbsp;But the abstract does't emphasize or focus on this main contribution in my reading, and the sections before Section 6 created some confusion to me. My general feeling after reading the whole document was: why not show me the Section 6 directly :)&nbsp;

When I read it back again, I think maybe the confusion comes from the positioning of section 4 and section 5. Section 4 has a title “abstract intent requirement” and section 5: “functional characteristics and behaviour”. &nbsp;When I read them at the first time, I thought these two sections aimed to discuss some advanced technical designs in an Intent-based system. 

Only after reading Section 6, I realised that the discussion in Section 4 and 5 is following the sequence of steps in figure 1 in Section 6: “intent solution(4.2)”, “intent user types(4.2 and 5.2)", "type of intent(4.4)”, “intent scope(5.3)”, network intent scope(5.4), different intent abstraction(5.5), intent life-cycle(5.6), etc.&nbsp; So maybe it confused me because of the existing of the other subsections: 4.1(what is intent), 4.3(benefit of intents), 5.1(abstracting intent operation), 5.7(autonomous driving levels).

This can be just my personal feeling, maybe it is not necessary to significantly change the structure of this document. But I can't help thinking that, if the main purpose of these two sections are preparing the readers for section 6 (otherwise the focus of this document is lost), maybe they can be organised in a more straightforward way.

3. The discussion in 4.1(what is intent), 4.3(benefit of intents) can be more brief. Well, frankly speaking, I personally think they are not necessary in this document. These two issues are "non-trivial", I feel any detailed discussion in this document may create inconsistence with the [Clemm] (the concept&amp;definition document) now or in future versions. We'd better lead the readers to [Clemm] &nbsp;if they are serious about these two issues.&nbsp;

4. The subsection&nbsp;5.1 (abstracting intent operation): I have no technical comments on the content, but it has no connection to the sections before and doesn't contribute to the section 6?

5. The subsection 5.7(autonomous driving levels) seems strange to me. Why does it belong to the section 5 “functional characteristics and behaviour"? 

6. Some more editorial comments:
(1) The "abstract": "intent management system” should be kept consistent with [clemm]: intent-based management system?
(2) page 2: the expire time is not correct, should be "May 10, 2022"?
(3) page3, page 49: should “table of contents” and “author’s addresses” start a new page? I see many drafts don't.
(4) page4 (introduction): last paragraph should be placed at the end of the “abstract”, especially the last sentence: “published for informational purposes”? And, should it be expressed as "The document is sponsored under the IRTF and is not issued&nbsp;by the IETF and is not an IETF standard"?
(5) “reference”: the order of references should not be random.
(6) “reference”: if this document is informational, shall all the references to be “informative references”? no “normative references”?
(7) &nbsp;inconsistence of terms: &nbsp;“Intent-driven networks” at the beginning of section 1, "Intent-based networking" at the beginning of subsection 1.
(8) the second paragraph on page 5: “The document describes…”, means “This document”? The 3rd paragraph on page 5:&nbsp;“IEEE-CNOM”, should have a full name or a link?&nbsp;
(9)&nbsp;subsection 4.4, the format of “types” is unclear, what’s the relationship between those “for” and the type above it. The format implies that each “for” is a sub-type (low level types) in my view. But under the last item “intents that affect other..”, there are some explanations.&nbsp;
(10) page 14: there is “for device replacements”. So I guess “for server replacements”, should be “for service replacements”? “server” is a type of “device”.

(11) page 21: item 5, there is two “then”.

Best,

Jeffrey

Original

From:"Colin Perkins"< [email-masked] &gt;;

Date:2021/12/2 6:51

To:"iMac"< [email-masked] &gt;;

CC:"Internet Research Steering Group"< [email-masked] &gt;;

Subject:Re: [irsg] IRSG review requestdraft-irtf-nmrg-ibn-intent-classification-05

Thank you, Jeffrey!
Colin

On 23 Nov 2021, at 14:32, JEF <[email-masked]&gt; wrote:

Hi Colin,
I can review this draft. I'll try to complete it before the end of next week.
Best,
Jeffrey
------------------&nbsp;Original&nbsp;------------------
From: &nbsp;"Colin Perkins";<[email-masked]&gt;;
Send time:&nbsp;Friday, Nov 19, 2021 8:34 PM
To:&nbsp;"Internet Research Steering Group"<[email-masked]&gt;;
Subject: &nbsp;[irsg] IRSG review request draft-irtf-nmrg-ibn-intent-classification-05

IRSG members,

The NMRG has requested that draft-irtf-nmrg-ibn-intent-classification-05 be considered for publication as an IRTF RFC. To progress this draft, we now need at least one IRSG member to volunteer to provide a detailed review of the draft, as follows:

&gt; The purpose of the IRSG review is to ensure consistent editorial and technical quality for IRTF publications. IRSG review is not a deep technical review. (This should take place within the RG.) At least one IRSG member other than the chair of the RG bringing the work forth must review the document and the RG's editorial process.
&gt; 
&gt; IRSG reviewers should look for clear, cogent, and consistent writing. An important aspect of the review is to gain a critical reading from reviewers who are not subject matter experts and, in the process, assure the document will be accessible to those beyond the authoring research group. Also, reviewers should assess whether sufficient editorial and technical review has been conducted and the requirements of this process document, such as those described in IRTF-RFCs have been met. Finally, reviewers should check that appropriate citations to related research literature have been made.
&gt; 
&gt; Reviews should be written to be public. Review comments should be sent to the IRSG and RG mailing lists and entered into the tracker. All IRSG review comments must be addressed. However, the RG need not accept every comment. It is the responsibility of the shepherd to understand the comments and ensure that the RG considers them including adequate dialog between the reviewer and the author and/or RG. Reviews and their resolution should be entered into the tracker by the document shepherd.
&gt; 
&gt; The IRSG review often results in the document being revised. Once the reviewer(s), authors, and shepherd have converged on review comments, the shepherd starts the IRSG Poll on whether the document should be published.

Please respond to this message if you’re able to perform such a review, and indicate the approximate time-frame by which you’ll be able to complete it. The document shepherd write-up is available at https://datatracker.ietf.org/doc/draft-irtf-nmrg-ibn-intent-classification/shepherdwriteup/ 

Thanks,
Colin

---

From: Olga Havel <[email-masked]>
Date: Tue, 7 Dec 2021 17:55:24 +0000

Hi Jeffrey,

Thank you for your review. We’ll go through your comments and get back to you.

Best Regards,
Olga

From: JEF [mailto:[email-masked]]
Sent: Tuesday 7 December 2021 01:59
To: Colin Perkins <[email-masked]>; nmrg <[email-masked]>; lichen.bri <[email-masked]>; Olga Havel <[email-masked]>; Adriana Olariu <[email-masked]>; pedro <[email-masked]>; jcnobre <[email-masked]>; diego.r.lopez <[email-masked]>
Cc: Internet Research Steering Group <[email-masked]>
Subject: Review comments on "draft-irtf-nmrg-ibn-intent-classification-05"

Hi,
I reviewed the draft as a member of IRSG, and below are my comments.
1. It seems that the section 6 is the main contribution from this document, which provides a methodology for classification (in figure 1) , an intent taxonomy (figure 2) and detailed classifications with examples for 3 “solutions” (Carrier, Data Centre, Enterprise networks). This part is written in a very clear way and the content is also helpful at least to me. If this is the main objective of the document, it is achieved very well. Thanks to the authors!
2. But the abstract does't emphasize or focus on this main contribution in my reading, and the sections before Section 6 created some confusion to me. My general feeling after reading the whole document was: why not show me the Section 6 directly :)
When I read it back again, I think maybe the confusion comes from the positioning of section 4 and section 5. Section 4 has a title “abstract intent requirement” and section 5: “functional characteristics and behaviour”.  When I read them at the first time, I thought these two sections aimed to discuss some advanced technical designs in an Intent-based system.
Only after reading Section 6, I realised that the discussion in Section 4 and 5 is following the sequence of steps in figure 1 in Section 6: “intent solution(4.2)”, “intent user types(4.2 and 5.2)", "type of intent(4.4)”, “intent scope(5.3)”, network intent scope(5.4), different intent abstraction(5.5), intent life-cycle(5.6), etc.  So maybe it confused me because of the existing of the other subsections: 4.1(what is intent), 4.3(benefit of intents), 5.1(abstracting intent operation), 5.7(autonomous driving levels).
This can be just my personal feeling, maybe it is not necessary to significantly change the structure of this document. But I can't help thinking that, if the main purpose of these two sections are preparing the readers for section 6 (otherwise the focus of this document is lost), maybe they can be organised in a more straightforward way.
3. The discussion in 4.1(what is intent), 4.3(benefit of intents) can be more brief. Well, frankly speaking, I personally think they are not necessary in this document. These two issues are "non-trivial", I feel any detailed discussion in this document may create inconsistence with the [Clemm] (the concept&definition document) now or in future versions. We'd better lead the readers to [Clemm]  if they are serious about these two issues.
4. The subsection 5.1 (abstracting intent operation): I have no technical comments on the content, but it has no connection to the sections before and doesn't contribute to the section 6?
5. The subsection 5.7(autonomous driving levels) seems strange to me. Why does it belong to the section 5 “functional characteristics and behaviour"?
6. Some more editorial comments:
(1) The "abstract": "intent management system” should be kept consistent with [clemm]: intent-based management system?
(2) page 2: the expire time is not correct, should be "May 10, 2022"?
(3) page3, page 49: should “table of contents” and “author’s addresses” start a new page? I see many drafts don't.
(4) page4 (introduction): last paragraph should be placed at the end of the “abstract”, especially the last sentence: “published for informational purposes”? And, should it be expressed as "The document is sponsored under the IRTF and is not issued by the IETF and is not an IETF standard"?
(5) “reference”: the order of references should not be random.
(6) “reference”: if this document is informational, shall all the references to be “informative references”? no “normative references”?
(7)  inconsistence of terms:  “Intent-driven networks” at the beginning of section 1, "Intent-based networking" at the beginning of subsection 1.
(8) the second paragraph on page 5: “The document describes…”, means “This document”? The 3rd paragraph on page 5: “IEEE-CNOM”, should have a full name or a link?
(9) subsection 4.4, the format of “types” is unclear, what’s the relationship between those “for” and the type above it. The format implies that each “for” is a sub-type (low level types) in my view. But under the last item “intents that affect other..”, there are some explanations.
(10) page 14: there is “for device replacements”. So I guess “for server replacements”, should be “for service replacements”? “server” is a type of “device”.
(11) page 21: item 5, there is two “then”.

Best,
Jeffrey

Original

From:"Colin Perkins"< [email-masked]<mailto:[email-masked]> >;

Date:2021/12/7 3:58

To:"iMac"< [email-masked]<mailto:[email-masked]> >;

CC:"Internet Research Steering Group"< [email-masked]<mailto:[email-masked]> >;

Subject:Re: Comments on  "draft-irtf-nmrg-ibn-intent-classification-05"

Hi Jeffrey,

On 4 Dec 2021, at 15:52, JEF <[email-masked]<mailto:[email-masked]>> wrote:

Hi IRSG and Colin,
Below are my comments on this draft.
1. It seems that the section 6 is the main contribution from this document, which provides a methodology for classification (in figure 1) , an intent taxonomy (figure 2) and detailed classifications with examples for 3 “solutions” (Carrier, Data Centre, Enterprise networks). This part is written in a very clear way and the content is also helpful at least to me. If this is the main objective of the document, it is achieved very well. Thanks to the authors!
2. But the abstract does't emphasize or focus on this main contribution in my reading, and the sections before Section 6 created some confusion to me. My general feeling after reading the whole document was: why not show me the Section 6 directly :)
When I read it back again, I think maybe the confusion comes from the positioning of section 4 and section 5. Section 4 has a title “abstract intent requirement” and section 5: “functional characteristics and behaviour”.  When I read them at the first time, I thought these two sections aimed to discuss some advanced technical designs in an Intent-based system.
Only after reading Section 6, I realised that the discussion in Section 4 and 5 is following the sequence of steps in figure 1 in Section 6: “intent solution(4.2)”, “intent user types(4.2 and 5.2)", "type of intent(4.4)”, “intent scope(5.3)”, network intent scope(5.4), different intent abstraction(5.5), intent life-cycle(5.6), etc.  So maybe it confused me because of the existing of the other subsections: 4.1(what is intent), 4.3(benefit of intents), 5.1(abstracting intent operation), 5.7(autonomous driving levels).
This can be just my personal feeling, maybe it is not necessary to significantly change the structure of this document. But I can't help thinking that, if the main purpose of these two sections are preparing the readers for section 6 (otherwise the focus of this document is lost), maybe they can be organised in a more straightforward way.
3. The discussion in 4.1(what is intent), 4.3(benefit of intents) can be more brief. Well, frankly speaking, I personally think they are not necessary in this document. These two issues are "non-trivial", I feel any detailed discussion in this document may create inconsistence with the [Clemm] (the concept&definition document) now or in future versions. We'd better lead the readers to [Clemm]  if they are serious about these two issues.
4. The subsection 5.1 (abstracting intent operation): I have no technical comments on the content, but it has no connection to the sections before and doesn't contribute to the section 6?
5. The subsection 5.7(autonomous driving levels) seems strange to me. Why does it belong to the section 5 “functional characteristics and behaviour"?
6. Some more editorial comments:
(1) The "abstract": "intent management system” should be kept consistent with [clemm]: intent-based management system?
(2) page 2: the expire time is not correct, should be "May 10, 2022"?
(3) page3, page 49: should “table of contents” and “author’s addresses” start a new page? I see many drafts don't.
(4) page4 (introduction): last paragraph should be placed at the end of the “abstract”, especially the last sentence: “published for informational purposes”? And, should it be expressed as "The document is sponsored under the IRTF and is not issued by the IETF and is not an IETF standard"?
(5) “reference”: the order of references should not be random.
(6) “reference”: if this document is informational, shall all the references to be “informative references”? no “normative references”?
(7)  inconsistence of terms:  “Intent-driven networks” at the beginning of section 1, "Intent-based networking" at the beginning of subsection 1.
(8) the second paragraph on page 5: “The document describes…”, means “This document”? The 3rd paragraph on page 5: “IEEE-CNOM”, should have a full name or a link?
(9) subsection 4.4, the format of “types” is unclear, what’s the relationship between those “for” and the type above it. The format implies that each “for” is a sub-type (low level types) in my view. But under the last item “intents that affect other..”, there are some explanations.
(10) page 14: there is “for device replacements”. So I guess “for server replacements”, should be “for service replacements”? “server” is a type of “device”.
(11) page 21: item 5, there is two “then”.

Best,
Jeffrey

Original
From:"Colin Perkins"< [email-masked]<mailto:[email-masked]> >;
Date:2021/12/2 6:51
To:"iMac"< [email-masked]<mailto:[email-masked]> >;
CC:"Internet Research Steering Group"< [email-masked]<mailto:[email-masked]> >;
Subject:Re: [irsg] IRSG review requestdraft-irtf-nmrg-ibn-intent-classification-05

Thank you, Jeffrey!
Colin

On 23 Nov 2021, at 14:32, JEF <[email-masked]<http://undefined/>> wrote:

Hi Colin,
------------------ Original ------------------
From:  "Colin Perkins";<[email-masked]<http://undefined/>>;
Send time: Friday, Nov 19, 2021 8:34 PM
To: "Internet Research Steering Group"<[email-masked]<http://undefined/>>;
Subject:  [irsg] IRSG review request draft-irtf-nmrg-ibn-intent-classification-05
IRSG members,

The NMRG has requested that draft-irtf-nmrg-ibn-intent-classification-05 be considered for publication as an IRTF RFC. To progress this draft, we now need at least one IRSG member to volunteer to provide a detailed review of the draft, as follows:

> The purpose of the IRSG review is to ensure consistent editorial and technical quality for IRTF publications. IRSG review is not a deep technical review. (This should take place within the RG.) At least one IRSG member other than the chair of the RG bringing the work forth must review the document and the RG's editorial process.
>
> IRSG reviewers should look for clear, cogent, and consistent writing. An important aspect of the review is to gain a critical reading from reviewers who are not subject matter experts and, in the process, assure the document will be accessible to those beyond the authoring research group. Also, reviewers should assess whether sufficient editorial and technical review has been conducted and the requirements of this process document, such as those described in IRTF-RFCs have been met. Finally, reviewers should check that appropriate citations to related research literature have been made.
>
> Reviews should be written to be public. Review comments should be sent to the IRSG and RG mailing lists and entered into the tracker. All IRSG review comments must be addressed. However, the RG need not accept every comment. It is the responsibility of the shepherd to understand the comments and ensure that the RG considers them including adequate dialog between the reviewer and the author and/or RG. Reviews and their resolution should be entered into the tracker by the document shepherd.
>
> The IRSG review often results in the document being revised. Once the reviewer(s), authors, and shepherd have converged on review comments, the shepherd starts the IRSG Poll on whether the document should be published.

Please respond to this message if you’re able to perform such a review, and indicate the approximate time-frame by which you’ll be able to complete it. The document shepherd write-up is available at https://datatracker.ietf.org/doc/draft-irtf-nmrg-ibn-intent-classification/shepherdwriteup/<http://undefined/>

Thanks,
Colin