Subject: Re: [nmrg] call for adoption as RG document : draft-zhou-nmrg-digitaltwin-network-concepts

From: Qin Wu <[email-masked]>
Date: Wed, 5 Jan 2022 09:37:21 +0000

Hi, Luis:
I believe your assumption is correct, we need to replicate such centralized control plane capabilities directly on top of the twined network elements.  In the current document, the digital twin entity management has already played such role.
Yes, we could allow other options, e.g.,

1.       replicate such centralized control plane and integrated into digital twin entity management,

2.       Introduce twined centralized control plane and integrated into digital twin layer;
but I am afraid that both options add a lot of complexity to the architecture design. For the second option, it add confusion about the relation between twined control plane element and digital twin entity management.
Hope this clarifies, thanks.

-Qin
发件人: LUIS MIGUEL CONTRERAS MURILLO [mailto:[email-masked]]
发送时间: 2022年1月5日 16:36
收件人: Qin Wu <[email-masked]>; Ciavaglia, Laurent <laurent.ciavaglia=[email-masked]>; [email-masked]
抄送: [email-masked]; Cheng Zhou <[email-masked]>
主题: RE: call for adoption as RG document : draft-zhou-nmrg-digitaltwin-network-concepts

Hi Qin,

Thanks so much for your clarifications. Just two further questions/clarifications in the last two topics, which are related.

I understand from your answer that DT focus basically on the network elements, including forwarding and control capabilities. And leaving apart any kind of twining of any centralized (i.e., SDN-like) control element. That’s clear.

Then I suppose that you can directly replicate such centralized (i.e., SDN-like) control plane capabilities directly on top of the twined network elements, and connect on top of it the applications in a similar way that you would do in a production network. Thus you are twining the network elements and replicating the central control capabilities to operate/manage such network elements.

Is this assumption correct? If so, then everything is totally clear to me now.

Thanks

Luis

De: Qin Wu <[email-masked]<mailto:[email-masked]>>
Enviado el: miércoles, 5 de enero de 2022 5:12
Para: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]<mailto:[email-masked]>>; Ciavaglia, Laurent <laurent.ciavaglia=[email-masked]<mailto:laurent.ciavaglia=[email-masked]>>; [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>; Cheng Zhou <[email-masked]<mailto:[email-masked]>>
Asunto: RE: call for adoption as RG document : draft-zhou-nmrg-digitaltwin-network-concepts

Hi, Luis:
Thank for valuable comments and input, please see reply inline below
发件人: nmrg [mailto:[email-masked]] 代表 LUIS MIGUEL CONTRERAS MURILLO
发送时间: 2021年12月27日 19:11
收件人: Ciavaglia, Laurent <laurent.ciavaglia=[email-masked]<mailto:laurent.ciavaglia=[email-masked]>>; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>
主题: Re: [nmrg] call for adoption as RG document : draft-zhou-nmrg-digitaltwin-network-concepts

Dear Laurent, all,

After reading the draft I support its adoption as RG document.

In respect to the points you raise, here are my views:

1.       NMRG being a *research* group it is important to articulate well the problem(s), challenge(s) and research questions.
This document clearly address a very relevant research topic which is the definition of network digital twin, as well as it proposes an initial architecture. In my view it is well stated, despite some aspects could be better clarified, as stated below when answering point 3.

2.       Is the scientific soundness of the draft satisfying? (quality of the scientific proposition, rigor of the method, impact) ; “the measure of success is the quality and impact of the research results” [RFC2014]
I think so.

3.       As the document proposes an *architecture*, it is important to provide a clear scope and positioning of this architecture with respect to network management/automation/operation frameworks and where/how the proposed architecture will prove useful or aims at replacing/augmenting certain functionality
With respect to the propose architecture, I think it is a good proposition. However, I think some points need better clarification:

-          In page 5, in the first paragraph after the bullets it is mentioned that it is expected the DT to control the physical network. This is also reflected in the architecture figure by means of an specific control interface from the DT to the physical network. I think this control capability should be better explained, including scope, situations for that, etc. Is this control expected to happen with/without supervision? Is it directly interacting with the physical network elements, through a control element (maybe with some associated policies), etc?
[Qin Wu] Good comments, If we need to specify control plane capability in details, I think probably we could reuse all the existing control plane mechanisms such as BGP, PCEP, NETCONF,IGP, etc, yes, control plane associated policy also can be leveraged, e.g., introduce Policy decision point and Policy enforcement point in the twin layer and network element layer respectively, or delegated policy to the network element and allow the network element have self management capability. Regarding Supervisory control , if my understanding is correct, it is more designed for process control, e.g., Robotics applications, it may require human to get involved, intervenes to modify the control algorithm in some way. Or some process in the physical element can accept instructions, carried it out autonomously. But I am not sure this is focused use case in this document, the idea is to apply digital twin concept widely adopted in industry application to network fields. Talking with our coauthors, we think this document should more focus on build and maintain twins. Therefore control capability specification is not high priority task, we will get back to this after we complete twins building and maintenance task. Hope this address your comments, thanks.

-          After Figure 2, when describing options for physical networks, a number of non-IETF networks are enumerated. Not sure if we should limit the scope to IETF technologies in this sense, since those are the ones that the research of IRTF can influence directly.
[Qin Wu] Agree, we should focus on IETF networks that the research of IRTF can influence directly.

-          When referring to base and functional models it would be nice to refer to existing IETF models that could exemplify the purpose of the DT architecture. This would help to understand the areas of future work, as well.
[Qin Wu] That is a very good suggestions, we could refer to various network topology models, inventory models, OAM models (such as LIME models), alarm models as examples to discuss how these models are put together to build and maintain twin. In addition, I am thinking we should exclude other modeling technology, such as knowledge graph, to build network digital models. But we probably need to refer to some other modeling technology defined in other SDO,e.g., RDF defined inW3C.

-          The architecture assumes a DT management entity, but the responsibilities of this entity are both: (1) managing the emulated nodes and (2) manage the overall DT. It would be probably better to separate these two roles on independent entities.

[Qin Wu] Good comment, I also see there is confusion whether entity management cover both responsibilities, maybe the root cause of confusion comes from the naming “Digital Twin Entity Management”, maybe we should change the name of “Digital Twin Entity Management” into “digital twin network management”, we will discuss how to address your comments, thanks.

-          It is not clear if the physical network in the architecture contains both network elements and the control and managing entities acting on those elements. I assume yes, but some explicit statement in that respect would be beneficial.
[Qin Wu] At this stage, we assume each network element should contain both forwarding element and local control/management elements, we model such network element as one digital twin entity. For SDN controller which manage or control all the network elements, we haven’t consider to model them in the digital twin layer, if you have any valid use case, please let us know.

-          The architecture assumes applications on top of the DT that could provide conventional OAM actions. This implies in my view the need of emulating as well the different NMSs/SDN controllers of the physical network that could be in place since the expectation would be to have similar integration in both the DT and the physical network. Is this the expectation in the draft?
[Qin Wu] I think these application are same applications built on top SDN controller in traditional SDN architecture, these application can be network visibility applications, network troubleshooting application, it doesn’t need to be another layer of NMS or SDN controllers, We want to leave this out scope of this document and just focus on how to build and maintain digital twins, make sense?
Best regards,

Luis

De: nmrg <[email-masked]<mailto:[email-masked]>> En nombre de Ciavaglia, Laurent
Enviado el: viernes, 10 de diciembre de 2021 13:02
Para: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>
Asunto: [nmrg] call for adoption as RG document : draft-zhou-nmrg-digitaltwin-network-concepts

Dear NMRG,

This message starts the call for adoption as RG document for:
Digital Twin Network: Concepts and Reference Architecture - draft-zhou-nmrg-digitaltwin-network-concepts
https://datatracker.ietf.org/doc/draft-zhou-nmrg-digitaltwin-network-concepts/

Please let us know if you support or not the work becoming a RG document.
In all cases, provide detailed comments to support your opinion and send them on the mailing list.
We are particularly interested in assessing the following aspects:
1.       NMRG being a *research* group it is important to articulate well the problem(s), challenge(s) and research questions.
2.       Is the scientific soundness of the draft satisfying? (quality of the scientific proposition, rigor of the method, impact) ; “the measure of success is the quality and impact of the research results” [RFC2014]
3.       As the document proposes an *architecture*, it is important to provide a clear scope and positioning of this architecture with respect to network management/automation/operation frameworks and where/how the proposed architecture will prove useful or aims at replacing/augmenting certain functionality

The procedure for RG document adoption and important criteria are detailed here: https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU

Given the time of the year, this call for adoption is open for four weeks and ends on January 7th, 2022.

Best regards, NMRG chairs
Laurent & Jérôme

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Wed, 5 Jan 2022 10:53:41 +0000

Hi Qin,

Yes, clear to me.

Best regards

Luis

De: Qin Wu <[email-masked]>
Enviado el: miércoles, 5 de enero de 2022 10:37
Para: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>; Ciavaglia, Laurent <laurent.ciavaglia=[email-masked]>; [email-masked]
CC: [email-masked]; Cheng Zhou <[email-masked]>
Asunto: RE: call for adoption as RG document : draft-zhou-nmrg-digitaltwin-network-concepts

Hi, Luis:

-Qin
发件人: LUIS MIGUEL CONTRERAS MURILLO [mailto:[email-masked]]
发送时间: 2022年1月5日 16:36
收件人: Qin Wu <[email-masked]<mailto:[email-masked]>>; Ciavaglia, Laurent <laurent.ciavaglia=[email-masked]<mailto:laurent.ciavaglia=[email-masked]>>; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; Cheng Zhou <[email-masked]<mailto:[email-masked]>>
主题: RE: call for adoption as RG document : draft-zhou-nmrg-digitaltwin-network-concepts

Hi Qin,

Thanks

Luis

Hi, Luis:

Dear Laurent, all,

Luis

Dear NMRG,