Subject: Re: [nmrg] Asking for feedback on a proposal for including compute and data awareness as part of a broad SDN architecture

From: "Diego R. Lopez" <[email-masked]>
Date: Mon, 14 Feb 2022 16:36:56 +0000

Hi Luis,

I know I come to this horribly late, but other urgent matters did not allow me to take care of this interesting proposal. So let me share a few reflections, in the hope it is not too late…

I believe this can open an interesting reflection on the flows related to the application of AI to network management and control, though there is a need to consider all the potential flows. And these include not only the data in the closed loop (monitoring/telemetry from network to AI, and action/control from AI to network), but as well the flows related to AI behavior (policies/intents, from network admins towards the AI, and explanations, from AI to network adminas), and the flows facilitating the cooperation among AIs (we can talk of knowledge sharing among different segments, and knowledge aggregation at different levels, or strata, of control). I believe all these data should share a common, model-based, approach, and define a recursive structure that could become a generalization of the CLAS model.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Mobile:  +34 682 051 091
----------------------------------

On 27/01/2022, 09:51, "nmrg on behalf of CARLOS JESUS BERNARDOS CANO" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi Luis, group,

Apologies for the late feedback.

I think your proposition of extending CLAS makes a lot of sense. I'm personally involved in several projects that explore somehow what you are proposing in terms of extending the resource layer/plane with a compute stratum, so the network can be programmed consistently in an integrated way. This is also very relevant, IMO, if we go to network architectures that extend to the very extreme edge, incorporating UE/CPE devices. The point of monitoring is also very relevant, and I can just reference for example 5Growth EU project as an example of architecture where this type of extension would be very useful.

Enabling the management of multiple (a lot) heterogeneous domains in a so-called "frictionless" way which also natively incorporates AI is one of the themes very much highlighted in the upcoming EU project proposal calls, which I guess many from this group would be familiar with. I think the proposal you make of exploring extending CLAS goes very well into this direction and I personally believe it's worth exploring in IRTF.

My two cents,

Carlos

On Mon, Jan 3, 2022 at 11:56 AM LUIS MIGUEL CONTRERAS MURILLO <[email-masked]<mailto:[email-masked]>> wrote:
Dear group,

Hope this mail finds all you well, and let wish all you a great 2022.

I prepared a draft for IETF112 that could not be presented at that time. The document, draft-contreras-nmrg-clas-evolution-00 (https://www.ietf.org/archive/id/draft-contreras-nmrg-clas-evolution-00.txt), augments a previous SDN architecture proposition (described in RFC8597, which was primarily adopted in the extinct SDNRG and then released as ISE document) by introducing two new aspects:

.- on one hand, the augmented architecture considers control, management and resource plane dimensions for compute capabilities, framed in a Compute Stratum which interoperates with the previously defined Service and Network (previously referred as Transport) Strata. The objective of this augmentation is to consider an integrated management of the more and more commonly deployed computing facilities in operational networks (cloud, edge, etc) which require a tighter integration with the network providing the connectivity of such environments.

.- on the other hand, the augmented architecture considers a new dimension related to the handling of data (e.g., telemetry, monitoring, etc) that can feed Artificial    Intelligence (AI) and Machine Learning (ML) capabilities assisting on closed loop automation processes, by defining a new Learning Plane associated to the other three aforementioned planes. The objective of this augmentation is to complement the control and management procedures with this new concern related to data that can act at different strata (and timescales), but interacting and interchanging among strata.

The intended final research objective and value proposition of the draft is the formalization of a comprehensive architecture supporting recent advances on overall management procedures, that could permit a further investigation on forms (e.g. APIs) to allow the interaction among strata. While I think this fits on the purpose of NMRG, I would like to collect feedback from the group about if this approach makes sense for the group and if there is interest to develop these ideas further.

Thanks in advance

Best regards

Luis

__________________________________
Luis M. Contreras

Transport & IP Networks
Systems and Network Global Direction
Telefónica I+D / CTIO unit / Telefónica

Distrito Telefónica, Edificio Sur 3, Planta 3
28050 Madrid
España / Spain

Mobile: +34 680 947 650
[email-masked]<mailto:[email-masked]>

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
_______________________________________________
nmrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nmrg

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is confidential and privileged information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Ciavaglia, Laurent" <[email-masked]>
Date: Fri, 25 Feb 2022 15:56:42 +0000

Dear Luis, Carlos, Diego and all,

In order to assess where this discussion and proposal could lead us, we have assigned a slot in the next NMRG session @ IETF 113.
We welcome a presentation from interested participants to expose the research questions and directions and open a debate on what NMRG, as a research group/forum, could do.
Please note that the time allocated will depend on how we run with the previous topics.

Side question from me: do you see or have already identified links or overlap with the scope of the work done in the COIN research group? (e.g. “including compute […])

Thank you.
Best regards, Laurent & Jérôme

From: nmrg <[email-masked]> On Behalf Of Diego R. Lopez
Sent: Monday, February 14, 2022 05:37 PM
To: CARLOS JESUS BERNARDOS CANO <[email-masked]>; LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Cc: [email-masked]
Subject: Re: [nmrg] Asking for feedback on a proposal for including compute and data awareness as part of a broad SDN architecture

[EXTERNAL] This message comes from an external organization.
Hi Luis,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi Luis, group,

My two cents,

Carlos

Thanks in advance

Best regards

Luis

Transport & IP Networks

Mobile: +34 680 947 650

---

From: "Diego R. Lopez" <[email-masked]>
Date: Sat, 26 Feb 2022 18:29:45 +0000

Hi Laurent,

In my view, the boundary would lie on two aspects: the perspective on the architecture and the application environment for the AI(s).

In the first case, if we focus on how the architecture has to be applied to identify the elements applicable to OAM of data-driven applications (whatever their purpose) , we are in NMRG territory, and we will be in the COIN environment when analyzing how to apply this to support seamless computing-in-the-network.

When it comes to the application environment, if the main focus is on network operations, and we are referring essentially to forwarding and aggregating YANG-based data flows I’d say we will be in the NMRG realm. If the goal is to provide a general network service, usable by any application and supporting a general data-enabled infrastructure, we would be entering the COIN country.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

On 25/02/2022, 16:56, "Ciavaglia, Laurent" <[email-masked]<mailto:[email-masked]>> wrote:

Thank you.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi Luis, group,

My two cents,

Carlos

Thanks in advance

Best regards

Luis

Transport & IP Networks

Mobile: +34 680 947 650