Subject: [nmrg] NMRG@IETF113: Discussions on network digital twins

From: Jérôme François <[email-masked]>
Date: Thu, 17 Mar 2022 20:37:50 +0100

Hi all,

In our meeting next week, one slot is dedicated to Reflections on Network Digital 
Twin research.
A set of questions you can already think about has been prepared and will support 
our discussions. They are at the end of the meeting notes 
(https://notes.ietf.org/notes-ietf-113-nmrg?view) and copied below for your 
convenience.

Please do not hesitate to propose other questions or provide already some answers.

Cheers,
Jérôme and Laurent,
NOMS co-chairs

**Preparatory question for Reflections on Network Digital Twin research**

Global questions:

1. There seems to be a "gap" in the definition(s) of what a *network* digital twin 
is. The key point here being the *network* dimension. This discussion/question is 
linked to the relationship between the physical network/infrastructure and its 
digital twin/representation: what parts of a network / networking infrastructure / 
devices are represented in a network digital twin? – without imposing a limiting 
definition in the answer.

2. Can we have a network digital twin  without digital twins of 
services/applications/users running on top of it? If no, is the digital twin a 
global concept that must encompass multiple levels?

3. What are the expected the benefits of using digital twins (for industry AND 
academia)?

4.  What are the research questions for digital twins which differs from more 
common approaches (like simulation, virtualization, emulation) that already 
attempt to address scalability and accuracy issues (to model real systems).

5. Is the major difference a close coupling between the real system and a modeled 
system? For example, can a simulation model can be fed with real data? In that 
case are the questions focused on how to enable such interactions rather than 
building new models to "simulate" the original network?

6. For challenges: what are some of the major aspects impacting the development of 
network digital twins: is it on scalability, granularity… ? (cf. link with your 
question on currently available data/metrics collection)

More concrete questions on enabling techniques:

7. Do we have metrics and measurement to evaluate the accuracy/fidelity of a 
digital twin? If no, what could be some orientations in regards to that?

8. How to test some operations on digital twins while still being synchronized 
with the original twin? How to return back a digital twin to a clean state in a 
soft manner?

9. What are the models (theoretical and experimental) that could be used to define 
a digital twin?

10. For enablers: clarify the role of some (fundamental) techniques/technologies 
for digital twins such as AI, what are other key enabling techniques/technologies 
essential to building and operating digital twins?

11. What is the gap between data we can already collect (regarding configuration 
or operation data) and what is necessary to build a digital twin network? Is the 
problem to acquire more data, more useful data or or filter all data we already have?

12. What would be the interoperability and federation needs for twins across 
network segments, actors, and technologies : what techniques, models for 
harmonization, (data and control) fusion and mappings, etc.

---

From: Qin Wu <[email-masked]>
Date: Fri, 18 Mar 2022 14:55:09 +0000

Jerome:
Good questions, let me share some of my own thoughts, hope it help the discussion.
-----邮件原件-----
发件人: nmrg [mailto:[email-masked]] 代表 Jér?me Fran?ois
发送时间: 2022年3月18日 3:38
收件人: [email-masked]
抄送: [email-masked]
主题: [nmrg] NMRG@IETF113: Discussions on network digital twins

Hi all,

In our meeting next week, one slot is dedicated to Reflections on Network Digital Twin research.
A set of questions you can already think about has been prepared and will support our discussions. They are at the end of the meeting notes
(https://notes.ietf.org/notes-ietf-113-nmrg?view) and copied below for your convenience.

Cheers,
Jérôme and Laurent,
NOMS co-chairs

Global questions:

1. There seems to be a "gap" in the definition(s) of what a *network* digital twin is. The key point here being the *network* dimension. This discussion/question is linked to the relationship between the physical network/infrastructure and its digital twin/representation: what parts of a network / networking infrastructure / devices are represented in a network digital twin? – without imposing a limiting definition in the answer.

[Qin Wu] Good question, I think the idea of this work is to borrow digital twin concept adopted in industry 4.0 into communication network such as enterprise network, provider network, maybe IoT network or industry IoT network should also be in the scope. But at the current stage, we leave this out.
Taking provider network as an example, I think all the router, switches, link between routers or switches in the provider network should be modelled, which can be formulated as network topology. In addition, the service flows travel through the network infrastructure can also be modelled. Therefore network digital twin encompasses three parts: 1)physical network which comprise physical network elements, link between them, 2)virtual twin network which comprises super node, super links,  3)mapping between physical world and virtual twin world. Unlike digital twin used in industry 4.0 which only allow one to one mapping between physical object and virtual object, network digital twin supports many to many mapping.

2. Can we have a network digital twin  without digital twins of services/applications/users running on top of it? If no, is the digital twin a global concept that must encompass multiple levels?

[Qin Wu] digital twins of service, application, user or human are modelled as part of digital twin network world, I see this as metaverse. I am not sure we can expand scope to model them, this is open question. We can think about it.
Even without digital twins of service/application/users, I think network digital twins can still hold, you can build digital twin network on top of physical network, also you can build another multiple digital twin networks on top of existing digital twin network, which forms layered or multi-level digital twin networks. We can have many network applications built on top of digital twin network platform such as network visibility application, network configuration application, network troubleshooting application.
Does this make sense?

3. What are the expected the benefits of using digital twins (for industry AND academia)?

[Qin Wu] I think the big benefit is to fix vulnerabilities in software and configuration and greatly reduce trial costs before moving software
and configuration to the real production network.

[Qin Wu] The big questions are how to use digital twin network platform to understand, predict, diagnose and optimize
the behavior/health of the physical network, what modelling technology or languages we plan to use?
How to enable physical network and twin network co-evolve.

5. Is the major difference a close coupling between the real system and a modeled 
system? For example, can a simulation model can be fed with real data? In that 
case are the questions focused on how to enable such interactions rather than 
building new models to "simulate" the original network?
[Qin Wu] Tend to agree, real time interaction is the key. Not only just provide network visibility by simulating the original network,
but also predict behavior or state changes of the physical network, optimize to make sure they are in best performance.

[Qin Wu] Besides scalability, granularity, I think we should also consider modelling precision to achieve high-confidence prediction,
data uncertainty is another aspect, e.g., data missing, measurement accuracy, different receiving or sending rate, privacy protection, etc.

[Qin Wu] I think we can consider fidelity level. but this require more discussion, I believe.

[Qin Wu] In my understanding, this rely on real time interaction between digital twin and original twin.
Return back a digital twin to a clean state rely on telemetry, synchronized with the orignal twin
rely on the policy control.

[Qin Wu] I think YANG data model, knowledge graph, AI training models, etc can be used.

[Qin Wu] I think modelling technology is the key, besides modelling techniques, we also
need to consider communication technology, computation technologies, to secure data exchanges
between physical network and digital twin network or between twin networks, maybe block chain 
should also be considered. But it seems heavy weight in some sense but nice to have.

[Qin Wu] I think one of the gaps is how fast and effective you can process the data, explore useful data.

[Qin Wu] 
it looks the answer is embedded in the your question, i think one of technique is data fusion technique to build single source of truth. Reasoning on Knowledge graph should also be used.
_______________________________________________
nmrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nmrg