Subject: Re: [nmrg] call for adoption as RG document: draft-yang-nmrg-network-measurement-intent

From: Qin Wu <[email-masked]>
Date: Sun, 3 Apr 2022 09:11:50 +0000

Hi,
I have read the latest version of draft-yang-nmrg-network-measurement-intent and have the following comments:
1. As described in section 6, the network measurement intent is break down into static NMI and Dynamic NMI. Unfortunately I fail to see the key difference between Static NMI and Dynamic NMI? I can see in most cases, it will be static NMI, which can be seen as SLO or SLA requirements requested by the customer. Are dynamic NMI more related to real time network performance measurement which is actually not the intent?

2.Is combination of active and passive measurement are hybrid measurement? How these three type measurements are related to measurement intent? How active measurement work together with passive measurement?

3. When you say "For example, if the transmission frequency of
   active measurement message is too fast, it will occupy too much
   bandwidth resources and affect the normal operation of actual
   business.  While if the transmission frequency is too slow, some instantaneous network anomalies will be missed and the network status cannot be accurately reflected." It looks to me that it also related to adaptive subscription discussed in NETCONF WG (https://datatracker.ietf.org/doc/html/draft-wang-netconf-adaptive-subscription-09)? No?

4. Regarding executable measurement policy such as the transmission frequency of active measurement in section 5.1, I think is highly related to draft-wang-netconf-adaptive-subscription, since it allows client to configure policy on the server and enable the server switch from one frequency of measurement to another frequency, I suggest you refer to this draft.

5. Regarding the interaction between NMI pre-verification module and NMI compliance assessment, I am not sure whether modify the execution time of the policy is the only way to adjust the NMI policy. It seems in most cases, when the policy is configured,
it will be executed forever unless you revoke the policy or change the policy parameters, No?

6. How SLA measurement intent in section 5.1 is different from Clustered performance measurement intent in section 5.2? My impression is SLA measurement intent focus on latency measurement, the technique used is adaptive telemetry while Clustered performance measurement intent is focusing on packet loss measurement and the technique used is clustering mechanism.
From: Jérôme François<mailto:[email-masked]>
Date: 2022-03-17 17:51
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>; draft-yang-nmrg-network-measurement-intent<mailto:[email-masked]>
Subject: [nmrg] call for adoption as RG document: draft-yang-nmrg-network-measurement-intent
Dear NMRG,

This message starts the call for adoption as RG document for:
Network measurement intent - one of IBN use cases
https://datatracker.ietf.org/doc/draft-yang-nmrg-network-measurement-intent/

Please note that this call for adoption is independent of the poll recently sent about the choice between a single or multiple for all use cases. If we finally decide to have a single document, merging can be applied later.

So let us know if you support or not this work becoming a RG document.
In all cases, provide detailed comments to support your opinion and send them on the mailing list.

This call for adoption is open until April 08.
The procedure for RG document adoption and important criteria are detailed here: https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU

Best regards, NMRG chairs
Laurent & Jérôme

---

From: 陈丹阳 <[email-masked]>
Date: Fri, 8 Apr 2022 17:56:56 +0800

Hi Qin,

Thanks for your comments, we gave the corresponding reply in the original email. 

Best Regards,

Danyang

发件人: Qin Wu [mailto:[email-masked]] 
发送时间: 2022年4月3日 17:12
收件人: [email-masked]
主题: Re: [nmrg] call for adoption as RG document: draft-yang-nmrg-network-measurement-intent

Hi,

A:What we want to express is that the “static NMI” means the measurement is independent of the network state, let’s say when we want to know the network delay of the pkt, the IBN system will continuously sampling whatever the network behaves, and the system will report us periodically. In contrast, “dynamic NMI” means the measurement is corresponding to the network state. For example, We want to know the network delay of the busy time, the IBN will adaptively change the sampling rate when it detects that the network state seems busy, and IBN system will report us differently compared to “static NMI”.

  A：Yes, we agree that the combination of active and passive measurement is hybrid measurement, besides, Method like INT is also a kind of hybrid measurement, INT inserts some information into the pkt and gather them for analysis. However, not all network devices support INT, and if we want to deploy an IBN system on top of them, and further want to enable hybrid mode for measurement, the system will enable active and passive mode at the same time. I think this is the proper way for the coordination of active and passive measurement. 

    A: Yes, exactly, we think IBN system can integrate the adaptive subscription of netconf as you mentioned. The adaptive telemetry method is quite similar, we will refer to the draft. 

A: OK, thanks, we will consider about referring to the draft.

A: There are many ways to adjust the NMI policy, and modifying the execution time is just one of them. If the NMI Compliance Assessment module determines that the policy meets user requirements, the policy will be executed forever until the policy execution is complete. If the policy does not meet requirements, the policy will be adjusted or a new policy is issued.

        A: I think we can modify the name of section 5.1 later, the major difference between section 5.1 and section 5.2 that we want to declare can be described as follows, the    adaptive telemetry of section 5.1 mainly focuses on timing accuracy and the clustering mechanism of section 5.2 mainly focuses on spatial accuracy. The former one needs to adatively change the sampling rate according to the network state as time goes on, while the latter one needs to consider which part of the sub-network devices should be enabled for measurement because too many devices will incur too much overhead.

From:  <mailto:[email-masked]> Jérôme François

Date: 2022-03-17 17:51

To:  <mailto:[email-masked]> [email-masked]

CC:  <mailto:[email-masked]> [email-masked];  <mailto:[email-masked]> draft-yang-nmrg-network-measurement-intent

Dear NMRG,

 <https://datatracker.ietf.org/doc/draft-yang-nmrg-network-measurement-intent/> https://datatracker.ietf.org/doc/draft-yang-nmrg-network-measurement-intent/

The procedure for RG document adoption and important criteria are detailed here:  <https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU> https://mailarchive.ietf.org/arch/msg/nmrg/CVEyLUvfxJk1Ud5WdM9Y5LGvQmU 

Laurent & Jérôme