Subject: Re: [ntpwg] [TICTOC] Control Messages Protocol for Use with Network Time Protocol Version 4

From: [email-masked]
Date: Mon, 26 Dec 2011 17:37:37 +0000

Dave,

This is the document I gave you a heads up on last fall. You suggested I bring Dave Hart into the loop. Dave provided the updates reflected in -01. As a listed author, you should be receiving the draft announcements. If this isn't happening, I will need to look into why. 

Anyhow, I am looking to the ntp developer community to provide the update and review necessary to make this accurate. The material was not captured in the update to RFC 1305 and we'd like to fix that. 

Karen

Sent from my Verizon Wireless BlackBerry

-----Original Message-----
From: "David L. Mills" <[email-masked]>
Sender: [email-masked]
Date: Mon, 26 Dec 2011 17:13:04 
To: Danny Mayer<[email-masked]>
Cc: NTP Working Group<[email-masked]>; [email-masked]<[email-masked]>; <[email-masked]>
Subject: Re: [TICTOC] [ntpwg] Control Messages Protocol for Use with Network
 Time Protocol Version 4

_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: "Ulrich Windl" <[email-masked]>
Date: Mon, 02 Jan 2012 09:07:53 +0100

Hello!

IMHO anything that is part of a packet on the network should be documented. Also if they are neccessary for understanding the algorithm, they should also be documented. And preferrably a specific code shouldn't change it's meaning over time; it's better to use a new code instead.

I'm not deeply in NTP at the moment, but felt to comment.

Regards,
Ulrich

>>> Danny Mayer <[email-masked]> schrieb am 28.12.2011 um 02:32 in Nachricht
<[email-masked]>:
> Dave,
> 
> I don't think that event codes should be documented in an RFC. They
> belong in the reference implementation documentation. They are specific
> to the reference implementation but other implementations need to be
> doing the own thing in this regard. I'm sure chrony doesn't use them,
> for example. If the status words are standard then they belong in the RFC.
> 
> Danny
> 
> On 12/26/2011 12:13 PM, David L. Mills wrote:
> > Danny,
> > 
> > This is the first I have seen the document, but my name is on it, so I
> > should respond.
> > 
> > The document  from which this is derived is twenty years old, although
> > it has been updated for recent developments. However, the system per and
> > clock status words do not align with those defined in the current ntpq
> > and status/event codes defined in the current reference implementation
> > documenttation. I suggest the description of the status words in the ID
> > be changed to agree with the documentaiton or the documentatino and
> > implementation be changed to agree with the ID.
> > 
> > The intent in the event codes is to align them with the protostats
> > statistics file messages. These are define din the  header files. While
> > these change from time to time, some kind of reference should be made to
> > the current list. I don't think this should be the IANA, so maybe the
> > reference should be to the current documentation.
> > 
> > Dave