Subject: [ntpwg] I-D Action: draft-ietf-ntp-mac-00.txt

From: [email-masked]
Date: Thu, 05 Jan 2017 06:57:20 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Time Protocol of the IETF.

        Title           : Message Authentication Code for the Network Time Protocol 
        Authors         : Aanchal Malhotra
                          Sharon Goldberg
	Filename        : draft-ietf-ntp-mac-00.txt
	Pages           : 4
	Date            : 2016-11-23

Abstract:
   RFC 5905 [RFC5905] states that Network Time Protocol (NTP) packets
   should be authenticated by appending a 128-bit key to the NTP data,
   and hashing the result with MD5 to obtain a 128-bit tag.  This
   document deprecates the authentication of NTP packets with MD5 and
   recommends the use of AES-CMAC [RFC4493] as a replacement.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ntp-mac/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-ntp-mac-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: "Ulrich Windl" <[email-masked]>
Date: Mon, 09 Jan 2017 08:38:58 +0100

>>> <[email-masked]> schrieb am 05.01.2017 um 15:57 in Nachricht

>         Title           : Message Authentication Code for the Network Time 

What about "Using AES-CMAC as Authentication Code for the Network Time  Protocol " instead?

>    recommends the use of AES-CMAC [RFC4493] as a replacement.

I would revert the sense to something like (roughly) "This draft specifies the use of AES-CMAC as an additional authentication method for ..., allowing to replace the older MD5-based authentication method which is condidered to be too weak meanwhile (at the time of writing)"

Ulrich

---

From: Danny Mayer <[email-masked]>
Date: Tue, 10 Jan 2017 09:55:17 -0500

> What about "Using AES-CMAC as Authentication Code for the Network Time  Protocol " instead?

That would be a bad idea. You don't want to tie an RFC about the MAC to
a specific protocol. This is about the MAC and not the algorithm.

> I would revert the sense to something like (roughly) "This draft specifies the use of AES-CMAC as an additional authentication method for ..., allowing to replace the older MD5-based authentication…

I disagree. This is a much better wording as is.

Danny

---

From: "Ulrich Windl" <[email-masked]>
Date: Tue, 10 Jan 2017 16:08:58 +0100

>>> Danny Mayer <[email-masked]> schrieb am 10.01.2017 um 15:55 in
> a specific protocol. This is about the MAC and not the algorithm.

But the abstract says the RFC is exactly about that specific MAC. NTP is also using a MAC (a different one), so the title is very generic IMHO. Assume you are just browing titles to find something you are looking for...

>> I would revert the sense to something like (roughly) "This draft specifies 
> the use of AES-CMAC as an additional authentication method for ..., allowing 
> to replace the older MD5-based authentication method which is condidered to be 
> too weak meanwhile (at the time of writing)"
>> 
> 

OK, I get accustomed to such documents...