Subject: [ntpwg] how many NTP packets per client per hour in 99 percentile of cases?

From: Job Snijders <[email-masked]>
Date: Sat, 29 Jul 2017 09:58:00 +0200

Dear NTP experts,

I'm looking for data on how many NTP packets per hour an NTP client
receives during normal operations (e.g. in 99 percentile of cases).

Let's assume the client is configured to work with 5 servers.

Kind regards,

Job
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: Harlan Stenn <[email-masked]>
Date: Sat, 29 Jul 2017 01:12:53 -0700

> Let's assume the client is configured to work with 5 servers.

Assuming I'm qualified to answer, the client will start polling once
every 64 seconds, so it will send/receive about 56 packets per server,
so about 281 packets for the 5 servers for an hour.

As the loop settles, the poll interval should increase to 1024 seconds,
at which time you're looking at about 3.5 packets per hour per server,
so about 17.5 packets per hour.
-- 
Harlan Stenn <[email-masked]>
http://networktimefoundation.org - be a member!
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: "Ulrich Windl" <[email-masked]>
Date: Mon, 31 Jul 2017 08:30:34 +0200

>>> Harlan Stenn <[email-masked]> schrieb am 29.07.2017 um 10:12 in Nachricht

> so about 17.5 packets per hour.

I wonder: If the requester would enable peerstats and count the lines in some time interval, wouldn't the sum of all such lines correspond to the number of packet exchanges? Or maybe some packet filter (on UDP port 123 and the client address) would also do.

Finally I wonder whether this type of questions has to be addresses to NTPWG.

Regards,
Ulrich

---

From: Job Snijders <[email-masked]>
Date: Mon, 31 Jul 2017 10:28:38 +0200

> Finally I wonder whether this type of questions has to be addresses to NTPWG.

According to https://datatracker.ietf.org/wg/ntp/about/ "security
considerations" are within this working group's charter.

Fortunately I've received a number of productive answers both on-list
and off-list for which I am grateful.

Kind regards,

Job