Subject: [OAUTH-WG] [Fwd: I-D ACTION:draft-vrancken-oauth-redelegation-00.txt]

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 09 Sep 2009 10:24:26 -0600

<hat type='chair'/>

As seen on the [email-masked] list just now. Perhaps the authors
would like to provide a friendly introduction to their work? :)

/psa

- -------- Original Message --------
Subject: I-D ACTION:draft-vrancken-oauth-redelegation-00.txt
Date: Wed,  9 Sep 2009 09:15:01 -0700 (PDT)
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: Using OAuth for Recursive Delegation
	Author(s)	: B. Vrancken, Z. Zeltsan
	Filename	: draft-vrancken-oauth-redelegation-00.txt
	Pages		: 11
	Date		: 2009-9-4
	
   This document describes a use case for delegating authorization by a
   Resource Owner to another user via a Client using the OAuth protocol.
   OAuth allows Clients to access server resources on behalf of another
  party (such as a different Client or an end-user).  This document
   describes the use of OAuth for delegating one Client's authorization
   to another Client - a scenario, which is also known as four-legged
   authorization.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-vrancken-oauth-redelegation-00.txt

---

From: Richard Barnes <[email-masked]>
Date: Wed, 09 Sep 2009 21:34:46 -0400

Think they already did, to first order:
<http://www.ietf.org/mail-archive/web/oauth/current/msg00284.html>

Peter Saint-Andre wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> <hat type='chair'/>
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.8 (Darwin)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> 
> iEYEARECAAYFAkqn1roACgkQNL8k5A2w/vyW1wCeImOus7lIB1MV4wqQ1cF25mWz
> DZUAnjqmTRH8JX4vKFbkeOEHS1ahVijP
> =rPFC
> -----END PGP SIGNATURE-----
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

---

From: Igor Faynberg <[email-masked]>
Date: Thu, 10 Sep 2009 13:54:02 -0400

Richard,

The authors are traveling now, so I will be happy to chime-in. (Incidentally,
Zachary had sent a notice to this list some time before.)

In short, this is a follow-up on 1) an interesting discussion on the list Re:
"four-legged" approach; and 2) the bar meeting at the last IETF, which Zachary
attended.

Here, in compliance with what appeared to be the consensus of the bar meeting,
the term of "four-legged" was dropped. The concept has been described as
"recursive delegation." The goal of the draft was to document it and provide a
use case.

With best regards,

Igor

---

From: "Zeltsan, Zachary (Zachary)" <[email-masked]>
Date: Fri, 18 Sep 2009 02:54:06 -0500

Peter,

We briefly introduced the draft in the original email, which Richard has mentioned. As Igor has explained, the goal of the draft is to describe a use case for the "four-legged" OAuth. (Richard's and Igor's messages are attached). The term "four-legged" was criticized at the Breakfast BoF, so it is not used (although is mentioned) in the draft. The draft also explains the use of the OAuth for the recursive ("n-legged") delegation.

Zachary

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Igor Faynberg
> Sent: Thursday, September 10, 2009 1:54 PM
> To: Richard Barnes
> Cc: [email-masked]
> Subject: Re: [OAUTH-WG] [Fwd: I-D 
> ACTION:draft-vrancken-oauth-redelegation-00.txt]
> 
> Richard,
> 
> The authors are traveling now, so I will be happy to 
> chime-in. (Incidentally, Zachary had sent a notice to this 
> list some time before.)
> 
> "four-legged" approach; and 2) the bar meeting at the last 
> IETF, which Zachary attended.
> 
> Here, in compliance with what appeared to be the consensus of 
> the bar meeting, the term of "four-legged" was dropped. The 
> concept has been described as "recursive delegation." The 
> goal of the draft was to document it and provide a use case.
> 
> With best regards,
> 
> Igor
> 
> >>As seen on the [email-masked] list just now. Perhaps the 
> >>authors would like to provide a friendly introduction to 
> their work? 
> >>:)
> >>
> >>/psa
> >>
> >>   OAuth allows Clients to access server resources on behalf of 
> >> another  party (such as a different Client or an 
> end-user).  This document
> >>http://www.ietf.org/internet-drafts/draft-vrancken-oauth-red
> elegation-
> >>00.txt
> >>