Subject: [OAUTH-WG] I-D Action:draft-ietf-oauth-v2-01.txt

From: [email-masked]
Date: Thu, 29 Apr 2010 14:15:02 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Open Authentication Protocol Working Group of the IETF.

	Title           : The OAuth 2.0 Protocol
	Author(s)       : E. Hammer-Lahav, et al.
	Filename        : draft-ietf-oauth-v2-01.txt
	Pages           : 49
	Date            : 2010-04-29

This specification describes the OAuth 2.0 protocol.  OAuth provides
a method for making authenticated HTTP requests using a token - an
identifier used to denote an access grant with specific scope,
duration, and other attributes.  Tokens are issued to third-party
clients by an authorization server with the approval of the resource
owner.  OAuth defines multiple flows for obtaining a token to support
a wide range of client types and user experience.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-oauth-v2-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 29 Apr 2010 14:33:51 -0700

Draft -01 submitted today shortly after the -00 (this will make it easier to do a diff for those who read the -00 draft).

I plan to publish -02 next week based on feedback received on the list.

EHL

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of [email-masked]
> Sent: Thursday, April 29, 2010 2:15 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [OAUTH-WG] I-D Action:draft-ietf-oauth-v2-01.txt
> 
> This specification describes the OAuth 2.0 protocol.  OAuth provides a
> method for making authenticated HTTP requests using a token - an identifier
> used to denote an access grant with specific scope, duration, and other
> attributes.  Tokens are issued to third-party clients by an authorization server
> with the approval of the resource owner.  OAuth defines multiple flows for
> obtaining a token to support a wide range of client types and user
> experience.
> 
> implementation to automatically retrieve the ASCII version of the Internet-
> Draft.

---

From: Torsten Lodderstedt <[email-masked]>
Date: Fri, 30 Apr 2010 09:28:44 +0200

Hi Eran,

would you please give an overview of what aspects you are going to  
change in the next draft and what issue you consider as still open?

thanks in advance,
Torsten.

Zitat von Eran Hammer-Lahav <[email-masked]>:

> Draft -01 submitted today shortly after the -00 (this will make it  
> easier to do a diff for those who read the -00 draft).
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Fri, 30 Apr 2010 08:46:15 -0700

I'd like to add scope and credentials response format in the next draft. Doesn't have to be perfect but something we can work with. I am also planning to complete the missing sections at the end.

My goal is to have a feature-complete spec before the interim meeting 5/20.

EHL

> From: Torsten Lodderstedt [mailto:[email-masked]]
> Sent: Friday, April 30, 2010 12:29 AM
> To: Eran Hammer-Lahav
> Cc: [email-masked]
> Subject: Re: [OAUTH-WG] I-D Action:draft-ietf-oauth-v2-01.txt
> 
> Hi Eran,
> 
> would you please give an overview of what aspects you are going to change
> in the next draft and what issue you consider as still open?
> 
> thanks in advance,
> Torsten.
> 
> >> From: [email-masked] [mailto:[email-masked]] On
> >> Behalf Of [email-masked]
> >> Internet- Draft.

---

From: Torsten Lodderstedt <[email-masked]>
Date: Fri, 30 Apr 2010 20:20:22 +0200

> My goal is to have a feature-complete spec before the interim meeting 5/20.

what do you mean with "feature-complete"?

regards,
Torsten.
>> Zitat von Eran Hammer-Lahav<[email-masked]>:
>>
>>