Subject: [OAUTH-WG] PHP-based OAuth 2.0 library, with sample Mongo DB implementation

From: Tim Ridgely <[email-masked]>
Date: Sun, 27 Jun 2010 21:47:17 -0400

Hi everybody,

We're looking to adopt OAuth 2.0 here at Open Dining, and we couldn't find a
suitable PHP server implementation.  With the draft status of the spec in
mind, we took a crack at an implementation anyway.

Documentation is very sparse still, but we commented the heck out of the
source.

Blog: http://www.opendining.net/blog/oauth-2-0-php-library/
Google Code: http://code.google.com/p/oauth2-php/

Feedback welcome.  Thanks!

Tim

---

From: Elena Lozano <[email-masked]>
Date: Mon, 28 Jun 2010 11:45:52 +0200

Hi everyone,

In RedIRIS[1], the Spanish academic and research network that provides advanced communication services to the scientific community and national universities, we are developing a PHP library to the Assertion Profile of the OAuth2 specification.  

This library [2] is in development and we're trying to adapt it to the newest version of the protocol. So far, it has been adapted to the draft v08.
We have developed an Authorization Server, a Resource Server and a Client. All the documentation and specification is in the url below. We've been using it in some use cases and works fine in our environment.

The documentation is still in its initial state, so if you think something needs more explanation, let us know!

We're open to any suggestions and reports, Thanks!

Elena.

[1] http://www.rediris.es/
[2] http://www.rediris.es/oauth2