Subject: [OAUTH-WG] Underscore, dash, green, blue

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 30 Jun 2010 22:08:02 -0700

First, sorry about this. :)

I do my best not to ask the group this kind of questions and just pick something on my own, but I can't decide so I'll run a quick vote (yes, a VOTE - I can't imagine seeking a consensus call on this).

-09 uses underscores for parameter names (except for in the headers) and dashes for parameter values. This seems like an odd selection. Before, it used dashes for header parameter names, and underscore everywhere else. Not great either.

So...

The changes my OCD can live with:

1. Use dashes throughout
2. Use underscores for all parameter names (headers included), dashes for all values
3. Use underscores throughout

I want to get this done with in a day because people are writing code for -09 and I'd like to stop making changes beyond editorial.  I just think that having different styles between the endpoint parameters and header parameters is broken.

EHL

---

From: Michael D Adams <[email-masked]>
Date: Wed, 30 Jun 2010 22:12:51 -0700

> 3. Use underscores throughout

3

---

From: Lukas Rosenstock <[email-masked]>
Date: Thu, 1 Jul 2010 08:41:39 +0200

3 except headers.

2010/7/1 Eran Hammer-Lahav <[email-masked]>:
> First, sorry about this. J
>
>
>
> I do my best not to ask the group this kind of questions and just pick
> something on my own, but I can’t decide so I’ll run a quick vote (yes, a
> VOTE – I can’t imagine seeking a consensus call on this).
>
>
>
> -09 uses underscores for parameter names (except for in the headers) and
> dashes for parameter values. This seems like an odd selection. Before, it
> used dashes for header parameter names, and underscore everywhere else. Not
> great either.
>
>
>
> So…
>
>
>
> I want to get this done with in a day because people are writing code for
> -09 and I’d like to stop making changes beyond editorial.  I just think that
> having different styles between the endpoint parameters and header
> parameters is broken.
>
>
>
> EHL
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>
>

-- 
http://lukasrosenstock.net/