Subject: [OAUTH-WG] type=web_server

From: Marius Scurtescu <[email-masked]>
Date: Thu, 10 Jun 2010 10:20:52 -0700

There are two requests that have type=web_server (but they are
directed to different endpoints):
- 2.5.1. Client Requests Authorization
- 2.5.2. Client Requests Access Token

The is the only case when a type is used for more than one request.

While the spec can work perfectly fine like this, if each request
message had a unique type that would simplify parsing and validation
in a generic library a lot.

Can we change in 2.5.2 the type to something else? web_token?

Thanks,
Marius

---

From: Igor Faynberg <[email-masked]>
Date: Thu, 10 Jun 2010 13:26:09 -0400

I agree. Clarity is essential, and if this is not fixed now, it will 
stay like that forever.

In fact, I would define 'type=web_server_auth' for 2.5.1 and 
'type=web_server_token' for 2.5.2.

Igor

Marius Scurtescu wrote:
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>