Subject: [OAUTH-WG] 4.2 Access Token Response in draft 8

From: Nat Sakimura <[email-masked]>
Date: Wed, 16 Jun 2010 10:26:50 +0900

It is my understanding that access token response may contain other
parameters than what is stated there.
Sometimes, mutually understanding server and client may want to
exchange other parameters on top of it and is legitimate, IMHO.

Is this understanding correct?

-- 
Nat Sakimura (=nat)
http://www.sakimura.org/en/
http://twitter.com/_nat_en

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Tue, 15 Jun 2010 19:52:33 -0700

There is nothing in the spec to prevent other parameters. There will be specific methods to extend the protocol.

EHL

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Nat Sakimura
Sent: Tuesday, June 15, 2010 6:27 PM
To: oauth
Subject: [OAUTH-WG] 4.2 Access Token Response in draft 8

It is my understanding that access token response may contain other parameters than what is stated there.
Sometimes, mutually understanding server and client may want to exchange other parameters on top of it and is legitimate, IMHO.

--
Nat Sakimura (=nat)
http://www.sakimura.org/en/
http://twitter.com/_nat_en
_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth

---

From: Nat <[email-masked]>
Date: Wed, 16 Jun 2010 12:07:44 +0900

I am looking forward to the extension mechanism. Is it coming in draft  
10?

=nat @ Tokyo via iPhone

On 2010/06/16, at 11:52, Eran Hammer-Lahav <[email-masked]> wrote:

> There is nothing in the spec to prevent other parameters. There will  
> be specific methods to extend the protocol.
>
> EHL
>

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Tue, 15 Jun 2010 20:27:28 -0700

-09

-----Original Message-----
From: Nat [mailto:[email-masked]] 
Sent: Tuesday, June 15, 2010 8:08 PM
To: Eran Hammer-Lahav
Cc: oauth
Subject: Re: [OAUTH-WG] 4.2 Access Token Response in draft 8

I am looking forward to the extension mechanism. Is it coming in draft 10?

=nat @ Tokyo via iPhone