Subject: [OAUTH-WG] draft-ietf-oauth-v2-06

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 9 Jun 2010 00:16:43 -0700

(Should show up any minute.)

This is mostly pre-meeting feedback, plus some big removals of signatures and discovery.

   o  Editorial changes, corrections, clarifications, etc.
   o  Removed conformance section.
   o  Moved authors section to contributors appendix.
   o  Added section on native applications.
   o  Changed error response to use the requested format.  Added support for HTTP "Accept" header.
   o  Flipped the order of the web server and user-agent flows.
   o  Renamed assertion flow "format" parameter name to "assertion_format" to resolve conflict.
   o  Removed the term identifier from token definitions.  Added a cryptographic token definition.
   o  Added figure titles.
   o  Added server response 401 when client tried to authenticate using multiple credentials.
   o  Clarified support for TLS alternatives, and added requirement for TLS 1.2 support for token endpoint.
   o  Removed all signature and cryptography.
   o  Removed all discovery.
   o  Updated HTML4 reference.

There is going to be another draft this week so if you are very busy, just wait.

EHL

---

From: Thomas Hardjono <[email-masked]>
Date: Wed, 9 Jun 2010 09:30:33 -0400

Is there a diff version of this draft (eg. a marked PDF say)?

ps. I know the IETF doesn't do PDFs, but I thought I'd ask anyways :)

/thomas/

__________________________________________

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Eran Hammer-Lahav
> Sent: Wednesday, June 09, 2010 3:17 AM
> To: OAuth WG ([email-masked])
> Subject: [OAUTH-WG] draft-ietf-oauth-v2-06
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 09 Jun 2010 08:03:28 -0600

> Is there a diff version of this draft (eg. a marked PDF say)?

Check the two "diff" links at the top of the page here:

http://tools.ietf.org/html/draft-ietf-oauth-v2-06

/psa