Subject: [OAUTH-WG] Typos and language in -21

From: Niv Steingarten <[email-masked]>
Date: Tue, 13 Sep 2011 00:00:48 +0300

In section 10.12 (CSRF):

5th paragraph: "A CSRF attack against the against the authorization
server's authorization endpoint"

    One "against the" is redundant.

4th paragraph: "The binding value enables the client to validate the
validity of the request by matching the binding value to the
user-agent's authenticated state."

    The phrase "validate the validity of the request" sounds a bit
awkward in my opinion. I'd personally go with either "establish the
validity of the request" or simply "validate the request".

-- Niv

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Tue, 20 Sep 2011 11:46:55 -0700

Thanks.

EHL

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Niv Steingarten
> Sent: Monday, September 12, 2011 2:01 PM
> To: OAuth WG
> Subject: [OAUTH-WG] Typos and language in -21
> 
> In section 10.12 (CSRF):
> 
> 5th paragraph: "A CSRF attack against the against the authorization server's
> authorization endpoint"
> 
> 4th paragraph: "The binding value enables the client to validate the validity of
> the request by matching the binding value to the user-agent's authenticated
> state."
> 
>     The phrase "validate the validity of the request" sounds a bit awkward in
> my opinion. I'd personally go with either "establish the validity of the
> request" or simply "validate the request".
> 
> 
> -- Niv
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth