Subject: [OAUTH-WG] Fwd: New Version Notification for draft-lodderstedt-oauth-revocation-03.txt

From: Torsten Lodderstedt <[email-masked]>
Date: Fri, 16 Sep 2011 21:32:01 +0200

Hi all,

I just published a new revision of the token revocation draft. We added 
JSONP support (thanks to Marius) and aligned the text with draft 21 of 
the core spec.

We would like to bring this draft forward as working group item (once 
the WG is ready). We think its relevance is illustrated by the fact that 
this draft (or its predecessor) has already been implemented by Google, 
Salesforce, and Deutsche Telekom.

regards,
Torsten.

-------- Original-Nachricht --------
Betreff: 	New Version Notification for 
draft-lodderstedt-oauth-revocation-03.txt
Datum: 	Fri, 16 Sep 2011 12:20:14 -0700
Von: 	[email-masked]
An: 	[email-masked]
CC: 	[email-masked], [email-masked], [email-masked]

A new version of I-D, draft-lodderstedt-oauth-revocation-03.txt has been successfully submitted by Torsten Lodderstedt and posted to the IETF repository.

Filename:	 draft-lodderstedt-oauth-revocation
Revision:	 03
Title:		 Token Revocation
Creation date:	 2011-09-16
WG ID:		 Individual Submission
Number of pages: 6

Abstract:
    This draft proposes an additional endpoint for OAuth authorization
    servers for revoking tokens.

The IETF Secretariat

---

From: Chuck Mortimore <[email-masked]>
Date: Fri, 16 Sep 2011 13:06:54 -0700

If it's not already implicit by our implementation, I'm voicing our support for this becoming a working group item.

- cmort

On Sep 16, 2011, at 12:31 PM, "Torsten Lodderstedt" <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

I just published a new revision of the token revocation draft. We added JSONP support (thanks to Marius) and aligned the text with draft 21 of the core spec.

We would like to bring this draft forward as working group item (once the WG is ready). We think its relevance is illustrated by the fact that this draft (or its predecessor) has already been implemented by Google, Salesforce, and Deutsche Telekom.

regards,
Torsten.

-------- Original-Nachricht --------
Betreff:        New Version Notification for draft-lodderstedt-oauth-revocation-03.txt
Datum:  Fri, 16 Sep 2011 12:20:14 -0700
Von:    <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
An:     <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
CC:     <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>, <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>, <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>

Abstract:

The IETF Secretariat

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

---

From: Justin Richer <[email-masked]>
Date: Mon, 19 Sep 2011 08:47:20 -0400

I also want to voice support for this. We've implemented an earlier
version of this on a few of our projects as well.

 -- Justin

On Fri, 2011-09-16 at 16:06 -0400, Chuck Mortimore wrote:
> If it's not already implicit by our implementation, I'm voicing our
> support for this becoming a working group item.   
> 
> - cmort
> 
> On Sep 16, 2011, at 12:31 PM, "Torsten Lodderstedt"
> <[email-masked]> wrote:
> 
> 
> 
> > Hi all,
> > 
> > I just published a new revision of the token revocation draft. We
> > added JSONP support (thanks to Marius) and aligned the text with
> > draft 21 of the core spec.
> > 
> > We would like to bring this draft forward as working group item
> > (once the WG is ready). We think its relevance is illustrated by the
> > fact that this draft (or its predecessor) has already been
> > implemented by Google, Salesforce, and Deutsche Telekom.
> > 
> > regards,
> > Torsten.
> > 
> >                               CC: 
> > [email-masked],
> > [email-masked],
> > [email-masked]
> > [email-masked]

---

From: Marius Scurtescu <[email-masked]>
Date: Mon, 19 Sep 2011 11:47:59 -0700

+1

On Fri, Sep 16, 2011 at 1:06 PM, Chuck Mortimore
<[email-masked]>wrote:

> On Sep 16, 2011, at 12:31 PM, "Torsten Lodderstedt" <
> [email-masked]> wrote:
>
> Hi all,
>
> JSONP support (thanks to Marius) and aligned the text with draft 21 of the
> core spec.
>
> We would like to bring this draft forward as working group item (once the
> WG is ready). We think its relevance is illustrated by the fact that this
> draft (or its predecessor) has already been implemented by Google,
> -------- Original-Nachricht --------  Betreff: New Version Notification
> for draft-lodderstedt-oauth-revocation-03.txt  Datum: Fri, 16 Sep 2011
> 12:20:14 -0700  Von:  <[email-masked]>[email-masked]  An:
>  <[email-masked]>[email-masked]  CC:  <[email-masked]>
> [email-masked], <[email-masked]>[email-masked],
> <[email-masked]>[email-masked]
>

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Mon, 19 Sep 2011 11:52:37 -0700

Just a general note: you don't need every spec to become a working group item. If you get an area director to sponsor your draft, you can push it through sooner as an individual submission. Sometimes you don't even need sponsorship.

I'm not saying this out of any objection to the WG taking on this work, just that I don't see a reason to wait. If you feel this simple document is ready and has consensus, you should find a sponsor and move to IETF LC.

EHL

From: [email-masked] [mailto:[email-masked]] On Behalf Of Marius Scurtescu
Sent: Monday, September 19, 2011 11:48 AM
To: Chuck Mortimore
Cc: OAuth WG
Subject: Re: [OAUTH-WG] Fwd: New Version Notification for draft-lodderstedt-oauth-revocation-03.txt

+1
On Fri, Sep 16, 2011 at 1:06 PM, Chuck Mortimore <[email-masked]<mailto:[email-masked]>> wrote:
If it's not already implicit by our implementation, I'm voicing our support for this becoming a working group item.

- cmort

regards,
Torsten.

-------- Original-Nachricht --------
Betreff:

New Version Notification for draft-lodderstedt-oauth-revocation-03.txt

Datum:

Fri, 16 Sep 2011 12:20:14 -0700

Von:

[email-masked]<mailto:[email-masked]>

An:

[email-masked]<mailto:[email-masked]>

CC:

[email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

Revision:        03

Title:           Token Revocation

Number of pages: 6

Abstract:

The IETF Secretariat

---

From: "Lu, Hui-Lan (Huilan)" <[email-masked]>
Date: Fri, 23 Sep 2011 16:00:52 -0500

+1

Huilan Lu

From: [email-masked] [mailto:[email-masked]] On Behalf Of Marius Scurtescu
Sent: Monday, September 19, 2011 2:48 PM
To: Chuck Mortimore
Cc: OAuth WG
Subject: Re: [OAUTH-WG] Fwd: New Version Notification for draft-lodderstedt-oauth-revocation-03.txt

+1

- cmort

regards,
Torsten.

-------- Original-Nachricht --------
Betreff:

Datum:

Von:

An:

CC:

Revision:        03

Title:           Token Revocation

Number of pages: 6

Abstract:

The IETF Secretariat

---

From: Igor Faynberg <[email-masked]>
Date: Fri, 23 Sep 2011 18:51:31 -0400

Yes, this is high time to have this a WG item!

Igor

On 9/16/2011 3:32 PM, Torsten Lodderstedt wrote:
> added JSONP support (thanks to Marius) and aligned the text with draft 
> 21 of the core spec.
>
> the WG is ready). We think its relevance is illustrated by the fact 
> that this draft (or its predecessor) has already been implemented by 
> Google, Salesforce, and Deutsche Telekom.
>
> regards,
> Torsten.
>