Subject: [OAUTH-WG] For a client credentials grant, what are you returning as the value of the "sub" element in an introspection response?

From: Todd W Lainhart <[email-masked]>
Date: Thu, 22 May 2014 10:08:21 -0400

For folks who have implemented the client credentials grant and 
introspection, I'm interested to know what you're returning for the value 
of "sub" in the token introspection response (
http://tools.ietf.org/html/draft-richer-oauth-introspection-04#section-2.2
).  The "client_id" value requesting the grant, or some other client 
registration metadata value?

Todd Lainhart
Rational software
IBM Corporation
550 King Street, Littleton, MA 01460-1250
1-978-899-4705
2-276-4705 (T/L)
[email-masked]

---

From: Justin Richer <[email-masked]>
Date: Thu, 22 May 2014 10:44:59 -0400

We return the client_id of the client that the token was issued to.

  -- Justin

On 5/22/2014 10:08 AM, Todd W Lainhart wrote:
> introspection, I'm interested to know what you're returning for the 
> value of "sub" in the token introspection response 
> (http://tools.ietf.org/html/draft-richer-oauth-introspection-04#section-2.2). 
>  The "client_id" value requesting the grant, or some other client 
> *
> 550 King Street, Littleton, MA 01460-1250**
> 1-978-899-4705
> 2-276-4705 (T/L)
> [email-masked]*
>
>
>
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth