Subject: [OAUTH-WG] Fwd: IPR Disclosure: Nokia Corporation's Statement about IPR related to RFC 6749

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 12 Sep 2014 00:22:45 +0200

Hi all,

in private messages I have gotten questions about this IPR announcement
received in March 2014 and the potential implications on the core OAuth
2.0 protocol. I was thinking about putting it on the agenda for the next
IETF meeting.

The feedback I am hoping to get is whether there is a concern about this
IPR from those who have products and services based on OAuth.

I want to know whether you see problems or not. If you have problems,
maybe there are ways to engineer around it.

Ciao
Hannes

PS: If someone has time to review the state of the art in 2009 I would
also like to chat with you.

-------- Forwarded Message --------
Subject: IPR Disclosure: Nokia Corporation's Statement about IPR related
to RFC 6749
Date: Fri, 28 Mar 2014 07:33:05 -0700
From: IETF Secretariat <[email-masked]>
To: [email-masked]
CC: [email-masked], [email-masked],
[email-masked], [email-masked], [email-masked],
[email-masked]

Dear Dick Hardt:

 An IPR disclosure that pertains to your RFC entitled "The OAuth 2.0
Authorization Framework" (RFC6749) was submitted to the IETF Secretariat on
2014-03-28 and has been posted on the "IETF Page of Intellectual
Property Rights
Disclosures" (https://datatracker.ietf.org/ipr/2336/). The title of the IPR
disclosure is "Nokia Corporation's Statement about IPR related to RFC
6749."");

The IETF Secretariat

---

From: John Bradley <[email-masked]>
Date: Thu, 11 Sep 2014 19:26:53 -0300

Some large number of us would be roasted by our legal departments if we looked at a patent.

Discussing the specifics of patents is not appropriate for a WG meeting.

Someone from  the IETF should look at the issue but not me.

John B.

On Sep 11, 2014, at 7:22 PM, Hannes Tschofenig <[email-masked]> wrote:

> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Mike Jones <[email-masked]>
Date: Thu, 11 Sep 2014 22:26:12 +0000

You should not bring this to the working group, other than making people aware that the disclosure exists (which you've already done).  I know that I will leave the room if the contents of a patent are discussed and I will encourage others to likewise do so.

Engineers should not evaluate patents.  If a person wants a legal opinion on the disclosure, they should privately consult their legal counsel.

				-- Mike

-----Original Message-----
From: OAuth [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Thursday, September 11, 2014 3:23 PM
To: [email-masked]
Subject: [OAUTH-WG] Fwd: IPR Disclosure: Nokia Corporation's Statement about IPR related to RFC 6749

Hi all,

in private messages I have gotten questions about this IPR announcement received in March 2014 and the potential implications on the core OAuth
2.0 protocol. I was thinking about putting it on the agenda for the next IETF meeting.

The feedback I am hoping to get is whether there is a concern about this IPR from those who have products and services based on OAuth.

I want to know whether you see problems or not. If you have problems, maybe there are ways to engineer around it.

Ciao
Hannes

PS: If someone has time to review the state of the art in 2009 I would also like to chat with you.

-------- Forwarded Message --------
Subject: IPR Disclosure: Nokia Corporation's Statement about IPR related to RFC 6749
Date: Fri, 28 Mar 2014 07:33:05 -0700
From: IETF Secretariat <[email-masked]>
To: [email-masked]
CC: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]

Dear Dick Hardt:

 An IPR disclosure that pertains to your RFC entitled "The OAuth 2.0 Authorization Framework" (RFC6749) was submitted to the IETF Secretariat on
2014-03-28 and has been posted on the "IETF Page of Intellectual Property Rights Disclosures" (https://datatracker.ietf.org/ipr/2336/). The title of the IPR disclosure is "Nokia Corporation's Statement about IPR related to RFC 6749."");

The IETF Secretariat

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 12 Sep 2014 00:32:11 +0200

Hi Mike,

as I wrote in my mail below, I am looking for feedback whether the IPR
is a concern to companies.

I am not asking for a patent assessment.

Ciao
Hannes

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 12 Sep 2014 00:38:40 +0200

Hi John,

don't misunderstand me: I am not planning to use our valuable OAuth WG
time to go through the claims and to discuss them.

Instead, I would like to point your attention to this IPR, to evaluate
it within your company (with whatever fancy process you have), and to
tell me at the upcoming IETF meeting whether there are concerns.

Other IPR announcements have arrived before we finished the work on them
and so it was a bit easier to take actions. We had that case a few times
in the group. So far, there have not been concerns with any of the IPR
declarations and we just continued our work as planned.

Ciao
Hannes