Subject: [OAUTH-WG] Dynamic Client Registration Management Protocol: Next Steps?

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 11 Sep 2014 01:50:07 +0200

Hi all,

in response to the discussions at the last IETF meeting the authors of
the "Dynamic Client Registration Management Protocol"
http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-management-05 have
changed the document type to "Experimental".

We need to make a decision about the next steps for the document and we
see the following options:

a) Publish it as an experimental RFC

b) Remove it from the working group and ask an AD to shepherd it

c) Remove it from the working group and let the authors publish it via
the independent submission track.

In any case it would be nice to let folks play around with it and then,
after some time, come back to determine whether there is enough interest
to produce a standard.

Please let us know what you think!

Ciao
Hannes & Derek

---

From: Justin Richer <[email-masked]>
Date: Wed, 10 Sep 2014 20:04:50 -0400

a) Publish it as experimental. There was reasonable support for this in 
both Toronto and London.

  -- Justin

On 9/10/2014 7:50 PM, Hannes Tschofenig wrote:
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Mike Jones <[email-masked]>
Date: Thu, 11 Sep 2014 00:07:51 +0000

+1

This gets it off the working group's plate and lets us gather data about whether this useful or not and whether it's right or whether changes are needed, based on actual usage experience.

From: OAuth [mailto:[email-masked]] On Behalf Of Justin Richer
Sent: Wednesday, September 10, 2014 5:05 PM
To: Hannes Tschofenig; [email-masked]
Subject: Re: [OAUTH-WG] Dynamic Client Registration Management Protocol: Next Steps?

a) Publish it as experimental. There was reasonable support for this in both Toronto and London.

 -- Justin

Hi all,

the "Dynamic Client Registration Management Protocol"<http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-management-05havechangedthedocumenttypeto>

http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-management-05 have<http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-management-05havechangedthedocumenttypeto>

changed the document type to "<http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-management-05havechangedthedocumenttypeto>Experimental".

to produce a standard.

Ciao

Hannes & Derek

OAuth mailing list

[email-masked]<mailto:[email-masked]>

---

From: John Bradley <[email-masked]>
Date: Wed, 10 Sep 2014 21:22:06 -0300

+1

Sent from my iPhone

> On Sep 10, 2014, at 9:07 PM, Mike Jones <[email-masked]> wrote:
> 
> +1
>  
> This gets it off the working group’s plate and lets us gather data about whether this useful or not and whether it’s right or whether changes are needed, based on actual usage experience.
>

---

From: Anthony Nadalin <[email-masked]>
Date: Thu, 11 Sep 2014 14:36:07 +0000

Is "experimental" the correct classification? Maybe "informational" is more appropriate as both of these were discussed. 

-----Original Message-----
From: OAuth [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Wednesday, September 10, 2014 4:50 PM
To: [email-masked]
Subject: [OAUTH-WG] Dynamic Client Registration Management Protocol: Next Steps?

Hi all,

in response to the discussions at the last IETF meeting the authors of the "Dynamic Client Registration Management Protocol"
http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-management-05 have changed the document type to "Experimental".

We need to make a decision about the next steps for the document and we see the following options:

c) Remove it from the working group and let the authors publish it via the independent submission track.

In any case it would be nice to let folks play around with it and then, after some time, come back to determine whether there is enough interest to produce a standard.

Ciao
Hannes & Derek

---

From: "Richer, Justin P." <[email-masked]>
Date: Thu, 11 Sep 2014 15:01:08 +0000

According to the guidelines here:

https://www.ietf.org/iesg/informational-vs-experimental.html

And the discussion in Toronto, it's clearly experimental.

 -- Justin

---

From: Anthony Nadalin <[email-masked]>
Date: Thu, 11 Sep 2014 15:46:54 +0000

I don't see it that way as the guidelines not clear and we should revisit this since there was no conclusion in Toronto. 

-----Original Message-----
From: Richer, Justin P. [mailto:[email-masked]] 
Sent: Thursday, September 11, 2014 8:01 AM
To: Anthony Nadalin
Cc: Hannes Tschofenig; [email-masked]
Subject: Re: [OAUTH-WG] Dynamic Client Registration Management Protocol: Next Steps?

 -- Justin

---

From: Phil Hunt <[email-masked]>
Date: Thu, 11 Sep 2014 08:55:25 -0700

Interesting. The definitions in that don't correspond with what ADs and other groups are doing. 

I heard httpbis using experimental as a placeholder for a draft that didn't have full consensus to bring back later. 

That was the feel I had in Toronto-that we weren't done but it was time to publish something. 

Reading the actual definition i would say neither fits. Ugh. 

Phil

> On Sep 11, 2014, at 8:01, "Richer, Justin P." <[email-masked]> wrote:
>

---

From: John Bradley <[email-masked]>
Date: Thu, 11 Sep 2014 13:02:08 -0300

I think this fits.

	• If the IETF may publish something based on this on the standards track once we know how well this one works, it's Experimental. This is the typical case of not being able to decide which protocol is "better" before we have experience of dealing with them from a stable specification. Case in point: "PGM Reliable Transport Protocol Specification" (RFC 3208)

If we publish something it may or may not look like the current spec but getting some experience with the current spec will inform that decision. 

John B.

---

From: "Richer, Justin P." <[email-masked]>
Date: Thu, 11 Sep 2014 16:03:35 +0000

+1 

That was the key line that I took from the guidelines as well and this was my understanding of the discussion in Toronto.

 -- Justin

---

From: Phil Hunt <[email-masked]>
Date: Thu, 11 Sep 2014 09:07:22 -0700

+1. Experimental seems best here. 

Phil

> On Sep 11, 2014, at 9:03, "Richer, Justin P." <[email-masked]> wrote:
> 
> +1 
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 11 Sep 2014 23:22:25 +0200

I also looked at
https://www.ietf.org/iesg/informational-vs-experimental.html and I got
the impression that an Experimental RFC would be the right category.

Ciao
Hannes

---

From: Maciej Machulak <[email-masked]>
Date: Fri, 12 Sep 2014 01:15:51 +0200

+1

-- 
Cheers, Maciej (sent from my tablet)
On Sep 11, 2014 5:07 PM, "Phil Hunt" <[email-masked]> wrote:

> > That was the key line that I took from the guidelines as well and this
> was my understanding of the discussion in Toronto.
> >
> > -- Justin
> >
> >>    • If the IETF may publish something based on this on the standards
> track once we know how well this one works, it's Experimental. This is the
> typical case of not being able to decide which protocol is "better" before
> we have experience of dealing with them from a stable specification. Case
> in point: "PGM Reliable Transport Protocol Specification" (RFC 3208)
> >>
> >> If we publish something it may or may not look like the current spec
> but getting some experience with the current spec will inform that decision.
> >>
> >> John B.
> >>> I heard httpbis using experimental as a placeholder for a draft that
> didn't have full consensus to bring back later.
> >>>
> >>>>> Is "experimental" the correct classification? Maybe "informational"
> is more appropriate as both of these were discussed.
> >>>>>
> >>>>> in response to the discussions at the last IETF meeting the authors
> of the "Dynamic Client Registration Management Protocol"
> >>>>> http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-management-05
> have changed the document type to "Experimental".
> >>>>>
> >>>>> In any case it would be nice to let folks play around with it and
> then, after some time, come back to determine whether there is enough
> interest to produce a standard.
> >>>>>