Subject: [OAUTH-WG] Your Review of the Native Apps Draft

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 6 Nov 2015 02:01:15 +0100

I just checked the minutes from the Prague IETF meeting and noticed that
Tony, Brian, Erik, Nat, and Eduardo promised to review the native apps
draft and post their review comments to the list.

Could you please do your reviews?

Ciao
Hannes

---

From: Erik Wahlström <[email-masked]>
Date: Fri, 6 Nov 2015 12:31:45 +0100

I posted my review comments here https://www.ietf.org/mail-archive/web/oauth/current/msg14835.html <https://www.ietf.org/mail-archive/web/oauth/current/msg14835.html>

Reposing it because the first comment in my review is also the same question I asked in this meeting. The problem is mainly a usability issue that needs some good recommendations in the draft. What happens to your app if the browser starts other apps to complete an authentication flow when the user comes back? The document need a note that this should be handled in some good way when the app is resumed again. I can try it out in a demo app we have that uses different eID’s (some apps) for authentication to see if it’s possible to figure out some good practices if that’s of interest.

/ Erik

> On 06 Nov 2015, at 02:01, Hannes Tschofenig <[email-masked]> wrote:
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth