Subject: [OAUTH-WG] errata id 4206

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 8 Dec 2015 11:20:41 -0500

Hi,

What do we do with the following errata, I don;t see any prior list responses:

https://www.ietf.org/mail-archive/web/oauth/current/msg14033.html

Thank you!

-- 

Best regards,
Kathleen

---

From: John Bradley <[email-masked]>
Date: Tue, 8 Dec 2015 14:01:41 -0300

The normative text in Sec 4.1.3 is correct.

redirect_uri
         REQUIRED, if the "redirect_uri" parameter was included in the
         authorization request as described in 
         Section 4.1.1, and their values MUST be identical.

The example is arguably not the best worded.  

From the servers point of view the redirect_uri supplied in step A is identical to the one it uses in step C.

From the client’s point of view they receive a authorization response back on the redirect URI with additional parameters, 
so the redirect_uri value is only part of the response URI.

I think his wording is better, but what is there is not strictly speaking wrong.   

It is in non normative text, and the normative text is correct.

I would mark it as editorial.

John B.

> On Dec 8, 2015, at 1:20 PM, Kathleen Moriarty <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Brian Campbell <[email-masked]>
Date: Tue, 8 Dec 2015 10:03:53 -0700

+1

On Tue, Dec 8, 2015 at 10:01 AM, John Bradley <[email-masked]> wrote:

> From the client’s point of view they receive a authorization response back
> on the redirect URI with additional parameters,

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 8 Dec 2015 12:10:42 -0500

Thank you, both!  I'll note this as editorial and will also note that
the URI is the same in A and C, but that the wording is better, hence
editorial.

Kathleen

On Tue, Dec 8, 2015 at 12:03 PM, Brian Campbell
<[email-masked]> wrote:
>> > On Dec 8, 2015, at 1:20 PM, Kathleen Moriarty
>> > <[email-masked]> wrote:
>> >
>> > Hi,
>> >

-- 

Best regards,
Kathleen