Subject: [OAUTH-WG] 11:107. space¿ bridge@¤_:;_)

From: Sheena Carrillo <[email-masked]>
Date: Fri, 19 Aug 2016 21:53:57 +0000 (UTC)

Sent from Yahoo Mail on Android 
 
  On Thu, Aug 18, 2016 at 12:00 PM, [email-masked]<[email-masked]> wrote:   Send OAuth mailing list submissions to
    [email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
    https://www.ietf.org/mailman/listinfo/oauth
or, via email, send a message with subject or body 'help' to
    [email-masked]

You can reach the person managing the list at
    [email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of OAuth digest..."

Today's Topics:

  1. Request for error code: all those from OAuth 2.0 core
      [RFC6749] (Manger, James)

----------------------------------------------------------------------

Message: 1
Date: Thu, 18 Aug 2016 11:45:00 +1000
From: "Manger, James" <[email-masked]>
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [OAUTH-WG] Request for error code: all those from OAuth 2.0
    core    [RFC6749]
Message-ID:
    <[email-masked]>
    
Content-Type: text/plain; charset="us-ascii"

The IANA "OAuth Extensions Error Registry<http://www.iana.org/assignments/oauth-parameters/oauth-parameters.xhtml#extensions-error>" doesn't list most of the errors defined in the core OAuth 2.0 spec [RFC6749], only those added by other specs.

This is just annoying. It would be far more useful for the IANA registry to be a single source of all OAuth 2.0 error codes.

I suggest listing the following to the registry (with RFC6749 as the reference, and perhaps "core" as the "extension"):

access_denied
invalid_client
invalid_grant
invalid_scope
server_error
temporarily_unavailable
unauthorized_client
unsupported_grant_type
unsupported_response_type

--
James Manger

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailarchive.ietf.org/arch/browse/oauth/attachments/20160818/90c240b4/attachment.html>

------------------------------

Subject: Digest Footer

_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth

------------------------------

End of OAuth Digest, Vol 94, Issue 25
*************************************

---

From: Sheena Carrillo <[email-masked]>
Date: Fri, 19 Aug 2016 21:53:57 +0000 (UTC)

Today's Topics:

Message: 1

access_denied
invalid_client
invalid_grant
invalid_scope
server_error
temporarily_unavailable
unauthorized_client
unsupported_grant_type

--
James Manger

-------------- next part --------------

Subject: Digest Footer