Subject: [OAUTH-WG] Identity Provider Interop Testing?

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 19 Sep 2016 13:23:19 +0000

I'm looking to do some OpenID Connect interoperability testing with someone who has implemented an identity provider. I have a relying party implementation that's been tested with Microsoft Hotmail and Google Gmail. I'd like to add support for at least one more IDP. Can anyone help?

Scott

---

From: Justin Richer <[email-masked]>
Date: Mon, 19 Sep 2016 09:35:29 -0400

You're better off contacting the OpenID Connect working group and the 
interoperability list there.

http://openid.net/wg/connect/

While there's a lot of overlap in the communities, OAuth and OIDC are 
different protocols and the discussion you want is better held there.

  -- Justin

On 9/19/2016 9:23 AM, Hollenbeck, Scott wrote:
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 19 Sep 2016 14:36:58 +0000

> -----Original Message-----
> From: OAuth [mailto:[email-masked]] On Behalf Of Justin Richer
> Sent: Monday, September 19, 2016 9:35 AM
> To: [email-masked]
> Subject: Re: [OAUTH-WG] Identity Provider Interop Testing?
> 

Understood, but there's this little detail:

> Please note that while anyone can join the mailing list as a read-only
> recipient, posting to the mailing list or actively contributing to the
> specification itself requires the submission of an IPR Agreement.

Sorry for the off-topic post, but I thought that a note sent to this list might just find the right people without having to deal with the overhead of getting an IPR Agreement in place to gain posting privileges.

Scott

---

From: Nat Sakimura <[email-masked]>
Date: Tue, 27 Sep 2016 14:02:32 +0000

There is an interop list which does not have IPR requirement.
The IPR Contribution Agreement is there to prevent a party to embed patent
encumbered claims into the specification to collect license fees at a later
date. There is no need for such in just working with the interops.

OpenID Connect Interop Group:
https://groups.google.com/forum/#!forum/openid-connect-interop

Cheers,

Nat

On Mon, Sep 19, 2016 at 11:37 PM Hollenbeck, Scott <[email-masked]>
wrote:

> Sorry for the off-topic post, but I thought that a note sent to this list
> might just find the right people without having to deal with the overhead
> of getting an IPR Agreement in place to gain posting privileges.
>
> Scott
>
-- 

Nat Sakimura

Chairman of the Board, OpenID Foundation

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 27 Sep 2016 14:22:53 +0000

Thanks, Nat.

Scott

From: Nat Sakimura [mailto:[email-masked]]
Sent: Tuesday, September 27, 2016 10:03 AM
To: Hollenbeck, Scott; Justin Richer; [email-masked]
Subject: Re: [OAUTH-WG] Identity Provider Interop Testing?

There is an interop list which does not have IPR requirement.
The IPR Contribution Agreement is there to prevent a party to embed patent encumbered claims into the specification to collect license fees at a later date. There is no need for such in just working with the interops.

OpenID Connect Interop Group: https://groups.google.com/forum/#!forum/openid-connect-interop

Cheers,

Nat

On Mon, Sep 19, 2016 at 11:37 PM Hollenbeck, Scott <[email-masked]<mailto:[email-masked]>> wrote:
> From: OAuth [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Justin Richer
> To: [email-masked]<mailto:[email-masked]>

Scott

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth
--

Nat Sakimura

---

From: Nat Sakimura <[email-masked]>
Date: Tue, 27 Sep 2016 14:28:07 +0000

Just as a side note: we are constructing the RP testing suite right now.
Perhaps you might want to become a beta tester as well. For more info,
please contact Mike Jones, who is CC'ed, for the detail.

Best,

Nat

On Tue, Sep 27, 2016 at 11:22 PM Hollenbeck, Scott <[email-masked]>
wrote:

> Thanks, Nat.
>
>
>
> Scott
>
>
>
> *From:* Nat Sakimura [mailto:[email-masked]]
> *Sent:* Tuesday, September 27, 2016 10:03 AM
> *To:* Hollenbeck, Scott; Justin Richer; [email-masked]
>
>
> *Subject:* Re: [OAUTH-WG] Identity Provider Interop Testing?
>
>
>
> On Mon, Sep 19, 2016 at 11:37 PM Hollenbeck, Scott <
> [email-masked]> wrote:
>
-- 

Nat Sakimura