Subject: [OAUTH-WG] draft-ietf-oauth-token-exchange/audience & draft-ietf-oauth-resource-indicators

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 30 Nov 2018 20:31:59 +0000

Hi all,

Token exchange registers the 'resource' parameter, at least to a large extend, and draft-ietf-oauth-resource-indicators indicates this in the IANA consideration section.

What isn't mentioned in draft-ietf-oauth-resource-indicators is that token exchange also defines the audience parameter. The audience parameter is defined as

"
Audience:
      The logical name of the target service where the client
      intends to use the requested security token.  This serves a
      purpose similar to the "resource" parameter, but with the client
      providing a logical name rather than a location.
"

I am mentioning this also because draft-ietf-ace-oauth-params defines a parameter 'req_aud', which was supposed to be similar to resource but at the last IETF meeting the argument was that it is a logical name. As such, it would correspond to the audience parameter registered in the token exchange.

Is my observation correct?

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Brian Campbell <[email-masked]>
Date: Fri, 30 Nov 2018 14:04:28 -0700

Seems correct, yes.

On Fri, Nov 30, 2018 at 1:32 PM Hannes Tschofenig <[email-masked]>
wrote:

> Hi all,
>
> Token exchange registers the 'resource' parameter, at least to a large
> extend, and draft-ietf-oauth-resource-indicators indicates this in the IANA
> consideration section.
>
> What isn't mentioned in draft-ietf-oauth-resource-indicators is that token
> exchange also defines the audience parameter. The audience parameter is
> defined as
>
> "
> Audience:
> I am mentioning this also because draft-ietf-ace-oauth-params defines a
> parameter 'req_aud', which was supposed to be similar to resource but at
> the last IETF meeting the argument was that it is a logical name. As such,
> it would correspond to the audience parameter registered in the token
> exchange.
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._