Subject: [OAUTH-WG] JWT Response for OAuth Token Introspection implementations

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Thu, 2 May 2019 16:46:15 -0400

All,

As part of the shepherd write-up for the *JWT Response for OAuth Token
Introspection* draft, we are looking for information about implementations
for this document:
https://datatracker.ietf.org/doc/draft-ietf-oauth-jwt-introspection-response/

Are you aware of any implementations?

Regards,
 Rifaat

---

From: Filip Skokan <[email-masked]>
Date: Fri, 3 May 2019 09:32:16 +0200

Hi Rifaat,

node.js OSS oidc-provider implements the document in full behind an optional feature toggle - https://github.com/panva/node-oidc-provider/blob/master/docs/README.md#featuresjwtintrospection

Best,
Filip

Odesláno z iPhonu

2. 5. 2019 v 22:46, Rifaat Shekh-Yusef <[email-masked]>:

> All,
> 
> As part of the shepherd write-up for the JWT Response for OAuth Token Introspection draft, we are looking for information about implementations for this document:
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Vladimir Dzhuvinov <[email-masked]>
Date: Mon, 6 May 2019 21:39:45 +0300

Hi Rifaat,

> Are you aware of any implementations?

Here is a production implementation of the JWT introspection response:

https://connect2id.com/products/server/docs/api/token-introspection

Vladimir

-- 
Vladimir Dzhuvinov

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Thu, 9 May 2019 15:45:57 -0400

Thanks Filip!

On Fri, May 3, 2019 at 3:32 AM Filip Skokan <[email-masked]> wrote:

> Hi Rifaat,
>
> node.js OSS oidc-provider implements the document in full behind an
> optional feature toggle -
> https://github.com/panva/node-oidc-provider/blob/master/docs/README.md#featuresjwtintrospection
>
> Best,
> Filip
>
> Odesláno z iPhonu
>
> Introspection* draft, we are looking for information about
> implementations for this document:
>

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Thu, 9 May 2019 15:46:08 -0400

Thanks Vladimir!

---

From: Steffo Weber <[email-masked]>
Date: Fri, 17 May 2019 16:21:51 +0200

Hi Rifaat

We did one as part of the ForgeRock platform (on a per project basis). Artefact can be found at: https://github.com/ForgeRock/PSD2-Accelerators/tree/yes.com/openig/yes-openig-signed-introspect-filter
We might move that to a different service within the platform at a later stage.

HTH

Steffo

> On 2. May 2019, at 22:46, Rifaat Shekh-Yusef <[email-masked]> wrote:
> 
> All,
> 

--
Dr Steffo Weber | Architect
ForgeRock

http://flip.it/caxRa

Phone: +49 151 5167 9521
Skype: steffo.weber

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Fri, 17 May 2019 13:39:42 -0400

Thanks Steffo!

On Friday, May 17, 2019, Steffo Weber <[email-masked]> wrote:

> Hi Rifaat
>
> We did one as part of the ForgeRock platform (on a per project basis).
> Artefact can be found at: https://github.com/ForgeRock/
> PSD2-Accelerators/tree/yes.com/openig/yes-openig-signed-introspect-filter
> > As part of the shepherd write-up for the JWT Response for OAuth Token
> Introspection draft, we are looking for information about implementations
> for this document: