Subject: Re: [OAUTH-WG] OAuth Digest, Vol 136, Issue 7

From: Bruno Brito <[email-masked]>
Date: Tue, 18 Feb 2020 21:49:27 -0300

Hi Guys,

I really understand the security and motivations behind ROPC and I'm not
against the decision it is deprecated. Actually I see many devs and teams
using ROPC to deliver a better UI experience in Mobile apps and easy
integration.
They try to follow specs of RFC 8252 and AppAuth isn't easy to use. Many
bugs shows up in the way, and it's not a good user experience at all. At
the end of the day, they became to use ROPC as an alternative. Tremendous
easy to implement compared against AppAuth.

My question is, we are really prepared to go away from ROPC? In one hand
the best practice says: Use AppAuth for Native apps. But in this case the
time and efforts the teams need to implement it in a good manner is
substantially high if we compare against a SPA Frontend using javascript
oidc. So my point is, isn't better for us before remove oidc, try something
to improve a better and easy integration with native apps?

/Bruno

On Tue, Feb 18, 2020 at 6:57 PM <[email-masked]> wrote:

> Send OAuth mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www.ietf.org/mailman/listinfo/oauth
> or, via email, send a message with subject or body 'help' to
>         [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of OAuth digest..."
> Today's Topics:
>
>    1. Re: OAuth 2.1: dropping password grant (Aaron Parecki)
>    2. Re: OAuth 2.1: dropping password grant (Hans Zandbelt)
>
>
>
> ---------- Forwarded message ----------
> From: Aaron Parecki <[email-masked]>
> To: Justin Richer <[email-masked]>
> Cc: Anthony Nadalin <tonynad=[email-masked]>, "
> [email-masked]" <[email-masked]>
> Bcc:
> Date: Tue, 18 Feb 2020 13:43:37 -0800
> Subject: Re: [OAUTH-WG] OAuth 2.1: dropping password grant
> Agreed. Plus, the Security BCP is already effectively acting as a grace
> period since it currently says the password grant MUST NOT be used, so in
> the OAuth 2.0 world that's already a pretty strong signal.
>
> Aaron
>
>
>
> On Tue, Feb 18, 2020 at 4:16 PM Justin Richer <[email-masked]> wrote:
>
>> There is no need for a grace period. People using OAuth 2.0 can still do
>> OAuth 2.0. People using OAuth 2.1 will do OAuth 2.1.
>>
>>  — Justin
>>
>> On Feb 18, 2020, at 3:54 PM, Anthony Nadalin <
>> tonynad=[email-masked]> wrote:
>>
>> I would suggest a SHOULD NOT instead of MUST, there are still sites using
>> this and a grace period should be provided before a MUST is pushed out as
>> there are valid use cases out there still.
>>
>> *From:* OAuth <[email-masked]> *On Behalf Of *Dick Hardt
>> *Sent:* Tuesday, February 18, 2020 12:37 PM
>> *To:* [email-masked]
>> *Subject:* [EXTERNAL] [OAUTH-WG] OAuth 2.1: dropping password grant
>>
>> Hey List
>>
>> (Once again using the OAuth 2.1 name as a placeholder for the doc that
>> Aaron, Torsten, and I are working on)
>>
>> In the security topics doc
>>
>>
>> https://tools.ietf.org/html/draft-ietf-oauth-security-topics-14#section-2.4
>> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-oauth-security-topics-14%23section-2.4&data=02%7C01%7Ctonynad%40microsoft.com%7C47bb597eef584c95ba4108d7b4b274b2%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637176550905333283&sdata=nA1S7TBfZg6cSwY2hI8hpRXhIA2joaaJFmNXrATgr2Y%3D&reserved=0>
>>
>> The password grant MUST not be used.
>>
>> Some background for those interested. I added this grant into OAuth 2.0
>> to allow applications that had been provided password to migrate. Even with
>> the caveats in OAuth 2.0, implementors decide they want to prompt the user
>> to enter their credentials, the anti-pattern OAuth was created to
>> eliminate.
>>
>>
>> Does anyone have concerns with dropping the password grant from the OAuth
>> 2.1 document so that developers don't use it?
>>
>> /Dick
>> _______________________________________________
>> OAuth mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/oauth
>>
>>
>> _______________________________________________
>> OAuth mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/oauth
>>
> --
> ----
> Aaron Parecki
> aaronparecki.com
> @aaronpk <http://twitter.com/aaronpk>
>
>
>
>
> ---------- Forwarded message ----------
> From: Hans Zandbelt <[email-masked]>
> To: Aaron Parecki <[email-masked]>
> Cc: Justin Richer <[email-masked]>, Anthony Nadalin <tonynad=
> [email-masked]>, "[email-masked]" <[email-masked]>
> Bcc:
> Date: Tue, 18 Feb 2020 22:57:33 +0100
> Subject: Re: [OAUTH-WG] OAuth 2.1: dropping password grant
> I would also seriously look at the original motivation behind ROPC: I know
> it has been deployed and is used in quite a lot of places but I have never
> actually come across a use case where it is used for migration purposes and
> the migration is actually executed (I know that is statistically not a very
> strong argument but I challenge others to come up with one...)
> In reality it turned out just to be a one off that people used as an easy
> way out to stick to an anti-pattern and still claim to do OAuth 2.0. It is
> plain wrong, it is not OAuth and we need to get rid of it.
>
> Hans.
>
> On Tue, Feb 18, 2020 at 10:44 PM Aaron Parecki <[email-masked]> wrote:
>
>> Agreed. Plus, the Security BCP is already effectively acting as a grace
>> period since it currently says the password grant MUST NOT be used, so in
>> the OAuth 2.0 world that's already a pretty strong signal.
>>
>> Aaron
>>
>>
>>
>> On Tue, Feb 18, 2020 at 4:16 PM Justin Richer <[email-masked]> wrote:
>>
>>> There is no need for a grace period. People using OAuth 2.0 can still do
>>> OAuth 2.0. People using OAuth 2.1 will do OAuth 2.1.
>>>
>>>  — Justin
>>>
>>> On Feb 18, 2020, at 3:54 PM, Anthony Nadalin <
>>> tonynad=[email-masked]> wrote:
>>>
>>> I would suggest a SHOULD NOT instead of MUST, there are still sites
>>> using this and a grace period should be provided before a MUST is pushed
>>> out as there are valid use cases out there still.
>>>
>>> *From:* OAuth <[email-masked]> *On Behalf Of *Dick Hardt
>>> *Sent:* Tuesday, February 18, 2020 12:37 PM
>>> *To:* [email-masked]
>>> *Subject:* [EXTERNAL] [OAUTH-WG] OAuth 2.1: dropping password grant
>>>
>>> Hey List
>>>
>>> (Once again using the OAuth 2.1 name as a placeholder for the doc that
>>> Aaron, Torsten, and I are working on)
>>>
>>> In the security topics doc
>>>
>>>
>>> https://tools.ietf.org/html/draft-ietf-oauth-security-topics-14#section-2.4
>>> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-oauth-security-topics-14%23section-2.4&data=02%7C01%7Ctonynad%40microsoft.com%7C47bb597eef584c95ba4108d7b4b274b2%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637176550905333283&sdata=nA1S7TBfZg6cSwY2hI8hpRXhIA2joaaJFmNXrATgr2Y%3D&reserved=0>
>>>
>>> The password grant MUST not be used.
>>>
>>> Some background for those interested. I added this grant into OAuth 2.0
>>> to allow applications that had been provided password to migrate. Even with
>>> the caveats in OAuth 2.0, implementors decide they want to prompt the user
>>> to enter their credentials, the anti-pattern OAuth was created to
>>> eliminate.
>>>
>>>
>>> Does anyone have concerns with dropping the password grant from the
>>> OAuth 2.1 document so that developers don't use it?
>>>
>>> /Dick
>>> _______________________________________________
>>> OAuth mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/oauth
>>>
>>>
>>> _______________________________________________
>>> OAuth mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/oauth
>>>
>> --
>> ----
>> Aaron Parecki
>> aaronparecki.com
>> @aaronpk <http://twitter.com/aaronpk>
>>
>> _______________________________________________
>> OAuth mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/oauth
>>
>
>
> --
> [email-masked]
> ZmartZone IAM - www.zmartzone.eu
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

---

From: Torsten Lodderstedt <[email-masked]>
Date: Wed, 19 Feb 2020 08:25:19 +0100

Hi Bruno,

thanks for your insights.

The recommendation is not only based on security considerations but just utility. As soon as one wants to integrate federated login or multi factor authentication,  ROPG reaches its limits.

Moreover, how do those teams implement user registration and user account recovery? In my experience, implementing this in a native experience will significantly increase cost of the implementation.

Two reasons to go with the code flow.

best regards,
Torsten.

> Am 19.02.2020 um 01:49 schrieb Bruno Brito <[email-masked]>:
>