Subject: [OAUTH-WG] Call for Adoption: DPoP

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Tue, 17 Mar 2020 08:20:38 -0400

All,

As per the conclusion of the PoP interim meeting, this is a call for
adoption for the *OAuth 2.0 Demonstration of Proof-of-Possession at the
Application Layer (DPoP)* document:
https://datatracker.ietf.org/doc/draft-fett-oauth-dpop/

Please, let us know if you support or object to the adoption of this
document as a working group document by March 31st.

Regards,
 Rifaat & Hannes

---

From: Rob Otto <[email-masked]>
Date: Tue, 17 Mar 2020 12:25:58 +0000

I support adoption

Thank you
Rob Otto

On Tue, 17 Mar 2020 at 12:21, Rifaat Shekh-Yusef <[email-masked]>
wrote:

> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

-- 
<https://www.pingidentity.com>
<https://www.pingidentity.com>
Rob Otto
EMEA Field CTO/Solutions Architect
[email-masked]

c: +44 (0) 777 135 6092
Connect with us: 
<https://www.glassdoor.com/Overview/Working-at-Ping-Identity-EI_IE380907.11,24.htm>
[image:
LinkedIn logo] <https://www.linkedin.com/company/21870> [image: twitter
logo] <https://twitter.com/pingidentity> 
<https://www.facebook.com/pingidentitypage> 
<https://www.youtube.com/user/PingIdentityTV> 
<https://www.pingidentity.com/en/blog.html>
<https://www.google.com/url?q=https://www.pingidentity.com/content/dam/ping-6-2-assets/Assets/faqs/en/consumer-attitudes-post-breach-era-3375.pdf?id%3Db6322a80-f285-11e3-ac10-0800200c9a66&source=gmail&ust=1541693608526000&usg=AFQjCNGBl5cPHCUAVKGZ_NnpuFj5PHGSUQ>
<https://www.pingidentity.com/en/events/d/identify-2019.html>
<https://www.pingidentity.com/content/dam/ping-6-2-assets/Assets/Misc/en/3464-consumersurvey-execsummary.pdf>
<https://www.pingidentity.com/en/events/e/rsa.html>
<https://www.pingidentity.com/en/events/e/rsa.html>
<https://developer.pingidentity.com/en/signup.html>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._

---

From: Filip Skokan <[email-masked]>
Date: Tue, 17 Mar 2020 13:36:23 +0100

I support the adoption of DPoP. 

Best,
Filip

> 17. 3. 2020 v 13:21, Rifaat Shekh-Yusef <[email-masked]>:
> 
> 
> All,
> 
> As per the conclusion of the PoP interim meeting, this is a call for adoption for the OAuth 2.0 Demonstration of Proof-of-Possession at the Application Layer (DPoP) document:
> Please, let us know if you support or object to the adoption of this document as a working group document by March 31st.
> 
> Regards,
>  Rifaat & Hannes
>

---

From: Vladimir Dzhuvinov <[email-masked]>
Date: Tue, 17 Mar 2020 14:40:24 +0200

+1 for DPoP

On 17/03/2020 14:25, Rob Otto wrote:
> I support adoption 
>
> Thank you
> Rob Otto
>
> On Tue, 17 Mar 2020 at 12:21, Rifaat Shekh-Yusef
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     All,
>
>     As per the conclusion of the PoP interim meeting, this is a call
>     for adoption for the *OAuth 2.0 Demonstration of
>     Proof-of-Possession at the Application Layer (DPoP)* document:
>     Please, let us know if you support or object to the adoption of
>     this document as a working group document by March 31st.
>
>     Regards,
>      Rifaat & Hannes
>
>     [email-masked] <mailto:[email-masked]>
> Ping Identity <https://www.pingidentity.com> 	
> Rob Otto
> [email-masked] <mailto:[email-masked]>
>
> c: +44 (0) 777 135 6092
>
> Connect with us: 	Glassdoor logo
> LinkedIn logo <https://www.linkedin.com/company/21870> twitter logo
> <https://twitter.com/pingidentity> facebook logo
> <https://www.facebook.com/pingidentitypage> youtube logo
> <https://www.youtube.com/user/PingIdentityTV> Blog logo
> /CONFIDENTIALITY NOTICE: This email may contain confidential and
> privileged material for the sole use of the intended recipient(s). Any
> review, use, distribution or disclosure by others is strictly
> prohibited..  If you have received this communication in error, please
> notify the sender immediately by e-mail and delete the message and any
> file attachments from your computer. Thank you./
>

-- 
Vladimir Dzhuvinov

---

From: Torsten Lodderstedt <[email-masked]>
Date: Tue, 17 Mar 2020 14:17:26 +0100

+1

> On 17. Mar 2020, at 13:40, Vladimir Dzhuvinov <[email-masked]> wrote:
> 
> +1 for DPoP
> 
>> On Tue, 17 Mar 2020 at 12:21, Rifaat Shekh-Yusef <[email-masked]> wrote:
>> All,
>> 
>> CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited..  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you. 
>>

---

From: Dominick Baier <[email-masked]>
Date: Tue, 17 Mar 2020 09:43:16 -0400

+1

———
Dominick Baier

On 17. March 2020 at 14:18:37, Torsten Lodderstedt (
torsten=[email-masked]) wrote:

+1

>> As per the conclusion of the PoP interim meeting, this is a call for
adoption for the OAuth 2.0 Demonstration of Proof-of-Possession at the
>> CONFIDENTIALITY NOTICE: This email may contain confidential and
privileged material for the sole use of the intended recipient(s). Any
review, use, distribution or disclosure by others is strictly prohibited..
If you have received this communication in error, please notify the sender
immediately by e-mail and delete the message and any file attachments from
your computer. Thank you.

---

From: Jim Willeke <[email-masked]>
Date: Tue, 17 Mar 2020 10:20:43 -0400

-jim
Jim Willeke

---

From: Brian Campbell <[email-masked]>
Date: Tue, 17 Mar 2020 10:13:52 -0600

+1 to adopt DPoP

---

From: Justin Richer <[email-masked]>
Date: Tue, 17 Mar 2020 17:25:53 -0400

+1

I support adoption of DPoP. I have written an implementation of its current state for a client and implemented its signature mechanism in another project (without the rest of the protocol, fwiw). 

Now, speaking as the editor of the group’s previous general-purpose http signature draft (for use with the general purpose PoP architecture) and co-editor of the new HTTP working group http signature draft, I still think that there’s room for both of these implementations out there. DPoP is simple and focused, it should do one thing and do it well. And the energies that are looking for a more general solution should help us make the wider HTTP Signature spec work across all those use cases.

 — Justin

> On Mar 17, 2020, at 8:20 AM, Rifaat Shekh-Yusef <[email-masked]> wrote:
> 
> All,
> 
> https://datatracker.ietf.org/doc/draft-fett-oauth-dpop/ <https://datatracker.ietf.org/doc/draft-fett-oauth-dpop/>
>

---

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Fri, 20 Mar 2020 21:06:15 +0000

+1

I support adoption of DPoP, and echo Justin’s sentiment that there remains room for further work.

–
Annabelle Backman (she/her)
AWS Identity
https://aws.amazon.com/identity/

From: OAuth <[email-masked]> on behalf of Justin Richer <[email-masked]>
Date: Tuesday, March 17, 2020 at 2:26 PM
To: Rifaat Shekh-Yusef <[email-masked]>
Cc: oauth <[email-masked]>
Subject: RE: [EXTERNAL] [OAUTH-WG] Call for Adoption: DPoP

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you can confirm the sender and know the content is safe.

+1

 — Justin

On Mar 17, 2020, at 8:20 AM, Rifaat Shekh-Yusef <[email-masked]<mailto:[email-masked]>> wrote:

All,

Regards,
 Rifaat & Hannes
_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

---

From: "Hjelm, Bjorn" <[email-masked]>
Date: Mon, 23 Mar 2020 15:47:20 -0700

Support the adoption of DPoP.

BR,
Bjorn

On Tue, Mar 17, 2020 at 5:21 AM Rifaat Shekh-Yusef <[email-masked]>
wrote:

> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dfett-2Doauth-2Ddpop_&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6tOf9bN5lnuu0jl9p1INnD0&m=39Ltley6USRVK8HYlsY2NYve1tYzi5V2Ni8mHz8DnOk&s=z8OqzZec3VH2oA9elDgXXkZTT-RU8YqSGHnGKuXxbWg&e=>
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_oauth&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6tOf9bN5lnuu0jl9p1INnD0&m=39Ltley6USRVK8HYlsY2NYve1tYzi5V2Ni8mHz8DnOk&s=l6rleK0Ml4-xpLa8WSNqQZflogiTtdgUcd5YBkwGXr4&e=
>

---

From: Steinar Noem <[email-masked]>
Date: Tue, 24 Mar 2020 09:11:41 +0100

+1

tir. 17. mar. 2020 kl. 13:21 skrev Rifaat Shekh-Yusef <[email-masked]
>:

-- 
Vennlig hilsen

Steinar Noem
Partner Udelt AS
Systemutvikler

| [email-masked] | [email-masked]  | +47 955 21 620 | www.udelt.no |