Subject: El-Gamal signatures again

From: "Michael Young" <[email-masked]>
Date: Thu, 28 Dec 2000 17:29:43 -0500

-----BEGIN PGP SIGNED MESSAGE-----

I never did see anyone answer on the OpenPGP specification of
El Gamal signatures.  I guessed the following:

    Pad as for RSA (PKCS-1).
    MPIs are:
 r (=g^k mod p); and,
 s (=(h-r*x)/k mod p)

Can someone confirm this?

---

From: Rodney Thayer <[email-masked]>
Date: Sat, 06 Jan 2001 00:35:05 -0800

El Gamal is apparently considered a Very Bad Thing.  Don't do it.