Subject: Re: Primary subkey subpacket

From: [email-masked]
Date: Wed, 14 Aug 2002 14:27:53 +0200

Timo Schulz wrote:
> Recently I stumbled over a problems with multiple subkeys. I know
> PGP doesn't let the user choose the key at all and GPG uses the
> newest key by default. What about a "primary subkey" subpacket
> which is placed on the self signature to force the implementation
> to use a special subkey. The format should be similar to the 
> "primary user id" packet.

where do you want to place it?
in subkey binding sig?
that would be odd..
because this means creating another binding sig (when making new subkey(s)),
and OpenPGP does not allow multiple binding sigs (unlike userid self sig),
and then keyserver problems, etc..

I think it may be better to put this in userid self sig
(this would allow different subkeys for different userids),
but then format can't be like "primary user id" (5.2.3.19.) subpacket,
it can be like Issuer (5.2.3.5.) or even better
like Revocation key (5.2.3.15.) subpacket

__
Disastry  http://disastry.dhs.org/

---

From: Timo Schulz <[email-masked]>
Date: Wed, 14 Aug 2002 18:29:13 +0200

> > which is placed on the self signature to force the implementation
                           ^^^^^^^^^^^^^^
[snip]
> where do you want to place it?

In the self signature.

> but then format can't be like "primary user id" (5.2.3.19.) subpacket,

Yes, I see this is a problem. The easiest solution would be to put
it in a signature which is part of the public key to have a non-ambiguous
assignment.

        Timo