Subject: Re: Text canonicalization

From: Florian Weimer <[email-masked]>
Date: Fri, 18 Oct 2002 19:42:03 +0200

Florian Weimer <[email-masked]> writes:

> [email-masked] writes:
>
>> The first is that it does not make clear what constitutes line endings.
>> In PGP we treat CR LF, CR, and LF all as line endings and convert each
>> one to CR LF.
>
> What about the other line ending characters?  With Unicode (or even
> ISO-8859-x close to an EBCDIC environment), there a few more
> characters which could end a line.

Let me repeat this question. ;-)

If you look at the discussion about the XML 1.1 specification, you'll
see that there is a real ambiguity.

-- 
Florian Weimer 	                  [email-masked]
University of Stuttgart           http://CERT.Uni-Stuttgart.DE/people/fw/
RUS-CERT                          fax +49-711-685-5898

---

From: "Dominikus Scherkl" <[email-masked]>
Date: Mon, 21 Oct 2002 12:31:14 +0200

Hi.

> see that there is a real ambiguity.
All behind the 128-bit ASCII code should be left unchanged.
This will do no harm, because all other soft- and hardware
in the trasportsystem will do the same.
If an editor interpret those "in text format comands", it might
do (for display reasons) but should also not change the text!!!

Again: This is not a topic to PGP at all, because those chars
are uncritical to the mail-system.
The whole thing about CR and LF is, that the mail sytem on
some systems change them, insert additional whitespace to
the end or cut it of - nothing like this will happen to unicode
line endings.

Best Regards
-- 
Dominikus Scherkl
[email-masked]