Subject: Re: Signature Subpacket 10?

From: Jon Callas <[email-masked]>
Date: Wed, 20 Jul 2005 17:21:55 -0700

On 30 Jun 2005, at 4:16 AM, Ian Grigg wrote:

> A little background.  This was added by the old
> PGP Inc company for commercial users so as to
> escrow email.  If a key had this subpacket, you
> would encrypt to that additional key as well.
>

Not precisely true. It's a way to have data access to any encrypted 
data.

> The notion was that it should go
> in the standard, but that was politically charged
> at the time - indeed Loius Freeh stood up in
> front of Congress and used this very feature as
> proof that it was possible to force all crypto
> programs to escrow messages for the FBI...
>

No. That's completely false. I have no idea where you heard that, but 
that's not at all true.

This is so false that the opposite is true. The FBI hated it because it 
was a completely voluntary system with easy workarounds. The FBI hated 
it, which is one of the amusing ironies about the thing.

> The compromise that was reached was that it
> not be documented in the standard.  I don't
> know if GPG implements it, or even if it the PGP
> line still includes it.  I think architecturally speaking,
> such a feature is better off in the proxy products,
> and layered over the top at the admin level
> rather than put in the tech.  I think it is relatively
> safe to ignore it.
>

It's part of PGP. It's also patented. US patent 6,314,190.

	Jon

---

From: Adam Back <[email-masked]>
Date: Thu, 21 Jul 2005 07:08:42 -0400

> it, which is one of the amusing ironies about the thing.

Ian's right, you're wrong, it is true.  

I definitely recall this event in testimony from Freeh being in the
news, using PGP's ADK/ARR/???  (several renames I forget all the
names) feature as an example of how key recovery was possible.

Probably you can dig it up with google and the right search terms.

Adam

---

From: Ian Grigg <[email-masked]>
Date: Thu, 21 Jul 2005 13:25:46 +0100

The events of 1997-1998 were pretty charged and
created a split in the pgp community.  My intent was
not to re-open that battle, but to point out to Ben
that it is unlikely that the subpacket concerned will
ever be documented.  It's status as "undocumented"
is more than just accidental, and if he or anyone
wants to figure it out he's just going to have to ask
everyone in private email.

So I suggest we leave it there.  Energies spent on
finishing the darn thing would be energies much
better spent.

iang
-- 
Advances in Financial Cryptography, Issue 2:
   https://www.financialcryptography.com/mt/archives/000498.html
Mark Stiegler, An Introduction to Petname Systems
Nick Szabo, Scarce Objects
Ian Grigg, Triple Entry Accounting