Subject: Re: Suggested changes for DSA2

From: [email-masked] ("Hal Finney")
Date: Mon, 27 Mar 2006 14:08:15 -0800 (PST)

As an implementor, the question remains: when I verify a signature, what
q sizes should I allow for a given p?  For example, what q is OK for a p
of 1536?  What q is OK for a p of 4096?  Should I just make something up?
How is that going to promote interoperability?

Hal

---

From: David Shaw <[email-masked]>
Date: Mon, 27 Mar 2006 17:32:16 -0500

> How is that going to promote interoperability?

For implementation of signature verification you can just take p and q
straight from the public key.  You don't need to guess since the key
has all the information you need.

David