Subject: Multiple signatures over a document

From: "Nickolay L." <[email-masked]>
Date: Wed, 11 Oct 2006 13:21:50 +0300

Hi!

I cannot resolve, how to correctly calculate multiple signatures over
the document. I'm hashing entire document body + beginning of
signature (as described in 2440), and everything is ok.
But, when I'm producing two old-style signatures :
1) GnuPG checks only the first one, and says that it's ok
2) PGP 8.1 checks both, but says that first one is invalid, and the
second is ok

Producing two new-style signatures (with one-pass signature packets),
getting :
1) GnuPG checks both, and says that they're correct.
2) PGP 8.1 checks both, and says that first is invalid, and second one
is valid.

It seems, that PGP calculates the signature over the whole document +
bodies of other signatures.

But from 2440 it seems, that signed hash must not include other
signatures.

Please, anybody can clearly describe, what behavior is correct?

And, maybe, such situation must be described in 2440?

--
  Best regards,Nickolay mailto:<[email-masked]>

---

From: Jon Callas <[email-masked]>
Date: Wed, 11 Oct 2006 12:42:32 -0700

> And, maybe, such situation must be described in 2440?

Could you provide a sample document to show the issue?

	Jon

---

From: "Nickolay L." <[email-masked]>
Date: Thu, 12 Oct 2006 18:53:21 +0300

Hello Jon,

JC> Could you provide a sample document to show the issue?

I've sent it privately. Do you have any ideas 'bout?

---

From: "Nickolay L." <[email-masked]>
Date: Fri, 13 Oct 2006 11:51:23 +0300

Hello Jon,

JC> Could you provide a sample document to show the issue?
Hm, i've sent files as soon as you sent first request.
Maybe, there were some problems with mail server.
Here is second attempt :

1) two example keypairs (password for both is 'password').
2) encrypted and signed file without one-pass entities
3) encrypted and signed file with one-pass entities