Subject: [openpgp] chairs for chartering process

From: Stephen Farrell <[email-masked]>
Date: Fri, 01 May 2015 20:14:14 +0100

Hi all,

First - many thanks to all of you who volunteered to help by chairing.
It's really encouraging that so many were willing and able, which was
the case for I think everyone who volunteered.

Having spoken to a few folks, I'm delighted to say that Daniel Kahn
Gillmor and Christopher Liljenstolpe (both cc'd on this) have agreed
to help out as chairs for the re-formed openpgp WG.

Christopher has lots of experience with chairing in the IETF and dkg
as you know is very active in lots of security things including PGP
so I think they should be a great team to help us move forward.

Daniel and Christopher will take it from here with the intent being
to try craft a charter along the lines we've already discussed on the
list and I'll start the formal chartering process once they tell me
that's sufficiently baked (so no need for a BoF before starting). And
then we all can get moving on getting the work done.

So please join me in thanking Christopher and Daniel for being
willing to help out and please help them by continuing to contribute
as constructively as you have collectively been doing.

Cheers and thanks again all,
Stephen.

---

From: "Christopher LILJENSTOLPE" <[email-masked]>
Date: Fri, 01 May 2015 13:43:02 -0700

Greetings, and thank's Stephen (I think) for the opportunity

	Daniel and I have been talking a bit about the working group, and a 
charter.  We'd like to put some of those ideas to the list for 
discussion.  Ideally, it would be good if we could have some consensus 
about a charter within the next week or two to start the formation 
process.

We would like to scope this WG fairly tightly, therefore:

1) The primary charter goal would be create a RFC4880bis document.
    a) At the end of that process, we would either re-charter, or close.
    b) Other documents (informational or bcp) MAY be entertained by the 
WG, but are not required for the WG to complete it's task, nor    will 
their progress "keep the WG from closing"

2) We will require at least two independent reviews (from within the WG) 
of an individual submission before a document is considered a candidate 
for WG acceptance.  The chairs will help chide reviewers, but we want to 
see interest in the WG in a document before it progresses.

3) We are going to try and run this group virtually as much as possible 
(i.e. we will only physically meet if necessary).

	What do you all think about these as chartering concepts?

	Christopher

--
李柯睿
Avt tace, avt loqvere meliora silentio
Check my PGP key here: http://www.asgaard.org/cdl/cdl.asc
Current vCard here: http://www.asgaard.org/cdl/cdl.vcf

---

From: Kathleen Moriarty <[email-masked]>
Date: Fri, 1 May 2015 21:43:00 -0400

Sent from my iPhone

> On May 1, 2015, at 4:43 PM, "Christopher LILJENSTOLPE" <[email-masked]> wrote:
> 

Thanks for taking this on.
> 
>    Daniel and I have been talking a bit about the working group, and a charter.  We'd like to put some of those ideas to the list for discussion.  Ideally, it would be good if we could have some consensus about a charter within the next week or two to start the formation process.
> 
>   b) Other documents (informational or bcp) MAY be entertained by the WG, but are not required for the WG to complete it's task, nor    will their progress "keep the WG from closing"
> 
> 2) We will require at least two independent reviews (from within the WG) of an individual submission before a document is considered a candidate for WG acceptance.  The chairs will help chide reviewers, but we want to see interest in the WG in a document before it progresses.
> 
> 3) We are going to try and run this group virtually as much as possible (i.e. we will only physically meet if necessary).
> 
Tight scope, making sure there is adequate interest in drafts, and operating mostly on list all sounds good.

Thank you,
Kathleen
> _______________________________________________
> openpgp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/openpgp

---

From: "Christopher LILJENSTOLPE" <[email-masked]>
Date: Fri, 01 May 2015 21:42:55 -0700

You are welcome Kathleen

	Christopher

On 1 May 2015, at 18:43, Kathleen Moriarty wrote:

>> discussion.  Ideally, it would be good if we could have some 
>> consensus about a charter within the next week or two to start the 
>> formation process.
>>
>> WG, but are not required for the WG to complete it's task, nor    
>> will their progress "keep the WG from closing"
>>
>> 2) We will require at least two independent reviews (from within the 
>> WG) of an individual submission before a document is considered a 
>> candidate for WG acceptance.  The chairs will help chide reviewers, 
>> but we want to see interest in the WG in a document before it 
>> progresses.
>>
>> 3) We are going to try and run this group virtually as much as 
>> possible (i.e. we will only physically meet if necessary).
>>
> Tight scope, making sure there is adequate interest in drafts, and 
> operating mostly on list all sounds good.
>
> Thank you,
> Kathleen
>>
>> Christopher
>>
>>
>>

---

From: Ben McGinnes <[email-masked]>
Date: Sat, 02 May 2015 19:56:49 +1000

On 2/05/2015 6:43 am, Christopher LILJENSTOLPE wrote:
> about a charter within the next week or two to start the formation process.
> 

Sounds good and it's not like any extraneous docs can't be rolled into
some other proposal if needed, maybe even stand alone informational
RFCs.

> see interest in the WG in a document before it progresses.

Also fine.

> (i.e. we will only physically meet if necessary).

Excellent, I know I've said before that operating online as much as
possible is my preference.  Flying to the USA or Europe right now is
completely out of the question in my case.

That said, depending on the nature of any physical meeting, providing
a means of participation for those of us a little farther afield would
be good.  PPAU does this every year for our congresses so it's
feasible, usually with a designated person to monitor an IRC channel
for responses and video or audio streaming via whatever method is most
appropriate (for audio a Mumble server will do in a pinch).

>     What do you all think about these as chartering concepts?

Sounds like a good plan.

Regards,
Ben

---

From: "Christopher LILJENSTOLPE" <[email-masked]>
Date: Sun, 03 May 2015 15:40:47 -0700

Greetings Ben,

	Comments in line....

> some other proposal if needed, maybe even stand alone informational

That's our thoughts.

>> see interest in the WG in a document before it progresses.

Thx

> appropriate (for audio a Mumble server will do in a pinch).

I've been at the end of an IRC/Jabber room trying to get attention for meetings I can't attend, so I have felt that frustration.  When I chair, I TRY and have on of the chairs watching the room(s), as well as the scribe.   It doesn't always work, but we will try to make it as easy as possible.

	Christopher

---

From: Werner Koch <[email-masked]>
Date: Mon, 04 May 2015 11:17:26 +0200

Hi,

and thanks for taking up this job.

> their progress "keep the WG from closing"

I am fine with that.

I am a bit curious why the IETF seems to have a policy to have only
short living working groups.  A hint to a document explaining that would
be appreciated.

Shalom-Salam,

   Werner

-- 
Die Gedanken sind frei.  Ausnahmen regelt ein Bundesgesetz.

---

From: Derek Atkins <[email-masked]>
Date: Mon, 04 May 2015 09:31:35 -0400

Congrats to DKG and Chris!  My hats off to you (literally :)

Good Luck, and let me know if there's any way I can help.

-derek

PS: I do have two drafts that I posted to this list last year that I'd
like to progress.  I've already received multiple independent reviews :)

-- 
       Derek Atkins                 617-623-3745
       [email-masked]             www.ihtfp.com
       Computer and Internet Security Consultant

---

From: Derek Atkins <[email-masked]>
Date: Mon, 04 May 2015 09:33:29 -0400

> short living working groups.  A hint to a document explaining that would

There isn't a written policy on it.

But from personal expierience people get burned out after a while.  When
a WG first starts there is usually a lot of energy, but that fades, so
groups that last a long time tend to attrophy.

---

From: "Christopher LILJENSTOLPE" <[email-masked]>
Date: Wed, 06 May 2015 11:12:54 -0700

Greetings Werner,

Our friendly AD can chime in here, but here's my take.

Working Groups have a tendency to continue to exist past their "use-by" date.  As they do, the quality and velocity of their output tends to decline.  There are some counterexamples, but, unfortunately, there are a lot of positive proof-points.  What we've tried to do is have long-lived "research this area and see if there is something we can do" work move into the IRTF, and leave the IETF for actually actioning on specific requirements.  

However, this is, after all, the community's working group, so if the community feels that the scope (and therefore, duration) should be more expansive, we can propose that for a charter, but the larger the charter, the more "convincing" we need to do, especially if the technology is mature like PGP is.

	Christopher

--
李柯睿
Avt tace, avt loqvere meliora silentio
Check my PGP key here: http://www.asgaard.org/cdl/cdl.asc
Current vCard here: http://www.asgaard.org/cdl/cdl.vcf
keybase: https://keybase.io/liljenstolpe

---

From: Werner Koch <[email-masked]>
Date: Thu, 07 May 2015 10:17:04 +0200

On Wed,  6 May 2015 20:12, [email-masked] said:

> Working Groups have a tendency to continue to exist past their
> "use-by" date.  As they do, the quality and velocity of their output
> tends to decline.  There are some counterexamples, but, unfortunately,

I understand.

> more expansive, we can propose that for a charter, but the larger the
> charter, the more "convincing" we need to do, especially if the
> technology is mature like PGP is.

I am fine with 

>>>  a) At the end of that process, we would either re-charter, or close.

this.

Salam-Shalom,

   Werner