Subject: [openpgp] Patch to clarify OCB implementation, add test vectors for EAX/OCB, compatible implementations available

From: Ronald Tse <[email-masked]>
Date: Tue, 6 Feb 2018 20:50:42 +0000

Greetings,

We’ve just created a merge request to RFC4880bis master at the following link with patch attached.

https://gitlab.com/openpgp-wg/rfc4880bis/merge_requests/11

This patch clarifies implementation details of OCB, removes description of OCB’s history, and provides test vectors for AEAD modes, including both EAX and OCB. This patch is mainly from the work of my colleague Nickolay.

Probably worth a brief mention, that there are now two fully compatible AEAD-EAX / AEAD-OCB OpenPGP implementations, namely GnuPG and RNP (https://github.com/riboseinc/rnp).

Kind regards,
Ron

_____________________________________

Ronald Tse
Ribose Inc.

---

From: Werner Koch <[email-masked]>
Date: Fri, 16 Feb 2018 11:42:23 +0100

> This patch clarifies implementation details of OCB, removes description of OCB’s history, and provides test vectors for AEAD modes, including both EAX and OCB. This patch is mainly from the work of…

Thanks.  I pushed this to the repo.

Shalom-Salam,

   Werner

-- 
Die Gedanken sind frei.  Ausnahmen regelt ein Bundesgesetz.

---

From: Ronald Tse <[email-masked]>
Date: Fri, 16 Feb 2018 17:09:22 +0000

Thank you very much for your help Werner!

Kind regards,
Ron

Ronald Tse
Ribose Inc.

> On Feb 16, 2018, at 12:50 AM, Werner Koch <[email-masked]> wrote:
>