Subject: Re: [openpgp] rfc4880bis and draft-openpgp-iana-registry-updates-01

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 2 Dec 2018 19:01:51 -0600

On Sat, Dec 01, 2018 at 07:21:43AM +0000, Ronald Tse wrote:
>    Hi Ben, Derek,
> 
>      Derek is absolutely right, here.
> 
>    I fully agree that managing two documents is more complex than handling
>    one.
> 
>      I'll note that for TLS 1.3 we did separate documents, RFCs 8446 and
>      8447,
>      since there were a *lot* of registry changes and we did want a permanent
>      record of them, but that split caused a lot of extra work to ensure
>      things
>      were synchronized during AUTH48.
> 
>    However, the OpenPGP IANA update document was created from a suggestion by
>    the Security AD, where the TLS registry update model was the acceptable
>    role model to follow. RFC 8447 is at 17 pages; this document is close to
>    30 - the OpenPGP IANA registries are numerous and changes to them many,
>    since a lot of them have been dilapidated since the days of 2440.
>    If we merge this into 4880bis and remove them at publication, we're adding
>    30 pages (temporarily) and then maybe removing 25 at publication. And we
>    lose the permanent record that RFC 8447 provides for TLS. Perhaps there is
>    an argument that the registries of OpenPGP aren't as important (!) as
>    TLS's for permanent record keeping, and therefore should be relegated to
>    an Internet-Draft, but it doesn't sound like a good reason to forgo that.
>    Given that the IETF process has already processed the pair of 8446/8447
>    successfully in a synchronized way, would it be possible that it's even
>    easier this time round?

Most of the pain of 8447 was on the WG chairs and AD to manually do
consistency checks.  I don't expect much of an efficiency gain from
practice, but I suppose there are probably ways to distribute the work that
we did not explore very well for 8447.

-Ben

---

From: Derek Atkins <[email-masked]>
Date: Mon, 03 Dec 2018 11:58:51 -0500

> we did not explore very well for 8447.

And we don't have a WG chair here.......

> -Ben

-derek
-- 
       Derek Atkins                 617-623-3745
       [email-masked]             www.ihtfp.com
       Computer and Internet Security Consultant

---

From: Ronald Tse <[email-masked]>
Date: Mon, 3 Dec 2018 17:26:56 +0000

I thought we were only left with a mailing list without a WG... ;-)

In any case, could the consistency checks can be done by the authors and RFC editors instead?

On Dec 4, 2018, at 12:58 AM, Derek Atkins <[email-masked]<mailto:[email-masked]>> wrote:

Benjamin Kaduk <[email-masked]<mailto:[email-masked]>> writes:

-Ben

-derek
--
      Derek Atkins                 617-623-3745
      [email-masked]<mailto:[email-masked]>             www.ihtfp.com<http://www.ihtfp.com>
      Computer and Internet Security Consultant

_____________________________________

Ronald Tse
Ribose Inc.

---

From: Derek Atkins <[email-masked]>
Date: Thu, 06 Dec 2018 10:17:21 -0500

> I thought we were only left with a mailing list without a WG... ;-)

Exactly.

> In any case, could the consistency checks can be done by the authors and RFC

Do YOU want to go ask them to do all this work?  Seriously?  That's
pretty unfair, just to meet some personal sense of "better".

Let's just make the changes in 4880bis and make everyone's life easier,
at the expense of potentially losing the historical reference if we
decide to remove the IANA actions from the final RFC.

N.B. that we don't have to remove the actions if we don't want to.

-derek

---

From: Ronald Tse <[email-masked]>
Date: Fri, 7 Dec 2018 00:43:44 +0000

Responses inline.

Do YOU want to go ask them to do all this work?  Seriously?

Sorry for the confusion — this proposal is made from my perspective of being one of the listed authors — what I meant is that “I” myself would be happy to take on the verification work to keep both documents in sync for publication.

From my understanding of the RFC Editor, who does an amazing job with edits, verification is something they will do anyway. The better the quality of the draft submitted by the authors, the less work the RFC Editor has to perform.

Anyway, if we’re going to integrate both documents, it seems like “I” will be the one responsible for doing so. My hope is to avoid duplicate work. But if that’s the consensus, I can combine the documents.

We’re talking about integrating 30 pages of addition material to 4880bis. I really don’t see how this makes the review of the content any easier. Instead, it is a lot more digestible (for everyone involved) to keep these two documents separate?

Ron

On Dec 6, 2018, at 11:17 PM, Derek Atkins <[email-masked]<mailto:[email-masked]>> wrote:

Ronald Tse <[email-masked]<mailto:[email-masked]>> writes:

Exactly.

In any case, could the consistency checks can be done by the authors and RFC
editors instead?

-derek

Ronald Tse
Ribose Inc.