Subject: [Openv6] possible use of APONF in realising google's view on application based policy

From: <[email-masked]>
Date: Thu, 19 Jun 2014 06:40:25 +0000

Dear all,

In this email I will try to clarify the scope of APONF by using an example.

This example is based on how the view of google on application based policy could be realised in the context of IETF.

The main goal of application based policy according to google is:

"Google’s goal here is to create an abstracted view of the network, so that you’re programming the abstraction, rather than manipulating individual devices. That way, you can write software that programs an arbitrary network.", cited from:

http://www.sdncentral.com/news/google-open-source-help-policy-based-sdn/2014/06/

This vision can be realised within the IETF as follows:

The abstract view of the network can be realised by using the Service Function Path (SFP), specified by the IETF SFC WG.

In adition to this, a way is needed to provide the SFP network view to application developers, such that the application developer can use this SFP during the development, but also runtime phases, such that the application can utilize the network configuration and resources in the most optimum way.

Note that a Service Function Path (SFP) is being specified in the IETF SFC WG.

What APONF can do is the following (scope of APONF):

o) monitor and verify the freshness of the Service Function Path (SFP)

o) distribute the SFP to network management applications (OSS applications). Note that a network management application are Operational Support System (OSS) applications
that help a communications service provider to monitor, control, analyze and manage a communication network.

o) any modifications done by network management applications on an SFP are communicated to the network management system

o) The network management system needs to use the updated SFP and implement the possible configuration changes! This action is out of the APONF scope.

Comments are very much appreciated!

Best regards,
Georgios Karagiannis

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Sat, 28 Jun 2014 12:53:35 +0000

Dear Georgios,

I agree that this may be a strong use case to show how a service provider to make good use of APONF, specially on the words "abstracted view of the network, so that you're programming the abstraction", which IMHO means to abstract the common parts and models from the existing complex and  diversiform network devices and architectures. During our survey in last year for the Openv6 work, we found that the network devices and architectures vary from each other in different countries. This may be a headache especially to those big global network service companies like google, as they may need to change their programming strategy according to the particular scenarios.

And you're right. The points you listed are out of scope of SFC WG, and should be covered in IETF.

I think a detailed use case draft describing the google case may be very helpful to clarify the scope as well as to enhance the significance of APONF.

Regards,
Will

From: Openv6 [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, June 19, 2014 2:40 PM
To: [email-masked]
Subject: [Openv6] possible use of APONF in realising google's view on application based policy

Dear all,

"Google's goal here is to create an abstracted view of the network, so that you're programming the abstraction, rather than manipulating individual devices. That way, you can write software that programs an arbitrary network.", cited from:

Best regards,
Georgios Karagiannis