Subject: [Openv6] Another question: the name of the functionalities

From: "Jose Saldana" <[email-masked]>
Date: Mon, 9 Jun 2014 17:31:44 +0200

Hi,
 
Another question is how to name the set of functionalities you are
considering in APONF:
 
- In the first paragraph, they are called "traffic capabilities": " the
communication network to apply the following different network management
and/or traffic capabilities"
 
- Later, they are called "traffic policies": "Examples of such network
management and traffic policies that are considered by APONF are the
following"

I think that finding a good name grouping these actions is crucial:
 
Manage dynamically network semantics
Orchestrate dynamically virtualized functions 
Permit or Block or Redirect the traffic
Log the traffic 
Copy the traffic 
Set the traffic 
Mark the traffic
 
Are they traffic policies? Network actions? Network functionalities? Network
capabilities? Traffic capabilities? Network management actions?

What do you think?
 
Jose Saldana

---

From: Felix <[email-masked]>
Date: Mon, 9 Jun 2014 16:39:04 +0000

Hi all,

I prefer "Network capabilities" for grouping these actions.

Best regards!

Felix

________________________________
发件人: Openv6 [[email-masked]] 代表 Jose Saldana [[email-masked]]
发送时间: 2014年6月9日 23:31
收件人: [email-masked]
主题: [Openv6] Another question: the name of the functionalities

Hi,

Another question is how to name the set of functionalities you are considering in APONF:

- In the first paragraph, they are called “traffic capabilities”: “ the communication network to apply the following different network management and/or traffic capabilities”

- Later, they are called “traffic policies”: “Examples of such network management and traffic policies that are considered by APONF are the following”

Are they traffic policies? Network actions? Network functionalities? Network capabilities? Traffic capabilities? Network management actions?

What do you think?

Jose Saldana

---

From: <[email-masked]>
Date: Mon, 9 Jun 2014 17:38:05 +0000

Hi Jose,

Thanks for the comments!
It is somehow difficult to find the right name for all these terms, since these capabilities can be network management capabilities, traffic conditioning capabilities, traffic routiong capabilities, etc.

I am not sure if it is needed to find just one name for these terms!

Best regards,

Georgios

Hi,

What do you think?

Jose Saldana

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Tue, 10 Jun 2014 06:35:27 +0000

+1
IMHO, this one is appropriate.

Regards,
Will (Shucheng LIU)

From: Openv6 [mailto:[email-masked]] On Behalf Of Felix
Sent: Tuesday, June 10, 2014 12:39 AM
To: Jose Saldana; [email-masked]
Subject: [Openv6] 答复: Another question: the name of the functionalities

Hi all,

Best regards!

Felix

________________________________
发件人: Openv6 [[email-masked]] 代表 Jose Saldana [[email-masked]]
发送时间: 2014年6月9日 23:31
收件人: [email-masked]<mailto:[email-masked]>
主题: [Openv6] Another question: the name of the functionalities
Hi,

What do you think?

Jose Saldana

---

From: "Hosnieh Rafiee" <[email-masked]>
Date: Tue, 10 Jun 2014 08:43:09 +0200

Hi all,

   GiLan is another important application of network function
virtualization. You may consider to add this into your PS draft.

Best,

Hosnieh

From: Openv6 [mailto:[email-masked]] On Behalf Of Liushucheng
(Will)
Sent: Tuesday, June 10, 2014 8:35 AM
To: Felix; Jose Saldana; [email-masked]
Subject: Re: [Openv6] 答复: Another question: the name of the
functionalities

+1

Regards,

Will (Shucheng LIU)

Hi all,

Best regards!

Felix

  _____  

发件人: Openv6 [[email-masked]] 代表 Jose Saldana [jsaldana@unizar.
es]
发送时间: 2014年6月9日 23:31
收件人: [email-masked]
主题: [Openv6] Another question: the name of the functionalities

Hi,

- In the first paragraph, they are called “traffic capabilities”: “ the
communication network to apply the following different network management
and/or traffic capabilities”

- Later, they are called “traffic policies”: “Examples of such network
management and traffic policies that are considered by APONF are the
following”

Log the traffic 

Copy the traffic 

Set the traffic 

Mark the traffic

 

What do you think?

Jose Saldana

---

From: <[email-masked]>
Date: Tue, 10 Jun 2014 06:47:25 +0000

Hi Hosnieh,

Thank you very much!

Can you please provide text?

Best regards,

Georgios

________________________________
Van: Openv6 [[email-masked]] namens Hosnieh Rafiee [[email-masked]]
Verzonden: dinsdag 10 juni 2014 8:43
Aan: [email-masked]
Onderwerp: Re: [Openv6] 答复: Another question: the name of the functionalities

Hi all,
   GiLan is another important application of network function virtualization. You may consider to add this into your PS draft.
Best,
Hosnieh

From: Openv6 [mailto:[email-masked]] On Behalf Of Liushucheng (Will)
Sent: Tuesday, June 10, 2014 8:35 AM
To: Felix; Jose Saldana; [email-masked]
Subject: Re: [Openv6] 答复: Another question: the name of the functionalities

+1

Regards,
Will (Shucheng LIU)

From: Openv6 [mailto:[email-masked]] On Behalf Of Felix
Sent: Tuesday, June 10, 2014 12:39 AM
To: Jose Saldana; [email-masked]<mailto:[email-masked]>
Subject: [Openv6] 答复: Another question: the name of the functionalities

Hi all,

Best regards!

Felix

What do you think?

Jose Saldana

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Tue, 10 Jun 2014 06:50:59 +0000

Hi Hosnieh,

Thank you for your suggestion. You’re right. GiLAN is a good case that we should consider adding this.

Regards,
Will (Shucheng LIU)

From: Openv6 [mailto:[email-masked]] On Behalf Of Hosnieh Rafiee
Sent: Tuesday, June 10, 2014 2:43 PM
To: [email-masked]
Subject: Re: [Openv6] 答复: Another question: the name of the functionalities

Hi all,

From: Openv6 [mailto:[email-masked]] On Behalf Of Liushucheng (Will)
Sent: Tuesday, June 10, 2014 8:35 AM
To: Felix; Jose Saldana; [email-masked]<mailto:[email-masked]>
Subject: Re: [Openv6] 答复: Another question: the name of the functionalities

+1

Regards,
Will (Shucheng LIU)

Hi all,

Best regards!

Felix

What do you think?

Jose Saldana

---

From: "Jose Saldana" <[email-masked]>
Date: Tue, 10 Jun 2014 10:16:54 +0200

Hi, Georgios. My idea is: the IETF is a standardization body, so the terms
do matter. One has to be consistent and to clearly establish a “glossary of
terms” to be used always the same way.
 
In addition, it could be a very good exercise to try to summarize the
objective of APONF in a single sentence. Something like this (from the draft
charter):
 
“The main goal of APONF is to specify the application-based policy
protocol(s), mechanisms and models required  by transport applications to
easily, accurately, and efficiently select and use the available
communication network capabilities, i.e., network management and/or traffic
policies.”
 
So here Tina talks about “network management and/or traffic policies.”

Jose
 
De: [email-masked] [mailto:[email-masked]] 
Enviado el: lunes, 09 de junio de 2014 19:38
Para: [email-masked]; [email-masked]
Asunto: RE: [Openv6] 答复: Another question: the name of the functionalities
 
Hi Jose,
 
Thanks for the comments!
It is somehow difficult to find the right name for all these terms, since
these capabilities can be network management capabilities, traffic
conditioning capabilities, traffic routiong capabilities, etc.

Best regards,
Georgios

  _____  

 

 

What do you think?
 
Jose Saldana

---

From: Qiong <[email-masked]>
Date: Tue, 10 Jun 2014 18:06:26 +0800

Hi Jose,

Thanks for your comment. I think network capability is a more general work
which can be applied to different scenarios. In APONF, we are focusing more
on traffic-related capabilities, so I prefer the term more specific to
"traffic".

Best wishes

-- 
==============================================
Qiong Sun
China Telecom Beijing Research Institude

Open source code:
lightweight 4over6: *http://sourceforge.net/projects/laft6/
<http://sourceforge.net/projects/laft6/>*
PCP-natcoord:* http://sourceforge.net/projects/pcpportsetdemo/
<http://sourceforge.net/projects/pcpportsetdemo/> *
===============================================

On Tue, Jun 10, 2014 at 4:16 PM, Jose Saldana <[email-masked]> wrote:

> objective of APONF in a single sentence. Something like this (from the
> draft charter):
>
>
>
> *De:* [email-masked] [mailto:[email-masked]]
> *Enviado el:* lunes, 09 de junio de 2014 19:38
> *Para:* [email-masked]; [email-masked]
> *Asunto:* RE: [Openv6] 答复: Another question: the name of the
> functionalities
>
>
>
> Hi Jose,
>
>
>
> Thanks for the comments!
> ------------------------------
>
> *发件人**:* Openv6 [[email-masked]] 代表 Jose Saldana [
> [email-masked]]
> *发送时间**:* 2014年6月9日 23:31
> *收件人**:* [email-masked]
> *主题**:* [Openv6] Another question: the name of the functionalities
>
> Hi,
>
>
>
> Are they traffic policies? Network actions? Network functionalities?
> Network capabilities? Traffic capabilities? Network management actions?
>
>
>
>
>
> What do you think?
>
>
>
> Jose Saldana
>
>
>
> _______________________________________________
> Openv6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/openv6
>
>

-- 
==============================================
Qiong Sun
China Telecom Beijing Research Institude

Open source code:
lightweight 4over6: *http://sourceforge.net/projects/laft6/
<http://sourceforge.net/projects/laft6/>*
PCP-natcoord:* http://sourceforge.net/projects/pcpportsetdemo/
<http://sourceforge.net/projects/pcpportsetdemo/> *
===============================================

---

From: Qiong <[email-masked]>
Date: Tue, 10 Jun 2014 18:07:59 +0800

Agree. This is also an important use case. We would add it in the next
version.

Thanks!

Qiong

On Tue, Jun 10, 2014 at 2:43 PM, Hosnieh Rafiee <[email-masked]> wrote:

> *From:* Openv6 [mailto:[email-masked]] *On Behalf Of *Liushucheng
> (Will)
> *Sent:* Tuesday, June 10, 2014 8:35 AM
> *To:* Felix; Jose Saldana; [email-masked]
> *Subject:* Re: [Openv6] 答复: Another question: the name of the
> functionalities
>
>
>
> +1
>
> *From:* Openv6 [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Felix
> *Sent:* Tuesday, June 10, 2014 12:39 AM
> *To:* Jose Saldana; [email-masked]
> *Subject:* [Openv6] 答复: Another question: the name of the functionalities
>
>
>
> Hi all,
>
>
>

Open source code:

---

From: "Hosnieh Rafiee" <[email-masked]>
Date: Tue, 10 Jun 2014 17:25:56 +0200

Hi Georgios,

  GiLan is another important application of network function virtualization.
In mobile core networks, it is preferable that QoS provisioning and network
function requirements are different for subscribers with different profiles.
In such scenarios, specialized applications such as BSS/OSS can  send
service policies to a policy decision point, which further map these service
policies to GiLan specific VNF policies, and realize the required QoS and
with appropriate network functions, for example, video transcoding
parameters, traffic steering points, etc.

Best,

Hosnieh

From: Openv6 [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Tuesday, June 10, 2014 8:47 AM
To: [email-masked]; [email-masked]
Subject: Re: [Openv6] 答复: Another question: the name of the
functionalities

Hi Hosnieh,

Thank you very much!

Best regards,

Georgios

  _____  

Van: Openv6 [[email-masked]] namens Hosnieh Rafiee
[[email-masked]]
Verzonden: dinsdag 10 juni 2014 8:43
Aan: [email-masked]
Onderwerp: Re: [Openv6] 答复: Another question: the name of the
functionalities

Hi all,

Best,

Hosnieh

+1

Regards,

Will (Shucheng LIU)

Hi all,

Best regards!

Felix

  _____  

Hi,

 

Log the traffic 

Copy the traffic 

Set the traffic 

Mark the traffic

 

What do you think?

Jose Saldana

---

From: <[email-masked]>
Date: Tue, 10 Jun 2014 20:15:42 +0000

Hi Hosnieh,

Thank you very much!
We will consider it for the next version of the problem statement draft!

Best regards,

Georgiois

________________________________
Van: Hosnieh Rafiee [[email-masked]]
Verzonden: dinsdag 10 juni 2014 17:25
Aan: Karagiannis, G. (EWI); [email-masked]
Onderwerp: RE: [Openv6] 答复: Another question: the name of the functionalities

Hi Georgios,

  GiLan is another important application of network function virtualization. In mobile core networks, it is preferable that QoS provisioning and network function requirements are different for subscribers with different profiles. In such scenarios, specialized applications such as BSS/OSS can  send service policies to a policy decision point, which further map these service policies to GiLan specific VNF policies, and realize the required QoS and with appropriate network functions, for example, video transcoding parameters, traffic steering points, etc.

Best,
Hosnieh

From: Openv6 [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, June 10, 2014 8:47 AM
To: [email-masked]; [email-masked]
Subject: Re: [Openv6] 答复: Another question: the name of the functionalities

Hi Hosnieh,

Thank you very much!

Best regards,

Georgios

Aan: [email-masked]<mailto:[email-masked]>

+1

Regards,
Will (Shucheng LIU)

Hi all,

Best regards!

Felix

What do you think?

Jose Saldana

---

From: <[email-masked]>
Date: Tue, 10 Jun 2014 20:57:24 +0000

Hi Jose,

Thank you very much!

I agree with you that the used terminology in all drafts needs to be clear!

A better terminology section will be included in a next version of the problelmet statement draft!

However, please note that what I meant in the previous email is that it is difficult and it is not needed to find only one term/name that incorporates all the capabilities that have an impact on APONF.

In order to be clear we need to list all the capabilities (not only an aggregated one) that have an impact on the mechanisms and solutions that will be worked out by APONF.

Best regards,

Georgios

________________________________
Van: Jose Saldana [[email-masked]]
Verzonden: dinsdag 10 juni 2014 10:16
Aan: Karagiannis, G. (EWI); [email-masked]
Onderwerp: RE: [Openv6] 答复: Another question: the name of the functionalities

Hi, Georgios. My idea is: the IETF is a standardization body, so the terms do matter. One has to be consistent and to clearly establish a “glossary of terms” to be used always the same way.

In addition, it could be a very good exercise to try to summarize the objective of APONF in a single sentence. Something like this (from the draft charter):

“The main goal of APONF is to specify the application-based policy protocol(s), mechanisms and models required  by transport applications to easily, accurately, and efficiently select and use the available communication network capabilities, i.e., network management and/or traffic policies.”

Jose

Hi Jose,

Thanks for the comments!

Best regards,

Georgios

What do you think?

Jose Saldana

---

From: "Jose Saldana" <[email-masked]>
Date: Wed, 11 Jun 2014 14:38:35 +0200

Fully agree.
 
Best regards,
 
Jose
 
De: Openv6 [mailto:[email-masked]] En nombre de
[email-masked]
Enviado el: martes, 10 de junio de 2014 22:57
Para: [email-masked]; [email-masked]
Asunto: Re: [Openv6] 答复: Another question: the name of the functionalities
 
Hi Jose,
 
Thank you very much!
I agree with you that the used terminology in all drafts needs to be clear!
A better terminology section will be included in a next version of the
problelmet statement draft!
However, please note that what I meant in the previous email is that it is
difficult and it is not needed to find only one term/name that incorporates
all the capabilities that have an impact on APONF.
 
In order to be clear we need to list all the capabilities (not only an
aggregated one) that have an impact on the mechanisms and solutions that
will be worked out by APONF.
 
Best regards,
Georgios
 
  _____  

Onderwerp: RE: [Openv6] 答复: Another question: the name of the

 

Jose
 
De: [email-masked] [mailto: <mailto:[email-masked]>
[email-masked]] 
Enviado el: lunes, 09 de junio de 2014 19:38
Para: [email-masked]; [email-masked]
Asunto: RE: [Openv6] 答复: Another question: the name of the functionalities
 
Hi Jose,
 
Thanks for the comments!

Best regards,
Georgios

  _____  

 

 

What do you think?
 
Jose Saldana