Subject: RE: Protocol Performance

From: <[email-masked]>
Date: Wed, 26 Jun 2002 16:42:30 -0400

Hi Ian,

I agree with you, after double-checking with the Alteon products information on the Nortel website, that a L7 switch like the Alteon web switch (in the Alteon products suite) cannot be used as an OPES device. However, I am not sure if I agree with you that the L7 switch cannot be controlled by either end. Control by the receiver doesnt seem to be feasible. However, coupled with the Alteon Web OS product, control by the sending side is possible!

-Srinivas

> -----Original Message-----
> From: ext Ian Cooper [mailto:[email-masked]]
> Sent: Wednesday, June 26, 2002 4:31 AM
> To: Gamze Seckin
> Cc: [email-masked]
> Subject: Re: Protocol Performance
> 
> 
> 
> --On 25 June 2002 16:34 -0700 Gamze Seckin <[email-masked]> wrote:
> 
> >2. Is it safe to say that a L7 switch (web switch, e.g. nortel
> > alteon) is a simplified OPES device (since ICAP is not an 
> requirement)?
> > If not, why?
> 
> No.
> 
> The L7 switch isn't a known entity in the communication path 
> between the 
> parties engaged in the request-response chain and as such can't be 
> controlled by either of the parties.
> 
>

---

From: Ian Cooper <[email-masked]>
Date: Wed, 26 Jun 2002 21:56:25 +0100

--On Wednesday, June 26, 2002 16:42 -0400 [email-masked] 
wrote:

> Hi Ian,
>
> I agree with you, after double-checking with the Alteon products
> information on the Nortel website, that a L7 switch like the Alteon web
> switch (in the Alteon products suite) cannot be used as an OPES device.
> However, I am not sure if I agree with you that the L7 switch cannot be
> controlled by either end. Control by the receiver doesnt seem to be
> feasible. However, coupled with the Alteon Web OS product, control by the
> sending side is possible!

I don't know enough about that product's remote configuration capabilities, 
but if content side can control it using a network-based protocol then the 
consumer side could also control it (all done out of band at the 
application layer, obviously).

The fact that such a protocol exists seems tangential to the point here, 
however.  RFC3238 consideration 2.2 would appear to be in play anyway.