Subject: RE: Unique Shared Secrets (4.4.2) in opes-authorization

From: "Abbie Barbir" <[email-masked]>
Date: Wed, 23 Oct 2002 10:18:47 -0400

eric,

The intend here is to secure the Hop-by-hop traffic. We can reaxime the
wording and the requirements.

-- This will be added as an action item for the -01 draft.

Abbie

> -----Original Message-----
> From: Eric Burger [mailto:[email-masked]] 
> Sent: Monday, October 21, 2002 10:35 PM
> To: OPES Group
> Subject: Unique Shared Secrets (4.4.2) in opes-authorization
> 
> 
> 
> Why must the shared secrets be unique for each requestor / 
> responder pair? Why do we care?  In fact, such a requirement 
> opens a security hole: I can guess someone else's key by 
> trying to enter keys until the "system" tells me I can't 
> because someone else has that key.
> 
> I would drop the bullet.
> 
>

---

From: <[email-masked]>
Date: Mon, 28 Oct 2002 16:07:07 -0500

Hi,
I had a look at the opes-authorization draft again, and I too was not really convinced of the need for "unique" shared secrets for each requestor/responder pair. The only way I can see for the integrity and confidentiality of OPES data (application) flow to be compromised is:
 
1. Two different data streams (with different "content consumers" and same or different "content providers") share the same OPES device.
2. One of the two CC's is malicious.
3. In this event, if the shared secrets for each requestor/responder pair are not unique, then the integrity and confidentiality of OPES data could be compromised.
 
However, if all the OPES CC's can be trusted, then uniqueness is not needed, IMHO!
 
-Srini

-----Original Message-----
From: ext Abbie Barbir [mailto:[email-masked]]
Sent: Wednesday, October 23, 2002 10:19 AM
To: [email-masked]; OPES Group
Subject: RE: Unique Shared Secrets (4.4.2) in opes-authorization

eric, 

The intend here is to secure the Hop-by-hop traffic. We can reaxime the wording and the requirements. 

Abbie 

> From: Eric Burger [ mailto:[email-masked]]

---

From: <[email-masked]>
Date: Mon, 28 Oct 2002 17:11:42 -0500

Hi,
I forgot to include a few words in my previous response on this issue! When I wrote "The only way I can see for the integrity and confidentiality of OPES data (application) flow to be compromised ", what I meant was that, if the shared keys are not unique, then the OPES data flow integrity could be compromised by the suggested technique.
 
-Srini

-----Original Message-----
From: ext [mailto:[email-masked]]
Sent: Monday, October 28, 2002 4:07 PM
To: [email-masked]; [email-masked]; [email-masked]
Subject: RE: Unique Shared Secrets (4.4.2) in opes-authorization

Hi,

 
-Srini

-----Original Message-----
From: ext Abbie Barbir [mailto:[email-masked]]
Sent: Wednesday, October 23, 2002 10:19 AM
To: [email-masked]; OPES Group
Subject: RE: Unique Shared Secrets (4.4.2) in opes-authorization

eric, 

Abbie

---

From: "Abbie Barbir" <[email-masked]>
Date: Tue, 29 Oct 2002 06:17:51 -0500

Sirini,
 
thanks for  the feedback. we will add this as an action item for the -01
draft.
 
abbie

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] 
Sent: Monday, October 28, 2002 4:07 PM
To: Barbir, Abbie [CAR:1A00:EXCH]; [email-masked];
[email-masked]
Subject: RE: Unique Shared Secrets (4.4.2) in opes-authorization

Hi,
I had a look at the opes-authorization draft again, and I too was not really
convinced of the need for "unique" shared secrets for each
requestor/responder pair. The only way I can see for the integrity and
confidentiality of OPES data (application) flow to be compromised is:
 
1. Two different data streams (with different "content consumers" and same
or different "content providers") share the same OPES device.
2. One of the two CC's is malicious.
3. In this event, if the shared secrets for each requestor/responder pair
are not unique, then the integrity and confidentiality of OPES data could be
compromised.
 
However, if all the OPES CC's can be trusted, then uniqueness is not needed,
IMHO!
 
-Srini

-----Original Message-----
From: ext Abbie Barbir [mailto:[email-masked]]
Sent: Wednesday, October 23, 2002 10:19 AM
To: [email-masked]; OPES Group
Subject: RE: Unique Shared Secrets (4.4.2) in opes-authorization

eric, 

Abbie 

> From: Eric Burger [mailto:[email-masked]
<mailto:[email-masked]> ]