Subject: ICAP header extensions

From: "Martin Stecher" <[email-masked]>
Date: Tue, 28 Jan 2003 08:42:57 +0100

Hi,

the ICAP protocol defines in section 4.3:
"User-defined header extensions are allowed. [... They] MUST follow the "X-"
naming convention [...]"

There are already a bunch of user-defined headers in use, unfortunately only two of them have been published officialy (X-Client-IP and X-Subscriber-ID in draft-beck-opes-icap-subid-00.txt), many more have been exchanged between organisations.

With the growing number of ICAP client and server implementations we see more and more user-defined headers being introduced.
Unfortunately there are already some with the identical meaning but different names.

To ensure further interoperability even beyond the standard feature set, I propose that we publish the X-headers that are in use.

Please find below a first list of headers that I am going to describe in the next days. Maybe we can simply extend the draft-beck-opes-icap-subid-00.txt document.

There is also a definition for an OTPIONS response's opt-body format that will be included in the description.

Knowing that there are more X-headers out there, I invite everybody to send his/her headers with a short discription so that we can add them to the document.
As soon as I hear about other headers and get the confirmation that their description can be published, I will add them as an ongoing process.

Best Regards
Martin Stecher

Current list - has to be extended, specifications will be added:

REQMOD/RESPMOD request headers
	X-Client-IP
	X-Server-IP
	X-Subscriber-ID
	X-Authenticated-User		
	X-Authenticated-Groups

REQMOD/RESPMOD response headers
	X-Attribute
	X-Attribute-Cacheability
	X-Attribute-Prefix
	X-ICAP-Profile

OPTIONS response headers
	X-Include

OPTIONS response opt-body
	Opt-Body-Type: Attribute-List

---

From: Alex Rousskov <[email-masked]>
Date: Tue, 28 Jan 2003 10:31:06 -0700 (MST)

On Tue, 28 Jan 2003, Martin Stecher wrote:

> the ICAP protocol defines in section 4.3: "User-defined header
> extensions are allowed. [... They] MUST follow the "X-" naming
> convention [...]"
>
> There are already a bunch of user-defined headers in use,
> unfortunately only two of them have been published officialy
> (X-Client-IP and X-Subscriber-ID in
> draft-beck-opes-icap-subid-00.txt), many more have been exchanged
> between organisations.
>
> With the growing number of ICAP client and server implementations we
> see more and more user-defined headers being introduced.
> To ensure further interoperability even beyond the standard feature
> set, I propose that we publish the X-headers that are in use.

Would it be a good idea to follow [1] and [2] with this?
Looks like those IDs attempt to solve the same problem.
 [1] http://www.ietf.org/internet-drafts/draft-klyne-msghdr-registry-06.txt
 [2] http://www.ietf.org/internet-drafts/draft-nottingham-hdrreg-http-00.txt

Alex.

-- 
                            | HTTP performance - Web Polygraph benchmark
www.measurement-factory.com | HTTP compliance+ - Co-Advisor test suite
                            | all of the above - PolyBox appliance