Subject: Fwd: RE: OPES protocol, pre-draft 01

From: jfcm <[email-masked]>
Date: Thu, 27 Feb 2003 08:11:20 +0100

A A typo of mine created some confusion. Sorry. Instead of this

>Service User <-----> dispatcher <----> Service Organizer
>                    /  ^      ^  \
>Other user       /    |      |    \  Other users
>                       v      v
>                 service <--> server  <----> service
>controler     /provider      dispatcher     provider
>external user 
>/                  ^            /^
>etc.. etc..                      |          /  |
>                                  v        /    v
>                                 etc.    /   alarms,logs 
>
>                                       /     etc
>                                     /
>                  other ONES domains

Please read that.

                                        Supervisor or
Service User <-----> dispatcher <----> Service Organizer
                    /  ^      ^  \
Other user        /   |      |   \  Other users
                       v      v
                  service <--> dispatcher <----> service
controler      /provider       / ^              provider
external user 
/               /  |             /  ^
etc.. etc..                  /   v           /    |
                             /  service     /      v
                   dispatcher   etc.      /   alarms,logs 

                                        /     etc
                                      /
                   other ONES domains

The difference is about the wrong typing "server<br>dispatcher" confusing 
with "server dispatcher".

I tried to keep it denser and using "server dispatcher" was a wrong wording 
(server's dispatcher was intended but I thought "'s" was only for 
persons?). Anyway using "server" as a separate machine was wrong. Using 
"secondary dispatcher" (like in the DNS) would also be wrong.

This only wants to show that there are thres building blccks:

- dispatchers
- services
- ends

That services are actually made of a service adminstrator triggering the 
services. and that the ends may be of tree different natures :

- user : they call and get the service
- organiser : they organize their access/responses to use the ONES (used on 
the flow)
- supervisor : they organize their responses as a permanent cooperative 
strategy.

This only shows that there is a simple (three building blocks, with limited 
number of building block types) but wich a lot more of interaction types 
than in the OPES draft model.

My only interest right now is that we understand clearly this way what is 
in the OPES area (in the charter of this group) and how it may benefit from 
ONES analysis (up to the WG to discuss issues over OPES charter). If we do 
not do that we risk to confuse?

jfc

---

From: Alex Rousskov <[email-masked]>
Date: Wed, 26 Feb 2003 15:50:35 -0700 (MST)

> This only wants to show that there are thres building blccks:

OPES includes dispatchers and services and excludes ends (beyond
application protocols the ends use). If you claim the above is
different from OPES at the building blocks level, then you need to
show that your ends need to communicate with dispatchers using ONES
protocols (not application protocols). I think you are doing that
later, where you tell us that "ends" are not necessarily "users" or
"content producers".

> That services are actually made of a service adminstrator triggering
> the services.

Possible under OPES.

> and that the ends may be of tree different natures :
>

Using an application protocol, I presume (not OPES/ONES protocol)? Or
do you expect a browser (for example) to be ONES-aware? In what way?

> - organiser : they organize their access/responses to use the ONES
> (used on the flow)

I do not understand this part. Organizers organize user messages? How
is this different from OPES dispatcher or processor role?

> - supervisor : they organize their responses as a permanent
> cooperative strategy.

I do not understand this part. Can you be more specific? What is a
permanent cooperative strategy? Does "their" refer to users? How is
this different from OPES dispatcher or processor role?

Also, where is a content producer (e.g., origin server)? Is that also
a service in ONES terminology? I would expect it to be one of the
"ends" since content producers are not ONES-aware.

> This only shows that there is a simple (three building blocks, with
> limited number of building block types) but wich a lot more of
> interaction types than in the OPES draft model.

I do not see more interaction yet. Perhaps that is because I do not
understand what "organiser" and "supervisor" are. All other entities
seem to match OPES entities well.

> My only interest right now is that we understand clearly this way
> what is in the OPES area (in the charter of this group) and how it
> may benefit from ONES analysis (up to the WG to discuss issues over
> OPES charter).

Same here! I think we are getting closer.

Thank you,

Alex.