Subject: RE: Start on OPES protocol work

From: "Abbie Barbir" <[email-masked]>
Date: Tue, 18 Feb 2003 11:36:12 -0500

Alex,
I think that u r right with your assumption.
Marshall, can u elaborate.

abbie

> -----Original Message-----
> From: Alex Rousskov [mailto:[email-masked]] 
> Sent: Tuesday, February 18, 2003 11:02 AM
> To: [email-masked]
> Subject: RE: Start on OPES protocol work
> 
> 
> 
> On Tue, 18 Feb 2003, Abbie Barbir wrote:
> 
> > http://beepcore.org/beepcore/specsdocs.jsp
> > http://www-106.ibm.com/developerworks/xml/library/x-beep2.html
> > http://www-106.ibm.com/developerworks/xml/library/x-beep/index.html
> 
> My understanding is that supporting BEEP requires supporting 
> XML because <start>, <greeting>, <profile>, and other XML 
> elements have to be supported. Please correct me if I am 
> wrong! I just want to make sure that XML-enemies know that 
> BEEP relies on XML...
> 
> It is possible to limit XML support to rigid parsing of the 
> few documented elements (we have done that in Web Polygraph 
> benchmark, for example). However, such limited support is the 
> "wrong thing to do" in general and is likely to cause 
> compatibility problems in the future.
> 
> Alex.
>

---

From: Marshall Rose <[email-masked]>
Date: Tue, 18 Feb 2003 08:50:00 -0800

> > wrong! I just want to make sure that XML-enemies know that 

beep's channel management uses xml to format messages. similarly, you
invoke sasl and tls using xml-formated messages. typically, these
messages get sent once per session, to "tune" the connection the way you
want it.
    
besides that, you're perfectly free to format your own messages however
you want, i.e., binary, 822, s-expressions, etc.

> > compatibility problems in the future.

the xml used by beep for the channel management/sasl/tls stuff is
purposefully restricted to permit minimal implementations. i've seen
some implementations get by using printf and sscanf.
    
/mtr