Subject: RE: SOAP and OCP

From: "Abbie Barbir" <[email-masked]>
Date: Tue, 22 Apr 2003 10:59:02 -0400

Oskar,

Agreed.
Although, I am sure that some will argue otherwise.
 We can address this now or may be address later with the SOAP draft.

ABbie

> -----Original Message-----
> From: Oskar Batuner [mailto:[email-masked]] 
> Sent: Tuesday, April 22, 2003 10:20 AM
> To: [email-masked]
> Subject: RE: SOAP and OCP
> 
> 
> 
> Another place for SOAP in OPES is access to 
> all reference and information points.
> 
> While there is a trend to postpone (preferably indefinitely 
> :) any specs that go beyond the definition of the reference - 
> still without such specs OPES achitsture is incomplete. 
> All references with undefined information structure look 
> more like a "fine print" - one that is not supposed to be read.
> 
> If we move some programmatically accessible information to 
> references without providing access specs - all 
> implementers are forced to create proprietary  access 
> formats and interoperability becomes a problem.
> 
> Should we look at this now?
> 
> Oskar
> 
> > -----Original Message-----
> > From: [email-masked] 
> > [mailto:[email-masked]]On Behalf Of Alex Rousskov
> > Sent: Tuesday, April 22, 2003 12:18 AM
> > To: [email-masked]
> > Subject: RE: SOAP and OCP
> > 
> > 
> > 
> > 
> > On Mon, 21 Apr 2003, Abbie Barbir wrote:
> > 
> > > On Mon, 21 Apr 2003, Alex Rousskov wrote:
> > >
> > > > My understanding is that any existing web service can already 
> > > > participate in an OPES system "as is" as long as the OPES 
> > > > processor using the service supports SOAP. However, such 
> > > > participation is outside of OCP scope because OCP is 
> not SOAP; OCP 
> > > > is a stand-alone protocol that has features not 
> described in SOAP 
> > > > specs. To support OCP, a web service must be modified.
> > >
> > > True, that is what I mean.
> > >
> > > > In other words, SOAP may be used as an OPES callout 
> protocol (from 
> > > > architectural point of view). However, the protocol we 
> are working 
> > > > on (OCP), is not identical to SOAP (but can be 
> implemented on top 
> > > > of SOAP). Modifications would be required for existing web 
> > > > services to support OCP.
> > >
> > > very true
> > >
> > > > Is my understanding correct? If it is, we may have a good 
> > > > compromise available: treat both OCP and SOAP as 
> possible callout 
> > > > protocols and make sure that OPES framework is not OCP- or 
> > > > SOAP-specific.  OPES implementations will use the most 
> appropriate 
> > > > protocol for their needs.
> > >
> > > I would love that.
> > 
> > Great! Given the above agreement, I would suggest that OCP 
> we work on 
> > right now is _not_ implemented on top of SOAP because:
> > 
> >   1a. SOAP does not deal well with opaque data exchange
> >   1b. efficient opaque data exchange is the primary goal of our OCP
> > 
> >   2.  SOAP strength (current deployment) can still be used whenever
> >     appropriate by OPES processors that support SOAP and either
> >     adapt SOAP-friendly data only or do not care about performance
> >     on binary data
> > 
> > Instead, I would suggest that the WG encourages Abbie to 
> write a "how 
> > to use SOAP as an OPES callout protocol" draft, supplying OPES 
> > implementors with an explicit OCP alternative. All WG documents 
> > (including those documenting tracing and bypass mechanisms) 
> will have 
> > to make sure that no specific callout protocol is assumed 
> in a general 
> > OPES context.
> > 
> > Any objections or further comments?
> > 
> > Thank you,
> > 
> > Alex.
>

---

From: "Abbie Barbir" <[email-masked]>
Date: Tue, 22 Apr 2003 20:48:35 -0400

Alex,

Agree

Abbie

> From: Alex Rousskov [mailto:[email-masked]] 
> Sent: Tuesday, April 22, 2003 7:51 PM
> Subject: Re: SOAP and OCP
> 
> 
> 
> On Tue, 22 Apr 2003, Markus Hofmann wrote:
> 
> > If there's a real need for having multiple callout protocols, let's 
> > have a discussion and see whether there's WG consensus to do so. 
> > Otherwise, I'd suggest we focus on getting a single callout 
> protocol 
> > done right, and base the companion documents around this protocol.
> >
> > Leaving too many options seems like a simple way to overcome 
> > controversy and to make everybody happy, but it might not always be 
> > the best choice in technical design.
> 
> I agree; you may have misinterpreted what we are after:
> 
> OPES architecture already assumes that adaptation can be done 
> by means other than OCP. Thus, we are not increasing 
> complexity or adding anything really new. We are simply 
> making a statement that OPES framework (tracing, bypass, and 
> such) should not depend on OCP because OCP is not the only 
> allowed way to do adaptation!
> 
> The fact that SOAP may be used as a callout protocol is just 
> a side-effect of the above statement. We will not focus on 
> SOAP. We will focus on "our" OCP. "How to use SOAP as an OPES 
> callout protocol" draft may (should??) end up having a single 
> normative sentence:
> 	use "as is"
> 
> Does this approach work for you?
> 
> Alex.
>

---

From: "Abbie Barbir" <[email-masked]>
Date: Tue, 22 Apr 2003 22:31:47 -0400

Markus,

No problem

Abbie

> From: Markus Hofmann [mailto:[email-masked]] 
> Sent: Tuesday, April 22, 2003 9:14 PM
> Abbie Barbir wrote:
> > The plan for now is to go ahead and get a transport for OCP 
> that best 
> > fits.
> 
> Absolutely, that's the goal!
> 
> > SOAP addresses some issues and is good in some situations.
> > We will readdress later.
> 
> Discussing the pros and cons of using SOAP (or other 
> protocols) as the 
> OCP transport is perfectly fine (and we already had some good 
> discussions around that topic). The goal of these discussions is to 
> decide on THE OCP transport - the result should be unambiguous, if 
> possible. The WG will then move forward with the selected OCP 
> transport and won't spend cycles on other alternatives.
> 
> If this sounds OK, we're in agreement.
> 
> -Markus
> 
>