Subject: Notification

From: "Abbie Barbir" <[email-masked]>
Date: Mon, 7 Apr 2003 18:53:25 -0400

With all the discussions on tracing, I discovered late today during my
attempt to summarize the discussion in a draft format that we have not yet
discussed Notification.

So, to start, 
1. What really triggers notification
   - End Application/user
2. Is the process automated
   - Rules triggers action, then error occurs OPES processor notify content
provider
   - Callout server dicovers errors and inform whom, OPES processor and it 
     then notify content provider?
3. How does this relate to Trust domains and Deployment
4. In the simplest case, can we say
   - Agent (consumer/provider application)  does not like the OPES actions,
invoke tracing (assuming that we have agreed on how) as a mechanism for
notification
(this is indirectly addressing notification)

5. Can we assume that notification is done on error only?
  - What is an error
    - Inavlid URL
    - Malformed Image etc..
    
6. How about Content Provider induced erros ( bad links or bad programming
practices)are they part of OPES Notification.

7. Can Notification be done offline (Poll OPES Servers at the end of
business day and check an error log file ?)

These are just thoughs for now

Abbie

---

From: Alex Rousskov <[email-masked]>
Date: Mon, 7 Apr 2003 17:38:02 -0600 (MDT)

Abbie,

	What is the difference between tracing and notification _if_
tracing is always-on (i.e., trace info is attached to every message)?
Both architecture and OCP requirements drafts do not define
"notification" (AFAIK), so I am not sure what the difference is.
Please clarify.

Thank you,

Alex.