Subject: RE: is there OPES prototype proxy?

From: "Abbie Barbir" <[email-masked]>
Date: Wed, 27 Aug 2003 10:01:01 -0400

Hi,

At this stage our charter does not focus on proxylet or how rules are loaded
to the opes processor.

Abbie

> -----Original Message-----
> From: Red K [mailto:[email-masked]] 
> Sent: Wednesday, August 27, 2003 9:05 AM
> To: Alex Rousskov
> Cc: [email-masked]
> Subject: Re: is there OPES prototype proxy?
> 
> 
> 
> Yes, I also mentioned that proxylet is not discussed
> for a long time. But what is the reason for this? 
> 
> Is it related to system efficiency and simple
> maintainance? I mean to setup one callout server is
> easy to maintain and higher efficient to carry out
> specific service than put them onto a single host.
> 
>  --- Alex Rousskov <[email-masked]>
> wrote: > 
> > On Wed, 27 Aug 2003, [iso-8859-1] Red K wrote:
> > 
> > > It is an fresh man's topic. But I still want to
> > know if there is any
> > > prototype OPES proxy that supports Proxylet Local
> > Execution
> > > Environment Java Binding V0.1. Thus I can develope
> > my proxylet
> > > because I am interested in OPES.
> > 
> > I am working on a prototype OPES proxy. It almost
> > talks OCP to a
> > prototype callout service being developed by Martin
> > Stecher. There is
> > no proxylet support. I heard proxylets were a
> > popular topic long time
> > ago, but there were no proxylets mentioned on this
> > list for quite a
> > while now. If you are interested in OPES, the
> > shortest path to a
> > working system may be to write a callout server that
> > speaks OCP. One
> > can write such a server in Java, of course.
> > 
> > HTH,
> > 
> > Alex.
> 
> __________________________________________________
> Do You Yahoo!?
> Play now and stand a chance to win cash prizes! 
> http://yahoo.com.sg/millionaire
>

---

From: Alex Rousskov <[email-masked]>
Date: Wed, 27 Aug 2003 09:12:16 -0600 (MDT)

> specific service than put them onto a single host.

I do not think that proxylets are always more or less efficient than
callout services. Same for the ease of maintenance. It all depends on
a particular environment and workload. Moreover, it is possible (if
not desirable!) to have a proxylet that communicates with the OPES
processor via OCP and, hence, is also a callout service.

Alex.

On Wed, 27 Aug 2003, Markus Hofmann wrote:

> Reason is that the OPES WG is chartered to specify the callout
> protocol and the rules language, but *not* a proxylet interface or a
> proxylet architecture - this would be a local implementation
> decision or standardized elsewhere.
>
> The OPES architecture does *not* rule out proxylet, but the focus of
> the WG is on the callout mechanism.

On Wed, 27 Aug 2003, Abbie Barbir wrote:

> At this stage our charter does not focus on proxylet or how rules
> are loaded to the opes processor.