Subject: I-D ACTION:draft-ietf-opes-smtp-use-cases-02.txt

From: [email-masked]
Date: Wed, 06 Jul 2005 15:50:02 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Open Pluggable Edge Services Working Group of the IETF.

	Title		: OPES SMTP Use Cases
	Author(s)	: A. Barbir, M. Stecher
	Filename	: draft-ietf-opes-smtp-use-cases-02.txt
	Pages		: 16
	Date		: 2005-7-6
	
The Open Pluggable Edge Services (OPES) framework is application
   agnostic.  Application specific adaptations extend that framework.
   This document describes OPES SMTP use cases and deployment scenarios
   in preparation for SMTP adaptation with OPES.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-opes-smtp-use-cases-02.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-opes-smtp-use-cases-02.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-opes-smtp-use-cases-02.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Tony Hansen <[email-masked]>
Date: Wed, 06 Jul 2005 16:16:03 -0400

I did a thorough review of this version of the document and really like
it. It has a number of small nits that I'll address in a separate email
message (typos, etc.), but I think that the basic document is fairly
well structured, succinct and clear.

The only semi-major change I'd consider making to it would be to copy a
version of Figure 2 (without the OCP callouts) into the Brief Overview,
after the paragraph "SMTP commands are...". Figure 1 and Figure 2 as
they are now have a lot of differrences, and it would make it clearer
when it gets to the current Figure 2 exactly what OPES is adding to the mix.

As I said, I think this is a good document.

	Tony Hansen
	[email-masked]

---

From: "Hector Santos" <[email-masked]>
Date: Wed, 6 Jul 2005 17:31:53 -0400

Extremely minor comment:

I really would not had commented on this,   but we just had a rather lengthy
discussion about proper syntax in the SMTP WG and how a systems may reject
the transaction due to improper syntax.  You need angle brackets around the
return path (MAIL FROM:) and forward path (RCPT TO:)
      C: MAIL FROM: <[email-masked]>
      S: 250 2.1.0 [email-masked]....Sender OK
      C: RCPT TO: <[email-masked]>
      S: 250 2.1.5 [email-masked] it might be best to show syntax
correct examples.

Minor stuff. Otherwise the document sounds look to me!

--
Hector Santos, Santronics Software, Inc.
http://www.santronics.com

----- Original Message -----
From: "Tony Hansen" <[email-masked]>
To: <[email-masked]>
Cc: "Markus Hofmann" <[email-masked]>
Sent: Wednesday, July 06, 2005 4:16 PM
Subject: Re: I-D ACTION:draft-ietf-opes-smtp-use-cases-02.txt

>
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.1 (MingW32)
> Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org
>
> iD8DBQFCzDwDxsSylYhzrRYRAp3pAKCcI4kt3KSwY7GDJPibuFreS8chYQCgwUDB
> hHvkmQae63aXHtj0/vbYaJA=
> =44s5
> -----END PGP SIGNATURE-----
>
>

---

From: William Leibzon <[email-masked]>
Date: Wed, 6 Jul 2005 21:56:05 -0700 (PDT)

Well, since you mention it, it might be good to remove extra space
after "MAIL FROM: and "RCPT TO:", same debate in ietf-smtp about
proper syntax, i.e. it should be:

       C: MAIL FROM:<[email-masked]>
       S: 250 2.1.0 [email-masked]....Sender OK
       C: RCPT TO:<[email-masked]>
       S: 250 2.1.5 [email-masked] it might be best to show syntax

> Minor stuff. Otherwise the document sounds look to me!

---
William Leibzon
   mailto: [email-masked]
Anti-Spam and Email Security Research Worksite:
   http://www.elan.net/~william/emailsecurity/
Whois & DNS Network Investigation Tools:
   http://www.completewhois.com