Subject: Re: OPES Rules Language

From: Markus Hofmann <[email-masked]>
Date: Mon, 25 Jul 2005 21:47:36 -0400

Folks,

what's the status of this effort? Anyone interested in making progress 
on the rules language and produce a draft?

If we don't see an initial draft (or a new revision of the "P" draft) 
by end of August 2005, I'll suggest to our ADs to remove this item 
from our charter.

Thanks,
   Markus

The Purple Streak, Hilarie Orman wrote:
> I'm going to give the rules language a shot by trying to author
> a draft that merges the best of P and Sieve.  Simple semantics
> and rich matching, with control points tailored to the OPES
> architecture.  Send your wish lists.
> 
> Hilarie
>

---

From: Markus Hofmann <[email-masked]>
Date: Mon, 25 Jul 2005 21:47:36 -0400

Folks,

Thanks,
   Markus

---

From: "The Purple Streak, Hilarie Orman" <[email-masked]>
Date: Tue, 26 Jul 2005 00:16:18 -0600

I am writing a draft, I expect to post it soon, but it won't have
a complete BNF grammar.  I'm concentrating on functionality
to support OPES:

  1. binding arguments to the OCP parameters so that copying
     can be avoided
  2. the linkage between the conditional part of the rules and the
     protocol parsers
      a. pre-parsed expressions
      b. signalling
  3. built-in actions
  4. state information
  5. caching
  6. runtime errors
  7. dynamic rules

I can't get anyone to explain how drafts are written these days, so
I'm using nroff.

Hilarie

---

From: Markus Hofmann <[email-masked]>
Date: Tue, 26 Jul 2005 09:31:16 -0400

Hilarie,

excellent, thanks, don't worry about not having a complete BNF grammar - 
it's important we get something going and then follow-up and continue to 
drive it forward together.

Thanks,
   Markus

---

From: Alex Rousskov <[email-masked]>
Date: Tue, 26 Jul 2005 14:25:41 -0600

On Tue, 2005-07-26 at 00:16 -0600, The Purple Streak, Hilarie Orman

> I can't get anyone to explain how drafts are written these days, so

If it is not too late, check out xml2rfc (xml.resource.org). Many think
it is the best approach available, and future IETF draft submission tool
will support xml2rfc schema.

I would be happy to send you P draft sources using xml2rfc schema, or
you can use the samples at the xml2rfc site as a starting point. It is
probably easy to convert simple nroff to xml2rfc; there may even be a
script to do that.

Alex.