Subject: [OPSEC] [Technical Errata Reported] RFC7404 (4183)

From: RFC Errata System <[email-masked]>
Date: Sun, 16 Nov 2014 14:09:50 -0800 (PST)

The following errata report has been submitted for RFC7404,
"Using Only Link-Local Addressing inside an IPv6 Network".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7404&eid=4183

--------------------------------------
Type: Technical
Reported by: Andreas Cudok <[email-masked]>

Section: 2.3

Original Text
-------------
Hardware dependency: LLAs have usually been based on 64-bit Extended
Unique Identifiers (EUI-64); hence, they change when the Message
Authentication Code (MAC) address is changed.

Corrected Text
--------------
Hardware dependency: LLAs have usually been based on 64-bit Extended
Unique Identifiers (EUI-64); hence, they change when the Media
Access Control (MAC) address is changed.

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7404 (draft-ietf-opsec-lla-only-11)
--------------------------------------
Title               : Using Only Link-Local Addressing inside an IPv6 Network
Publication Date    : November 2014
Author(s)           : M. Behringer, E. Vyncke
Category            : INFORMATIONAL
Source              : Operational Security Capabilities for IP Network Infrastructure
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 17 Nov 2014 11:23:47 +0000

Andreas

Thanks for the report.

There is indeed an error in RFC 7404 about the MAC expansion. I cannot
imagine how we (the authors) failed to spot it.

-éric