Subject: OSPF AREAS

From: "PLACID,JOSEPH (Non-A-India,ex1)" <[email-masked]>
Date: Wed, 24 Apr 2002 20:50:03 +0800

Sec 3, RFC 2328 says "A router actually has a seperate link-state database
for each area it is connected to"
But why is an area a defined to be a collection of links/interfaces.So a
router with interfaces connected to multiple areas (lets say two) will have
two seperate link state databases in its memory? Why can't an area be a
collection of routers? What are the advantages/disadvantages?

Joseph Placid

---

From: Acee Lindem <[email-masked]>
Date: Wed, 24 Apr 2002 15:21:23 -0400

Joseph,

PLACID,JOSEPH (Non-A-India,ex1) wrote:
> two seperate link state databases in its memory?

There is one database for the topology for each area. Areas are required
to provide a level of hierarchy. A separate SPF calculation is run for each
area. One can always use a single area if desired.

> Why can't an area be a collection of routers?

This is simply terminolgy. In the SPF algorithm, routers and multi-access
networks are graph verticies and links are their edges.

> What are the advantages/disadvantages?
>
>
> Joseph Placid
>
>

--
Acee

---

From: Erblichs <[email-masked]>
Date: Thu, 25 Apr 2002 11:34:08 -0700

Joeseph,

        If I understand your question I would suggest you
        look at the general docs that you can find for
        the Link state protocol (IS-IS: Intermediate
        System - Intermediate System : aka router-router).

        The L1/L2 ISIS router resides completely within
        one area where the ABR (area border router sits)
        on the edges of two areas) as a comparison. BTW,
        all ISIS routers sit within a specific area.

        The OSPF and ISIS Link state routing protocols are
        very similar and still have enough differences to
        be interesting. In my opinion.

        Mitchell Erblich
        ---------------------------