Subject: Re: ABR Summaries causing bad OSPF route paths

From: Don Goodspeed <[email-masked]>
Date: Wed, 14 May 2003 16:16:26 -0400

Mitchell,

If there is a need to give a set of routes a different cost than
the overall summary range, advertise a subset range on both ABRs.

For example, take the range 128.0.0.0/16 advertised on both ABRs.
One can then advertise a subset of this same range (128.0.192.0/24)
and the costing of this range of routes only would give the 2nd ABR
preference.

-don

 --- On Wed 05/14, Erblichs < [email-masked] > wrote:
From: Erblichs [mailto: [email-masked]]
To: [email-masked]
Date: Wed, 14 May 2003 12:14:44 -0700
Subject: ABR Summaries causing bad OSPF route paths

Group,<br><br>        I ran into what I call sys admin error in specifiying<br>        ABR summaries. This is due to the fact that each summary<br>        only carries a single weight. These summaries are<br>        advertised outside of the area. However, a better/shorter<br>        path may be to one of the summarized subnets via a<br>        different ABR but that 2nd ABR has summarized the subnet<br>        with a higher weight.<br><br>        Should / are RFCs existing that handle the incorrect<br>        summarizing and/or the improper weighting of the summaries?<br><br>        Should OSPF have a intelligence that tries to identify<br>        the proper level of summaries and/ or the weighting of such?<br><br>        Yes, I do realize that summaries have benefits dealing with<br>        decreased route tables, fewer OSPF control packets, etc.<br><br>        Mitchell Erblich<br>        Sr Software Engineer<br>

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

---

From: Erblichs <[email-masked]>
Date: Wed, 14 May 2003 13:59:32 -0700

Don,

        Thanks, I know how to summarize subnets.

        This investigation was requested by the "customer"
        after we reviewed this "issue".

        I was looking for a algorithm that can intelliently
        2nd guess a sys admin and might want to log a message.

        I was thinking about a summarization tree..

        Mitchell Erblich
        Sr Software Engineer