Subject: un-num p2p clarification.

From: kamatchi soundaram <[email-masked]>
Date: Mon, 5 May 2003 16:48:09 -0700

Hi all,

  I have the following two doubts in Un-num p2p for OSPF.

1) If I bring up an un-num p2p with one of the other interface's valid ip
address (ex. LAN), does the un-num p2p need to be associated with the same
"AREA" with which the LAN has been associated??? or can be associated with
an different area address.
More clearly: The router R1 has three interfaces, but interface #1 has a
valid IP address and other two are un-num p2p interfaces. So, the two un-num
p2p interfaces will use the Ip address of Interface #1. Assume, the
interface #1 got associated with Area 0. Now the question is, can the un-num
p2p interfaces be associted to some other AREA other than AREA 0 or not??

2) In implementation point of view:
Generally the numbered p2p and ethernet interfaces will be configured as
Net-number/Mask and AREA. Since in numbered IP case, each interface can be
specifically configured with Net num and mask and AREA.
But in the case of un-num p2p, how the configuration will be??
 For example what will be the net number and mask and area configuation??

Thanks in advance,
GKS.

---

From: alok <[email-masked]>
Date: Tue, 6 May 2003 12:41:37 +0530

> p2p interfaces be associted to some other AREA other than AREA 0 or not??

hi,

pardon me if this has already been asked,

can u please explain as to why they would use the "IP address" of interface
#1?

wouldnt Link-id be "router-id"?

-rgds
Alok

---

From: kamatchi soundaram <[email-masked]>
Date: Tue, 6 May 2003 10:21:03 -0700

Hi alok!

  To forward and process IP looks for valid IP address in the received
packet. Since in the case of un-num p2p, there is no specific IP address in
OSPF point of view, the Valid IP address of the other interface, will be
used as the source IP address in the IP Header.

Btw: That's the reason OSPF specifies, to configure un-num p2p to an
interface of a router, the router should have atleast one valid IP address
(it may be for LAN or for loop-back).

GKS.

---

From: Alok Dube <[email-masked]>
Date: Wed, 7 May 2003 00:21:52 +0530

Hi,

maybe im wrong..

....doesnt it say somewhere in the RFC that the router-id is given a /32
address in OSPF? and propogated?
-rgds
Alok

> packet. Since in the case of un-num p2p, there is no specific IP
> address in OSPF point of view, the Valid IP address of the other
> interface, will be used as the source IP address in the IP Header.
>
> interface of a router, the router should have atleast one valid IP
> address (it may be for LAN or for loop-back).
>
> GKS.
>> > 1) If I bring up an un-num p2p with one of the other interface's
>> > valid
> ip
>> > address (ex. LAN), does the un-num p2p need to be associated with
>> > the
> same
>> > "AREA" with which the LAN has been associated??? or can be
>> > associated
> with
>> > More clearly: The router R1 has three interfaces, but interface #1
>> > has a valid IP address and other two are un-num p2p interfaces. So,
>> > the two
>> un-num
>> > interface #1 got associated with Area 0. Now the question is, can
>> > the
>> un-num

---

From: j j <[email-masked]>
Date: Tue, 6 May 2003 13:23:08 -0700

On Cisco routers I believe that your un-numbered
interfaces will be in the same area as the interface
from which the ip address is borrowed.  If you
don't want this then use a loopback interface.

Your second question partly answers the first
question.
for the "network" command you have to use the
ipaddress/mask of the interface from which you are
borrowing.

--- kamatchi soundaram <[email-masked]>
>  For example what will be the net number and mask

__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com

---

From: kamatchi soundaram <[email-masked]>
Date: Tue, 6 May 2003 16:20:02 -0700

Yes! by looking at the CISCO routers, i do believe that un-numbered
interfaces will be in the same area as the interface from which IP address
is borrowes. But my question is why can't use different area address for the
un-numbered interfaces even though the IP address is borrowed from the other
interface and not from the Loop back interface??

GKS.

---

From: j j <[email-masked]>
Date: Tue, 6 May 2003 17:24:11 -0700

Its not clear to me why.  But their config commands
definitely does not support this.
for e.g. -

interface ethernet 0
  ip address 10.1.1.1 255.255.255.0

interface serial 0
  ip unnumbered interface ethernet 0

router ospf 99
  network 10.1.1.0 0.0.0.255 area 2

So both ethernet and serial interface would fall under
area 2.

It is not clear to me why it would not be possible to
have a command under interface to specify an ospf
area.

Do you have a good reason to not use a loopback
interface?

wrote:
> from which IP address
> > >   I have the following two doubts in Un-num p2p
> for
> > > OSPF.
> > >
> > > 1) If I bring up an un-num p2p with one of the
> other
> > > interface's valid ip
> > > address (ex. LAN), does the un-num p2p need to
> be
> > > associated with the same
> > > "AREA" with which the LAN has been associated???
> or
> > > can be associated with
> > > More clearly: The router R1 has three
> interfaces,
> > > but interface #1 has a
> > > p2p interfaces will use the Ip address of
> Interface
> > > #1. Assume, the
> > > p2p interfaces be associted to some other AREA
> other
> > > than AREA 0 or not??
> > >
> > > Generally the numbered p2p and ethernet
> interfaces
> > > will be configured as
> > > Net-number/Mask and AREA. Since in numbered IP
> case,
> > > each interface can be
> > > specifically configured with Net num and mask
> and
> > > AREA.
> > > But in the case of un-num p2p, how the
> configuration
> > > will be??
> > >  For example what will be the net number and
> mask
> > > and area configuation??
> > >
> > > Thanks in advance,
> > > GKS.
> >
> >

---

From: Acee Lindem <[email-masked]>
Date: Sun, 11 May 2003 14:27:25 -0400

> p2p interfaces be associted to some other AREA other than AREA 0 or not??

There is no protocol requirement for the two interfaces to be in the same
area or for the P2P link's reference interface to be advertised at all.

>  For example what will be the net number and mask and area configuation??

You are confusing a specific vendor's implementation with the OSPF specification.
Read RFC 2328 Appendix C.

--
Acee

---

From: kamatchi soundaram <[email-masked]>
Date: Tue, 13 May 2003 11:17:02 -0700

----- Original Message -----
From: "Acee Lindem" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, May 11, 2003 11:27 AM
Subject: Re: un-num p2p clarification.

> area or for the P2P link's reference interface to be advertised at all.
Consider the following set-up:
             | eth 0
           R1
           |  |
           |  |
           R2
            | eth0
In the above set-up, R1 and R2 connected by two un-num p2p interfaces. And
both does have one Lan interface.
The R1 router Lsa will have info as, two point to point links and one stub
link. Lets assume the un-num p2p interface MIB-2 index are 2 and 3 for p2p-1
and p2p-2 of Router R1 respectively. So, this will be advertised in the LSA
as a link data.
 Similarly, R2 will have two p2p links and one stub links. Assume mib-2 if
index are 4 and 5 for R2's p2p links.

 Then during next-hop calculation, the correct interface has to be
associated with the correct other end of the p2p link from R1 to R2. If we
don't have any interface reference detail (that is the other end interface
mib index value associated with either neighbor table or interface table),
then there is a chance that always for the both p2p-1 and p2p-2 of the R2
will be reachable via the same p2p-1 of R1. Which will basically makes the
packet forward always in the same interface. Either p2p-1 or p2p-2 of R1 to
R2.

 Even though the next hop address will be the same R2 router's lan ip
address to reach the R2's lan network, the packet originating interfaces at
R1 are different.

Well! there is a practical requirement for the above scenario. So, don't
discard that the above set-up will not be used anywhere. We face the above
scenario in our SONET and WDM networks.

---

From: Acee Lindem <[email-masked]>
Date: Tue, 13 May 2003 15:06:12 -0400

kamatchi soundaram wrote:
>>>1) If I bring up an un-num p2p with one of the other interface's valid
>>
> ip
>
>>>address (ex. LAN), does the un-num p2p need to be associated with the
>>
> same
>
>>>"AREA" with which the LAN has been associated??? or can be associated
>>
> with
>
>>>valid IP address and other two are un-num p2p interfaces. So, the two
>>
> un-num
>
>>>interface #1 got associated with Area 0. Now the question is, can the
>>
> un-num
>
>>>p2p interfaces be associted to some other AREA other than AREA 0 or
>>
> not??
>

GKS,

You simply use your view of which P2P links are up (as per your router LSA).
The backlink check can use any link for the area in question as per footnote 23
on page 182 of RFC 2328 (I can't remember who previous pointed this out but
thanks).

Thanks,
Acee

--
Acee