Subject: NSSA forwarding address

From: somnath mani <[email-masked]>
Date: Fri, 30 May 2003 00:47:44 -0700

Folks,
The RFC for NSSA states that we set the forwarding address in a type 7 LSA to be that of any interface on which OSPF is configured ( barring the scenario, when the interface to the other AS is internal to OSPF).
This is a problem when you are trying to do equal cost multipath routing and in some other situations.

Consider a router A with 2 interfaces configured to run OSPF, IF1 and IF2. The cost on both these interfaces is 10 , let's say.

If we pick the forwarding address to be IF2 ( We are redistributing at router A), then a router B adjacent to A over IF1 will compute the cost for a type 7 LSA route to be 10 + 10 = 20 ( Assume either ends of the interfaces are configured with same cost). Whereas, router C, adjacent to router A over IF2 will compute the same to be 10 !!

Routers upstream of Router B and C will prefer to route via C !

Would it not be better if we set the forwarding address to be the router ID ( provided we have added it as a stub host ) ?

Thanks
Somnath

---------------------------------
Do you Yahoo!?
Free online calendar with sync to Outlook(TM).

---

From: Vivek Dubey <[email-masked]>
Date: Fri, 30 May 2003 11:27:01 -0000

Hi Somnath,
RFC preference rule for picking Fwd addr

1) If the network between the NSSA AS boundary router and the
adjacent AS is
    advertised into OSPF as an internal OSPF route (choose next
hop)
2) Loop back interface
3) NSSA interface
4) Stub interface

 From what i understood from your mail :
if you choose loop back address problem
scenarion will not occur.

vivek

On Fri, 30 May 2003 somnath mani wrote :
>Folks,
>The RFC for NSSA states that we set the forwarding address in a
>type 7 LSA to be that of any interface on which OSPF is
>configured ( barring the scenario, when the interface to the
>other AS is internal to OSPF).
>Consider a router A with 2 interfaces configured to run OSPF, IF1
>and IF2. The cost on both these interfaces is 10 , let's say.
>
>If we pick the forwarding address to be IF2 ( We are
>redistributing at router A), then a router B adjacent to A over
>IF1 will compute the cost for a type 7 LSA route to be 10 + 10 =
>20 ( Assume either ends of the interfaces are configured with
>same cost). Whereas, router C, adjacent to router A over IF2 will
>compute the same to be 10 !!
>
>Would it not be better if we set the forwarding address to be the
>router ID ( provided we have added it as a stub host ) ?
>
>Thanks
>Somnath
>
>
>
>

___________________________________________________
Get email that means BUSINESS! me @ mycompany.com.
Just Rs.1499/year.
To start, click http://www.rediffmailpro.com

---

From: "Pat Murphy - (650)329-4044" <[email-masked]>
Date: Fri, 30 May 2003 08:31:04 -0700

NSSA RFC3101, states

   Normally the next hop address of an installed AS external route
   learned by an NSSA ASBR from an adjacent AS points at one of the
   adjacent AS's gateway routers. If this address belongs to a network
   connected to the NSSA ASBR via one of its NSSAs' active interfaces,
   then the NSSA ASBR copies this next hop address into the forwarding
   address field of the route's Type-7 LSA that is originated into this
   NSSA, as is currently done with Type-5 LSAs....

   ...For an NSSA with no such network the forwarding address
   field may only be filled with an address from one of the its active
   interfaces or 0.0.0.0.

Note in both cases the address must be chosen from one of the NSSA's
networks. This always applies. If no such address is available, 0.0.0.0
must be used and the P-bit must be clear. When forced to chose an
address from one of "the NSSA's active interfaces", the preference is

   1) Loop back interface
   2) Stub interface
   3) Any remaining interface

In all cases the network containing the non-zero forwarding address of a
Type 7 LSA must be part of the NSSA.

By the way it looks like the IETF OSPF WG page needs its Mailing Lists
updated.

Pat