Subject: Re: ABR Summaries causing bad OSPF route paths

From: Phil Chen <[email-masked]>
Date: Wed, 14 May 2003 15:41:07 -0400

I am not sure your weight concept, and I am assume you are refering to cost to destinations. If you care about optimal routing of IP packet to a particular set of destinations, for example an IP subnetwork, you can exclude it from your high level summary. There isn't much OSPF intellegence can help you here. Route summary is a tool to allow you to essentially defeat OSPF itelligence in exchange for scalability. At least OSPF gives admin a choice.

--Phil

-----Original Message-----
From: Erblichs [mailto:[email-masked]]
Sent: Wednesday, May 14, 2003 3:15 PM
To: [email-masked]
Subject: ABR Summaries causing bad OSPF route paths

Group,

        I ran into what I call sys admin error in specifiying
        ABR summaries. This is due to the fact that each summary
        only carries a single weight. These summaries are
        advertised outside of the area. However, a better/shorter
        path may be to one of the summarized subnets via a
        different ABR but that 2nd ABR has summarized the subnet
        with a higher weight.

        Should / are RFCs existing that handle the incorrect
        summarizing and/or the improper weighting of the summaries?

        Should OSPF have a intelligence that tries to identify
        the proper level of summaries and/ or the weighting of such?

        Yes, I do realize that summaries have benefits dealing with
        decreased route tables, fewer OSPF control packets, etc.

        Mitchell Erblich
        Sr Software Engineer

---

From: Phil Chen <[email-masked]>
Date: Wed, 14 May 2003 17:21:51 -0400

Mitchell,

I wasn't really refering it as a software tool, I meant it as OSPF feature. I casually pick the word "tool" to describe various protocol feature that you can use to solve your problems. Your CLI should have some command to allow you to do just what I said. That is the tool you are refering to. Some vendor also have a GUI based OSPF configuration tool, but I wasn't really refering to those tools in my original message.

--Phil

-----Original Message-----
From: Erblichs [mailto:[email-masked]]
Sent: Wednesday, May 14, 2003 5:12 PM
To: Phil Chen
Subject: Re: ABR Summaries causing bad OSPF route paths

Phil Chen,

        Are you saying that the route summary tool
        is released with your router's OS or are you
        saying that it is in the public domain or ..?

        Mitchell Erblich
        --------------