Subject: OSPF Refresh and Flooding Reduction in Stable Topologies

From: Vivek Dubey <[email-masked]>
Date: Fri, 23 May 2003 10:28:14 -0000

Padma,

1) Ospf LSA refreshing/aging provides robustness
    to protocol

2) Demand circuit proposed a special case
    compromising this robustness.

3) draft-pillay-esnault-ospf-flooding-05.txt :
    Proposes :
    "The flooding reduction capable routers will continue to send
hellos
    to their neighbors and keep their aging self-originated LSAs
in
    their database. However, they will flood their self-originated
LSAs
    with the DoNotAge bit set. Hence, self-originated LSAs need
not be
    reflooded unless there is change in the contents of the LSA.
"

Isn't the net effect is "do not age LSAs"....ways
to do that could be (aim here is to Refresh and Flooding
Reduction in Stable Topologies):

1)Either set DoNotAge bit (as above draft and RFC 1793 says)
OR
2)
   a)
   Avoid the aging concept, ie  dont do any
   flushing from database , if any LSA reaches maxage.

   Instead if LSA reaches maxAge , check as RFC 1793 says..
         (1) The LSA has been in the router's database for at
least
             MaxAge seconds.

         (2) The originator of the LSA has been unreachable
(according
             to the routing calculations specified by Section 16
of [1])
             for at least MaxAge seconds.

   Flush maxage LSA only if two above conditions are met.
   If not, probably reset the age to zero.

   b)As "draft-pillay-esnault-ospf-flooding-05.txt" says
     "self-originated LSAs need not be reflooded unless
      there is change in the contents of the LSA. "

Wont point (2) will have same effect as setting
"Do not age bit".....
Morevr one need not depend on demand circuit extension
also..
There could be few other issues with point (2) but wanted
to know comments of the group on the approach.

thanks,
vivek

___________________________________________________
Get email that means BUSINESS! me @ mycompany.com.
Just Rs.1499/year.
To start, click http://www.rediffmailpro.com

---

From: Acee Lindem <[email-masked]>
Date: Fri, 23 May 2003 13:56:30 -0400

Vivek,

The draft relies on RFC 1793 and uses the same mechanisms. Other
approachs are certainly possible.

Thanks,
Acee

--
Acee

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Fri, 23 May 2003 15:58:24 -0700

Hi Vivek

See comments below.

> 1) Ospf LSA refreshing/aging provides robustness

Yes in theory. IMHO if we had a lot of cases where only refresh
corrected malfunctions .. we would hear a lot of complaints that
OSPF is malfunctioning within a 30 minutes window.

>     compromising this robustness.
see above

> to know comments of the group on the approach.

There are major drawbacks to the approach in 2.

1. In the approach in (2) -- all routers will have to be
upgraded to deploy the feature. The originating routers
to block their flooding and the receiving routers
implement no aging in DB. In the draft only some routers
need to be upgraded to make the feature work as long as
the receiving routers understand DNA lsas.

2. So the routers receiving will not age any LSAs that they
received. By default I guess they will not age LSAs from
*all* routers or else you will have to configure that
on each receiving router. This is not very realistic.
More over how will you know if there are routers out
they that are aging their database and hence require
the originating router to refresh ?

All these cases are covered in the draft.
- the originator controls the flooding and how
its lsa should be treated by others.
- Use of indication lsas enables the originating
router to revert to normal flooding and DNA clear
if a router does not implement the DNA within the AS.
- No need to update all routers to get the feature working
- Configuration is only on the originating routers
with flooding reduction.

Padma