Subject: Re: DR election

From: "Zebaida, Dror (Dror)" <[email-masked]>
Date: Tue, 13 May 2003 15:03:48 +0300

I understand that if there is already a DR/BDR then R4 will not become the DR.
However, when an interface transitions out of the WAIT state, if it thinks it is
alone on the network, it declares itself the DR.  If after that, it connects to the
network, there are 2 routers declaring themselves DR. In our case R3 and R4.
At this stage, is a new DR elected, or does R3 remain the DR.

The scenario I am describing is R4 is conneced to the network after it transitioned
out of the WAIT state (after 40 seconds)

Thanks

-----Original Message-----
From: Russ White [mailto:[email-masked]]
Sent: Tuesday, May 13, 2003 2:56 PM
To: [email-masked]
Subject: Re: DR election

As long as there is already a dr on the link, R4 would not take over as the
DR. Or it shouldn't. Think of it this way: The DR isn't elected first, the
BDR is. Then the routers attached to the link "discover" there is no DR,
and promote the BDR to DR, and elect a new BDR.

:-)

Russ

On Tue, 13 May 2003, Dror wrote:

> Hi,
>
> I have a question regarding a DR election algorithm.  If I have a netowrk
> with 3 routers R1,-R3, each having the same priority and with router IDs
> 0.0.0.1, 0.0.0.2, 0.0.0.3 respectively.
>
> After a DR election process is done, R3 will be DR, R2 will be BDR and R1
> will be DR-Other.  This is the result of the DR election process since R3
> has the largest router ID.
>
> If I add a new router R4 with router ID 0.0.0.4, do I expect R4 to become
> the DR, or does it just become another DR-other since there is already a DR
> in the network.
>
> Does the result depend on whether R4 is connected to the network when it is
> still in the WAIT state, or the result is the same nevertheless.
>
> Thanks
> Dror
>

__________________________________
[email-masked] CCIE <>< Grace Alone

---

From: Acee Lindem <[email-masked]>
Date: Tue, 13 May 2003 09:28:05 -0400

Hi Dror,

> I understand that if there is already a DR/BDR then R4 will not become the DR.

As described succintly in Russ White's e-mail below.

> out of the WAIT state (after 40 seconds)

This really should never happen on a broadcast or NBMA network unless you have
some type of connectivity or an NBMA configuration problem. I have seen it happen
on an NBMA network if the existing DR and BDR are using the RFC 2328 appendix C
suggested X.25 poll interval of 2 minutes and all the DR eligible neighbors are
not configured as eligible on all the DR eligible routers. When it happens a new
DR election will be triggered and R4 will become DR. I believe R2 will remain
as BDR.

Thanks,
Acee

--
Acee

---

From: Michael J Barnes <[email-masked]>
Date: Tue, 13 May 2003 08:35:36 -0700

> out of the WAIT state (after 40 seconds)

In this case there is a "collision" which will force a DR election, so R4
will become the DR and R3 will become DROTHER.

Regards,
Michael

---

From: kamatchi soundaram <[email-masked]>
Date: Tue, 13 May 2003 10:47:41 -0700

Yes! i did see that happened.

 You can easily simulate this condition.

Connect R1, R2 and R3 to the Network first. In that R3 will become DR and R2
will Become BDR. Meantime, start R4 separately (mean, don't hook-up the R4
Lan cable to the network.). In that case, since R4 didn't see anyother
router in the network, it will become as DR.

 Then when you put the R4 also into the network, R4 will become the DR and
R2 remained as BDR.

Well! i had seen this scenario in my network.

GKS.