Subject: Re: AS scope Opaque LSA

From: Manral V-G19459 <[email-masked]>
Date: Tue, 22 Jul 2003 18:58:20 +0530

Hi Acee,

>> Minto - I think you've uncovered a problem here. A
>> router in an area other than the originating router
>> will not have route to the originating router and
>> will purge the stale DoNotAge LSA.
>>
> One solution would be for any router announcing any
> AS scoped LSA to advertise itself as an ASBR (as per
> its router bit in the router LSA). Other solutions
> are welcome :^)
How about the ABR originating Type-10 opaque LSA's, with
router ID's of routers still reachable and originate
global scope LSA's, which have reachability to the ABR.

It is backward compatibility and will not create problems
about multiple LSA's being injected into the domain (in
case every router advertizes type-11's :-)). This solution
can be made generic for OSPFv3, where we can have unknown
LSA types in the future.

Sounds reasonable?

Thanks,
Vishwas

---

From: Acee Lindem <[email-masked]>
Date: Wed, 23 Jul 2003 01:24:02 -0400

> global scope LSA's, which have reachability to the ABR.

Hi Vishwas,

Are you suggesting that ABRs advertise reachability for
all attached routers in a new LSA? If so, I don't think
we want a new mechanism. It seems it would be better
to just make any router originating a globally scoped
LSA an ASBR than invent a new way (other than the type
4 LSA) to advertise router reachability.

I may not have understood your suggestion.

Thanks,
Acee

--
Acee