Subject: Type-4 LSA

From: Chris Hellberg <[email-masked]>
Date: Thu, 17 Jul 2003 00:32:19 +1200

Hi,

With reference to this message (and yup, it's a long time ago):

http://peach.ease.lsoft.com/scripts/wa.exe?A2=ind9902&L=ospf&P=R52&I=-3

I'm still trying to figure out the purpose of the Type-4 LSA. From John's explanation, the type-4 LSA needs to be explicitly created to descibe the ABSR's presence, and hence there's reachability to the ASBR for other routers in other areas with the Type-5 LSAs.

I understand that there are separate "namespaces" to keep the types of data discrete, but wouldn't there be a summary LSA generated by an ABR that contains the same information as the Type-4 LSA? Why not use the fact that a summary route has a link-state-id set to the router id of the ABSR and the its its mask is a /32? I'm just curious as to why have the separate LSA if the information is already there? Is it due to the fact the type-3 LSA could get lost in summarisation, or that the two pieces of information in the summary LSA aren't absolute-enough information to rely on that summary LSA being a bona fide type 3 of the type 1 LSA?

Cheers,

Chris

------------------------------------------------------------------------------
"This communication, including any attachments, is confidential. 
If you are not the intended recipient, you should not read
it - please contact me immediately, destroy it, and do not
copy or use any part of this communication or disclose
anything about it. Thank you."
------------------------------------------------------------------------------

---

From: Acee Lindem <[email-masked]>
Date: Wed, 16 Jul 2003 09:47:13 -0400

Chris Hellberg wrote:
> I'm still trying to figure out the purpose of the Type-4 LSA. From John's
 > explanation, the type-4 LSA needs to be explicitly created to descibe
 > the ABSR's presence, and hence there's reachability to the ASBR for
 > other routers in other areas with the Type-5 LSAs.
>
> I understand that there are separate "namespaces" to keep the types of
> data discrete, but wouldn't there be a summary LSA generated by an ABR that
> contains the same information as the Type-4 LSA? Why not use the fact
> that a summary route has a link-state-id set to the router id of the ABSR
> and the its its mask is a /32? I'm just curious as to why have the separate
> LSA if the information is already there? Is it due to the fact the type-3 LSA
> could get lost in summarisation, or that the two pieces of information in the
 > summary LSA aren't absolute-enough information to rely on that summary
 > LSA being a bona fide type 3 of the type 1 LSA?

Chris,

The only information required in a type 5 or 7 LSA to link it to its
advertising router is the router ID. There is nothing to guarentee
that a router will advertise a /32 stub link corresponding to it's
router LSA.

Thanks,
Acee
P.S. Use /nl occasionally in your message next time :^)

--
Acee

---

From: Alok Dube <[email-masked]>
Date: Thu, 17 Jul 2003 17:51:33 +0530

Hi Acee,

This has nothing to do with the present way OSPF is implemented, but I
would like to know the following inline:

>> data discrete, but wouldn't there be a summary LSA generated by an ABR
>> that contains the same information as the Type-4 LSA? Why not use the
>> fact that a summary route has a link-state-id set to the router id of
>> the ABSR and the its its mask is a /32? I'm just curious as to why
>> have the separate LSA if the information is already there? Is it due
>> to the fact the type-3 LSA could get lost in summarisation, or that
>> the two pieces of information in the
> > summary LSA aren't absolute-enough information to rely on that
> > summary LSA being a bona fide type 3 of the type 1 LSA?
>
> Chris,
>
> advertising router is the router ID. There is nothing to guarentee that
> a router will advertise a /32 stub link corresponding to it's router
> LSA.

Can the type-5, when propogated into the rest of the AS not be linked to
the "router-id" of the ABR of the area from where the type-5 originated?
Within an area, the router-id is the unique identifier of the routes it
originates and the ABR in the area will know that "router-id" due to the
router-LSA orginated by the ASBR?
it would a bit like the present for type-3:

next-hop for external routes=ABR;
and at ABR, next-hop=path to router-id from where route was learnt?

pardon me if I am missing something/have missed something in the RFC.

why is it that in network summary type -3 LSAs we rely on ABR to relay the
packet to the destination (it modifies the type 3 and tells the area that
the path to the destn network is via itself),but for AS external LSAs, we
dont rely on ABR to do the same?
-thanks
Alok

---

From: Acee Lindem <[email-masked]>
Date: Thu, 17 Jul 2003 09:52:36 -0400

>>a router will advertise a /32 stub link corresponding to it's router

Hi Alok,

> the "router-id" of the ABR of the area from where the type-5 originated?

The ABR of the originating area won't help a non-ABR in a
non-backbone area.

> dont rely on ABR to do the same?

We do rely on the ABRs to generate a type 4 summary LSAs for ASBRs. I'm not
sure I get what you are trying to do.

--
Acee