Subject: Re: Incremental SPF calculation

From: Krishna Rao <[email-masked]>
Date: Tue, 8 Jul 2003 10:21:14 -0000

Hi Mitchell,
What i meant is doing SPF calculation
in incremental steps.
Reason being if LSDB is containing large
number of LSAs going for complete SPF calculation
will tie down the processor. Better if LSDB
is splitted in parts and each portion is used
for incremental calculation. At the same time maintaining
the sanity of routing table.

thanks,
krishna

On Tue, 08 Jul 2003 Erblichs wrote :
>Actually what you are looking for is documentation for
>is a incremental Equal Cost Multipath algorithm.
>
>Incremental in its most coarse form could be divided
>into a ECMP algothihm for each area and then for
>External LSAs..
>
>Mitchell Erblich
>Sr Software Engineer
>----------------------------
>
>Krishna Rao wrote:
> >
> > Is there any standard/non-standard documentation
> > available for incremental SPF calculation.
> >
> > krishna
> >
> > ___________________________________________________
> > Click below to experience Sooraj R Barjatya's latest
>offering
> > 'Main Prem Ki Diwani Hoon' starring Hrithik, Abhishek
> >   & Kareena http://www.mpkdh.com

___________________________________________________
Click below to experience Sooraj R Barjatya's latest offering
'Main Prem Ki Diwani Hoon' starring Hrithik, Abhishek
  & Kareena http://www.mpkdh.com

---

From: Erblichs <[email-masked]>
Date: Tue, 8 Jul 2003 04:09:02 -0700

Krishna,

        Read my lips, the main OSPF RFC specifies ECMP..
        If you impliment a SPF algorithm then you are
        out of OSPF RFC compliance.

        The SPF algorithm was developed by a mathematician
        (can't spell his name :-) ) and has some fundamental
        foundations for the ECMP algorithm.

        And incremental computations have been around
        for a few years. Try checking a few university
        web sites for theoritectical information..

        Else, you are going to have to pay a few dollars
        for a working example..

        Mitchell Erblich
        Sr Software Engineer
        ------------------------