Subject: AS scope Opaque LSA

From: "Jeyanath Minto J - CTD, Chennai." <[email-masked]>
Date: Thu, 17 Jul 2003 13:04:34 +0530

Hi ,
 i have few Question regarding AS scope Opaque LSA.

  1. Is it possible to originate an AS scope LSA by a non ASBR router.

  2. if Opaque LSA supports DNA , Then howcome we remove the Stale DNA
Opaque LSA.
              (This will Happen only, non ASBR router may originate AS scope
Opaque LSA)

  3. And , is there any As scope Opaque LSA currently used ?

Cheers
Minto Mascarenhas
**********************************************************************
The person who knows "how" will always have a job .
The person who knows "why" will always be his boss.
**********************************************************************

---

From: Acee Lindem <[email-masked]>
Date: Tue, 22 Jul 2003 09:32:39 -0400

From: Manral V-G19459
Sent: Tuesday, July 22, 2003 17:39
To: 'Mailing List'
Subject: RE: AS scope Opaque LSA

Hi Acee,

 >> Minto - I think you've uncovered a problem here. A
 >> router in an area other than the originating router
 >> will not have route to the originating router and
 >> will purge the stale DoNotAge LSA.
 >>
 > One solution would be for any router announcing any
 > AS scoped LSA to advertise itself as an ASBR (as per
 > its router bit in the router LSA). Other solutions
 > are welcome :^)
How about the ABR originating Type-10 opaque LSA's, with
router ID's of routers still reachable and originate
global scope LSA's, which have reachability to the ABR.

It is backward compatibility and will not create problems
about multiple LSA's being injected into the domain (in
case every router advertizes type-11's :-)). This solution
can be made generic for OSPFv3, where we can have unknown
LSA types in the future.

Sounds reasonable?

Thanks,
Vishwas

---

From: Manral V-G19459 <[email-masked]>
Date: Wed, 23 Jul 2003 11:23:25 +0530

Hi Acee,

I was thinking along the lines you stated. Incase we were using the DC extensions the ABR would inject the information of all reachable routers to the other area in an Opaque LSA.

But are you saying that we have a condition where a Router-originating Global Scope LSA's should also set itself as ASBR, whenever DC-extensions is enabled. Though a new mechanism is not introduced, the number of LSA's injected will be greatly increased.

Either ways we would want to state it somewhere. It would have an impact on DC extensions for Refresh Optimizations as the LSA's would get flushed often(if we did not set the router as ASBR). I think its however more an issue with OSPFv3 where the protocol is open to any Global Scope LSA and future extensions.

Thanks,
Vishwas

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]]
Sent: Wednesday, July 23, 2003 10:54
To: [email-masked]
Subject: Re: AS scope Opaque LSA

> global scope LSA's, which have reachability to the ABR.

Hi Vishwas,

Are you suggesting that ABRs advertise reachability for
all attached routers in a new LSA? If so, I don't think
we want a new mechanism. It seems it would be better
to just make any router originating a globally scoped
LSA an ASBR than invent a new way (other than the type
4 LSA) to advertise router reachability.

I may not have understood your suggestion.

Thanks,
Acee

--
Acee

---

From: "Jeyanath Minto J - CTD, Chennai." <[email-masked]>
Date: Wed, 23 Jul 2003 11:27:42 +0530

Hi Vishwas,
        if i understood right, its not very easy to implement. What Acce
Suggest is very Easy to Implement (Originate Type 4 LSA).
       see the issues in your apporach ,
               1. We Need to chose LSA (Type 10 ) Originating Router ( To
avoid duplicate LSA )
               2. Handle the Area Partion.

Cheers
Minto Mascarenhas

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]]
Sent: Wednesday, July 23, 2003 10:54 AM
To: [email-masked]
Subject: Re: AS scope Opaque LSA

Hi Vishwas,

Thanks,
Acee

--
Acee

---

From: Manral V-G19459 <[email-masked]>
Date: Wed, 23 Jul 2003 11:36:46 +0530

Hi Minto,

> 1. We Need to chose LSA (Type 10 ) Originating Router
> (To avoid duplicate LSA )
No reason to avoid duplicates, just like we work with summary LSA's right now. I think that will help in the second case you pointed too.

Agree?

Thanks,
Vishwas

-----Original Message-----
From: Jeyanath Minto J - CTD, Chennai.
[mailto:[email-masked]]
Sent: Wednesday, July 23, 2003 11:28
To: [email-masked]
Subject: Re: AS scope Opaque LSA

Hi Vishwas,

Cheers
Minto Mascarenhas

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]]
Sent: Wednesday, July 23, 2003 10:54 AM
To: [email-masked]
Subject: Re: AS scope Opaque LSA

Hi Vishwas,

Thanks,
Acee

--
Acee

---

From: "Jeyanath Minto J - CTD, Chennai." <[email-masked]>
Date: Wed, 23 Jul 2003 12:17:24 +0530

Hi Vishwas,

>>No reason to avoid duplicates, just like we work with summary LSA's right
now. I think that will help in the second case
>>you pointed too.

Agreed. Sloving Opaque LSA problem by Opaque LSA is nice. but We need one
more new bit to indicate the AS scope opaque LSA originator (Like ASBR bit
in router LSA).

Cheers,
Minto

-----Original Message-----

Hi Vishwas,

Cheers
Minto Mascarenhas

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]]
Sent: Wednesday, July 23, 2003 10:54 AM
To: [email-masked]
Subject: Re: AS scope Opaque LSA

Hi Vishwas,

Thanks,
Acee

--
Acee