Subject: Re: I-D ACTION:draft-ietf-ospf-ospfv3-auth-02.txt

From: [email-masked]
Date: Tue, 29 Jul 2003 12:47:05 -0500

Here is the change log:

- Mandate using the "smallest" prefix with "LA-bit" set as 
  the source and destination addresses for the packets 
  exchanged over the virtual links if the security is
  enabled.

- Added IPsec requirements section

- References divided in Normative and Informative

- Some editorial changes

- Some formatting errors corrected 

regards
Mukesh

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, July 29, 2003 9:15 AM
> To: [email-masked]
> Subject: I-D ACTION:draft-ietf-ospf-ospfv3-auth-02.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the Open Shortest Path First IGP 
> Working Group of the IETF.
> 
>         Title           : Authentication/Confidentiality for OSPFv3
>         Author(s)       : M. Gupta, N. Melam
>         Filename        : draft-ietf-ospf-ospfv3-auth-02.txt
>         Pages           : 8
>         Date            : 2003-7-29
> 
> This document describes means/mechanisms to provide
> authentication/confidentiality to OSPFv3 using IPv6 AH/ESP Extension
> Header.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-ospf-ospfv3-auth-02.txt
> 
> To remove yourself from the IETF Announcement list, send a message to
> ietf-announce-request with the word unsubscribe in the body 
> of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
>         "get draft-ietf-ospf-ospfv3-auth-02.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
>         [email-masked].
> In the body type:
>         "FILE /internet-drafts/draft-ietf-ospf-ospfv3-auth-02.txt".
> 
> NOTE:   The mail server at ietf.org can return the document in
>         MIME-encoded form by using the "mpack" utility.  To use this
>         feature, insert the command "ENCODING mime" before the "FILE"
>         command.  To decode the response(s), you will need 
> "munpack" or
>         a MIME-compliant mail reader.  Different 
> MIME-compliant mail readers
>         exhibit different behavior, especially when dealing with
>         "multipart" MIME messages (i.e. documents which have 
> been split
>         up into multiple messages), so check your local 
> documentation on
>         how to manipulate these messages.
> 
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: Acee Lindem <[email-masked]>
Date: Tue, 29 Jul 2003 16:50:43 -0400

>   exchanged over the virtual links if the security is

Hi Mukesh,

I think choosing the first address with the LA-bit set in
the intra-area prefix LSA (router ref-LSA-type) with the
numerically lowest Link-State ID is more efficient, easier for
both sides to implement, and gives the OSPFv3 implementation
greater freedom to influence the choice of a stable address
to be used for the Virtual Link endpoint.

What are the arguments for making this change? It could be possible
that I'm missing something :^) However, I think the dynamics are
similar of handling virtual link endpoints are similar with
both techniques.

Thanks,
Acee

--
Acee