Subject: Re: DB Synchronization

From: Shanthi Pendyala <[email-masked]>
Date: Fri, 29 Aug 2003 10:40:25 -0700

hi,

Router A will request a copy of the stale LSA from B even though it has the more upto-date LSA.

It will then immediately flood the updated LSA after
increasing the seq no.

so the DB exchange will complete..

shanthi kiran

-----Original Message-----
From: Parag Deshpande [mailto:[email-masked]]
Sent: Friday, August 29, 2003 10:13 AM
To: [email-masked]
Subject: DB Synchronization

Hi,

I had a doubt ->

2 routers A and B have an ospf adjacency.

Router A sends an ASExt lsa for network N1/m1 with LSID = N1.
Then Router A goes down & comes up again & reoriginates
ASExt lsa for network N1/m2 with LSID = N1 and then
gets adjacent with Router B.

**where m1 != m2 & they are multiple of 8. (/8, /16..)
also assuming that all other parameters are same.

However in this case the DB Exchange will fail to
synchronize these LSAs bcoz they appear
to be similar- LSID, SeqNum, Checksums being equal**
and thus will have to wait for the LSA to get refreshed.

I was wondering whether this can be resolved faster.

Thanks
Parag

---

From: Parag Deshpande <[email-masked]>
Date: Fri, 29 Aug 2003 14:34:19 -0500

I will be more clear here --

- Router A originates the LSA with seq no = 80000001 (Say mask is /8)
- Router B receives it.
- Now Router A goes down and comes up again.
- Originates LSA (with different mask -  /16 but same lsid) with Seq no. =
80000001
    (This always results in same checksum assuming other parameters such as
cost etc. are same!!)
Now during DB exchange
- Router A receives a DD packet with its own LSA listed - however when it
compares
  DB LSA with one in DD packet the Seq number and Checksum would be same
  (and age difference < MAXAGE_DIFF)
   so it would assume that its the same LSA and not request it.
- Same thing happens at Router B.
- Untill Router A reoriginates the LSA Router B would still keep the Old LSA
(mask = /8).

As I understand this is a very rare case - but I was thinking if OSPF rfcs
provide any mechanism to resolve this faster - though I didn't find any such
references.

Thanks
Parag

----- Original Message -----
From: Shanthi Pendyala <[email-masked]>
To: <[email-masked]>
Sent: Friday, August 29, 2003 12:40 PM
Subject: Re: DB Synchronization

hi,

Router A will request a copy of the stale LSA from B even though it has the
more upto-date LSA.

shanthi kiran

-----Original Message-----
From: Parag Deshpande [mailto:[email-masked]]
Sent: Friday, August 29, 2003 10:13 AM
To: [email-masked]
Subject: DB Synchronization

Hi,

I had a doubt ->

Thanks
Parag