Subject: Re: RFC 2328 : Appendix E

From: Vivek Dubey <[email-masked]>
Date: Tue, 12 Aug 2003 11:25:50 -0000

Hi Acee,
Continuing the thread:
   Router R1 originates AS Ext LSAs:
      LS1 : 10.0.0.0/8
      LS2 : 10.0.255.255/16 ; Fwd Addr N1; Metric 10; Type 1

   Router R2 originates AS Ext LSA:
      LS1 : 10.0.0.0/16 ; Fwd Addr N1; Metric 10; Type 1

1)Now are LS2(R1) and LS1(R2) functionally equivalent ??

2)Further is there a possibility of routers,
   with some supporting Appendix E and others not,
   being present in same domain ??

Vivek

On Wed, 06 Aug 2003 Acee Lindem wrote :
>Hi Vivek,
>
>It might be a bit clearer as you suggest but the outcome
>is the same. The description is from the perspective of the
>LSAs while the example is from the perspective of
>routes which need to be advertised.
>
>
>Vivek Dubey wrote:
>>Conflict in description and example ??
>>
>>RFC 2328:Appendix E
>>--------------------
>>(2)
>>Obtain the network mask from the body of the already existing
>>AS-external-LSA. Call this mask NM2. There are then two cases:
>>
>>o   NM2 is longer than NM1. In this case, change the existing
>>     LSA        (having Link State ID of NA) to reference the
>>new
>>     network [NA,NM1] by        incrementing the sequence
>>number,
>>     changing the mask in the body to NM1 and inserting the
>>cost
>>     of the new network.        Then originate a new LSA for the
>>old
>>     network [NA,NM2], with Link        State ID equal to NA
>>or'ed
>>     together with the bits that        are not set in NM2
>>(i.e.,
>>     network [NA,NM2]'s broadcast address).
>>
>>As an example of the algorithm, consider its operation when
>>the
>>following sequence of events occurs     in a single router
>>(Router
>>A).
>>(1) Router A wants to originate an AS-external-LSA for
>>     [10.0.0.0,255.255.255.0]:
>>     (a) A Link State ID of 10.0.0.0    is used.
>>
>>(2) Router A then wants to originate an AS-external-LSA for
>>     [10.0.0.0,255.255.0.0]:
>>
>>     (a) The LSA for    [10.0.0,0,255.255.255.0] is
>>reoriginated
>>         using a new    Link State ID of 10.0.0.255.
>>
>>     (b) A Link State ID of 10.0.0.0    is used for
>>         [10.0.0.0,255.255.0.0].
>>
>>vivek>>
>>Point (2) in e.g should be:
>>      a) Reoriginate existing LSA with
>>         10.0.0.0 [10.0.0.0, 255.255.0.0], incrementing
>>         sequence number,changing the mask in the body, and
>>         inserting the cost of new network.
>>
>>      b) Originate a new LSA for LsId
>>         10.0.0.255 [10.0.0.0, 255.255.255.0]
>>
>>
>>Vivek
>>
>>___________________________________________________
>>Download the hottest & happening ringtones here!
>>OR SMS: Top tone to 7333
>>Click here now:
>>http://sms.rediff.com/cgi-bin/ringtone/ringhome.pl
>>
>
>--
>Acee

___________________________________________________
Meet your old school or college friends from
1 Million + database...
Click here to reunite www.batchmates.com/rediff.asp

---

From: Acee Lindem <[email-masked]>
Date: Tue, 12 Aug 2003 22:50:10 -0400

Hi Vivek,

> 1)Now are LS2(R1) and LS1(R2) functionally equivalent ??

No - the masks in the body of the LSA are different.

>   being present in same domain ??

Yes. An OSPFv2 router can't make any assumptions regarding
te setting of the host bits in the Link State ID for type 3
or 5 LSA's originated by another router. Incremental SPF
computations must take this fact into account.

--
Acee