Subject: Re: Unequal cost multi-path routing?

From: Acee Lindem <[email-masked]>
Date: Sat, 2 Aug 2003 10:18:54 -0400

Ashish Zalani wrote:
> This may sound like a dumb question, but:
>
> Why does OSPF not support unequal cost multi-path routing, like EIGRP?
> Is it because unequal cost multi-path may lead to routing loops or other similar routing problems?

Yes - it complicates the basic SPF and there has never been
a strong requirement.

> -Ashish.

--
Acee

---

From: ROB PATH <[email-masked]>
Date: Sun, 3 Aug 2003 14:08:44 -0700

--- Acee Lindem <[email-masked]> wrote:
> > Is it because unequal cost multi-path may lead to
> routing loops or other similar routing problems?
>

The default SPF based route calculation in the case of
OSPF does not take into account the traffic load
on any of the routes.

The SPF algorithm computes the optimal routes based
only on the cost metric and traffic load on the paths
are not considered.

So if load balancing is done over multiple unequal
cost paths then it leads to non-optimal routing.

E.g assume there are n paths P1, P2, ... Pn of unequal
costs say, C1, C2, C3, C4, .... ... Cn and total
lengths of packets transmitted over those paths are,
L1, L2, ... ... Ln.

Also let Cj is the cost to transmit a packet of unit
length over the path Pj.

Without loss of generality the unequal costs can be
ordered as :- Cn > Cn-1 > ... ... C3 > C2 > C1 > 0.

Then total cost of transmission using

a) Unequal cost multi-path load balancing is :-
        C1L1+C2L2+C3L3+ ... ... CnLn

b) No unequal cost multi-path load balancing (Optimal
Routing) is :- C1 * (L1+L2+L3+ ... ... +Ln).

Now :-
C1L1+C2L2+C3L3+ ... ... CnLn > C1L1+C1L2+C1L3+...+C1Ln
                             > C1 * (L1+L2+L3+ ...+Ln)

This shows that Unequal cost multi-path routing
leads to non-optimal routing.

Thanks,
     Rob.

> > -Ashish.

=====
Rob Path
E-Mail : [email-masked]

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com