Subject: Re: Regarding functionally equivalent LSA.

From: Vivek Dubey <[email-masked]>
Date: Thu, 30 Oct 2003 12:18:07 -0000

1) R1 goes down
2) R2 looses the ASBR entry to R1
3) R1 reoriginates static routes flushed previously because of same
   being originated by R1.
   Morever R1 should only flush As Ext LSA (being of lower router id) 
   only if ASBR (of higher router id) is reachable.
How is it done may vary with implementations.

-Vivek

On Thu, 30 Oct 2003 Subratm wrote :
>Pl. look at the following scenario.
>
>         10.0.0.0       20.0.0.0      30.0.0.0
>      R1------------R2-------------R3----------
>
>R1,R2 are ASBRs.
>
>Router id of R1 is 10.0.0.4
>Router id of R2 is 10.0.0.3
>Router id of R2 is 30.0.0.3
>
>R1 and R2 have static route to the network 11.0.0.0/8. So both R1 and R2
>originate ASExt LSA for the network 11.0.0.0/8. Because R1 has the higher
>router id, R2 flushes out the ASExt LSA for the network 11.0.0.0/8
>originated by itself. Now all three routers (R1,R2,R3) have the ASExt LSA
>for the network 11.0.0.0/8 originated by R1. Therefore they have the route
>to 11.0.0.0/8 in the ip routing table.
>
>Now R1 goes down. R2 and R3 delete the route to 11.0.0.0/8 from the ip
>routing table. But R2  is not able to originate the ASExt LSA as the
>existing ASExtLSA for 11.0.0.0/8 has the higher router id (R1's router id).
>So R3 does not have the route to 11.0.0.0/8. R2 and R3 has the ASExt LSA for
>11.0.0.0/8 originated by R1.
>
>Ideally how should R2 behave so that R3 will have the route to 11.0.0.0/8 in
>it's IP routing table.
>
>Regards Subrat
>
>
>
>***************************************************************************
>This message is proprietary to Future Software Limited (FSL)
>and is intended solely for the use of the individual to whom it
>is addressed. It may contain  privileged or confidential information
>and should not be circulated or used for any purpose other than for
>what it is intended.
>
>If you have received this message in error, please notify the
>originator immediately. If you are not the intended recipient,
>you are notified that you are strictly prohibited from using,
>copying, altering, or disclosing the contents of this message.
>FSL accepts no responsibility for loss or damage arising from
>the use of the information transmitted by this email including
>damage from virus.
>***************************************************************************

---

From: Subratm <[email-masked]>
Date: Thu, 30 Oct 2003 18:20:09 +0530

In step 3 did u mean R1 to be R2 by mistake?? I am just modifying the
sequence. Pl. let me know my understanding is correct.

1) R1 goes down
2) R2 looses the ASBR entry to R1
3) R2 reoriginates static routes flushed previously because of same
  being originated by R1.
  Morever R2 should only flush As Ext LSA (being of lower router id)
  only if ASBR (of higher router id) is reachable.
How is it done may vary with implementations.

  -----Original Message-----
  From: Mailing List [mailto:[email-masked]]On Behalf Of Vivek
Dubey
  Sent: Thursday, 30 October 2003 5:48 PM
  To: [email-masked]
  Subject: Re: Regarding functionally equivalent LSA.

  1) R1 goes down

  -Vivek

---

From: Erblichs <[email-masked]>
Date: Thu, 30 Oct 2003 10:08:30 -0800

To posters of this mail-thread,

        You do realize that this is a public mail alias and
        that no stated or inferred confidential information
        agreements are in place between members of this mail
        alias.

        Mitchell Erblich
        --------------------------

> Subratm wrote:
>      From: Mailing List [mailto:[email-masked]]On
>      Behalf Of Vivek Dubey