Subject: Re: My comment on draft-mirtorabi-ospf-tunnel-adjacency

From: "Pat Murphy - (650)329-4044" <[email-masked]>
Date: Fri, 14 Nov 2003 10:02:04 -0700

Sina,

In your original draft TAs were never tied to a path whose first hop must
use a specific interface or link whose status can be monitored. Has that
changed? I almost posted a more complicated example with intermediate
routers A1 and C1 in Area 1, and B2 and D2 in Area 2. In this case A0, B0,
C0, and D0 do not see Xs fail.

                        N2
                         .
                         .
                        B0
                       . . .
          Area 1     .   .   .     Area 2
           link    .     .     .    link
                 .      B2     .
               .         .         .
             A0....A1...Xs....C1...C0
               .         .         .
                 .       .      .
                   .    D2     .   Area 1
          Area 2     .   .   .      link
           link        . . .
                        D0

Its very hard to build a straightforward non-contrived example of a cloud
of routers with a bevy of backup tunnels supporting them. In general there
would be multiple hopes. Given that SPF calculations of distinct areas are
completely disjoint, I do see these lag times during which packet storms
can exist. It would be a difficult scenario to troubleshoot.

Pat

---

From: Sina Mirtorabi <[email-masked]>
Date: Fri, 14 Nov 2003 10:18:48 -0800

Pat,

Let me Mention one more time.

In your example with endless encapsulation you *assumed* that TA1 path
goes over each other therefore endless encapsulation occur during the
failure detection.

The fact is that TA path cannot go over each other therefore after the
first encapsulation the packet will be dropped. It has nothing to do
with detecting the failure

If you still think that this is possible please provide metric with the
shortest path taken with each TA in your example

Thanks
Sina

->
->Sina,
->
->In your original draft TAs were never tied to a path whose
->first hop must use a specific interface or link whose status
->can be monitored. Has that changed? I almost posted a more
->complicated example with intermediate routers A1 and C1 in
->Area 1, and B2 and D2 in Area 2. In this case A0, B0, C0, and
->D0 do not see Xs fail.
->
->                        N2
->                         .
->                         .
->                        B0
->                       . . .
->          Area 1     .   .   .     Area 2
->           link    .     .     .    link
->                 .      B2     .
->               .         .         .
->             A0....A1...Xs....C1...C0
->               .         .         .
->                 .       .      .
->                   .    D2     .   Area 1
->          Area 2     .   .   .      link
->           link        . . .
->                        D0
->
->Its very hard to build a straightforward non-contrived
->example of a cloud of routers with a bevy of backup tunnels
->supporting them. In general there would be multiple hopes.
->Given that SPF calculations of distinct areas are completely
->disjoint, I do see these lag times during which packet storms
->can exist. It would be a difficult scenario to troubleshoot.
->
->Pat
->