Subject: Re: Area Parameters

From: Igor Miroshnik <[email-masked]>
Date: Wed, 10 Dec 2003 08:43:23 -0500

Acee,

   On of the OSPF postulates states that all routers attached to a common
area must have synchronized LS databases in that area. What if one of those
routers sends a non-default Network Summary to another one, which rejects
it, as it was configured to neither generate nor propagate non-default
Network Summaries? Should the latter raise Sequence Mismatch? Then this
pair will unsuccessfully attempt to get adjacent forever. Otherwise,
accepting such a Summary by the latter router will override the policy
intended to reduce the LSDB and CPU overhead in it.

Thank you,
Igor

On Wed, 10 Dec 2003 06:19:26 -0500, Acee Lindem <[email-masked]> wrote:

>Igor Miroshnik wrote:
>
>>Group,
>>
>>RFC 2328 says (listing, inter alia, StubDefaultCost):
>>
>>"   C.2 Area parameters
>>
>>    All routers belonging to an area must agree on that area's
>>configuration. Disagreements between two routers will lead to an inability
>>for adjacencies to form between them, with a resulting hindrance to the
>>flow of routing protocol and data traffic."
>>
>
>Hi Igor,
>
>The general statement above applies to area type. It probably should be
>more explicit. The OSPF
>specification evolved over a number or iterations and originally the
>authentication type was also
>specified at an area level.
>
>
>
>>
>>On the other hand,
>>
>>"   12.4.3.1. Originating summary-LSAs into stub areas
>>
>>... Note that StubDefaultCost need not be configured identically in all of
>>the stub area's area border routers."
>>
>>1) Don't the quoted passages contradict?
>>
>Somewhat - when in doubt, match on the  more specific statement.
>
>>2) What about ospfAreaSummary: should all routers in a stub area agree
upon
>>this parameter? If so, how can they indicate that: no bit in area options
>>tells about Totally Stubby Areas?
>>
>They don't necessarily need to agree if you want to prefer one ABR as an
>exit point for OSPF
>inter-area traffic.
>
>
>>
>>Thank you,
>>Igor
>>
>>
>>

---

From: Acee Lindem <[email-masked]>
Date: Wed, 10 Dec 2003 09:07:22 -0500

Igor Miroshnik wrote:

>Network Summaries?
Hi Igor,

I'm not sure I understand your concern. Why would one of the ABRs
rejected the LSA? The no-summary
configuration dictates what is advertised - not what is accepted.

>Should the latter raise Sequence Mismatch? Then this
I think the intent of configuring no-summary on only a subset of ABRs
would be to prefer certain
exit points for inter-area traffic. In any case, you would still reduce
the total number  of summaries
in the area by configuring no-summary on some of the ABRs.