Subject: multiple address families in OSPFv3

From: je chen <[email-masked]>
Date: Tue, 9 Dec 2003 14:14:56 -0800

Hi,

I have three questions.

1) Is there extension of OSPFv3 to support OSPFv3
running on IPv4 network ?
2) I read draft "support multiple address families in
OSPFv3". It looks to me it is part of the effort to
support OSPFv3 running on IPv4 network. Do I
misunderstand the purpose of this draft ?
3) If OSPFv3 is running on top of IPv6 only, how can
it support IPv4 address family as an IGP ?

Thanks,
Ed

__________________________________
Do you Yahoo!?
New Yahoo! Photos - easier uploading and sharing.
http://photos.yahoo.com/

---

From: Acee Lindem <[email-masked]>
Date: Fri, 12 Dec 2003 01:28:43 -0500

>running on IPv4 network ?
No - although one alternative discussed for virtual links and IPv4 address
families is to natively carry OSPFv3 over IPv4.

>misunderstand the purpose of this draft ?
I think you may have - what this draft would allow you to do is to advertise
IPv4 prefixes with OSPFv3. You'd still run OSPFv3 over IPv6 .

>it support IPv4 address family as an IGP ?
The OSPFv3 intra-area calculation builds a graph (with routers and
transit networks as the verticies) representing the area's topology . If
you modify the calculation to choose an IPv4 next-hop (as opposed to
the IPv6 link-local addresses) and advertise IPv4 prefixes in place
of IPv6 prefixes for all types of prefix LSAs you can support
IPv4 address families. Granted, I 've left out a lot of details but
the approach is clear.