Subject: Re: Area Parameters

From: Igor Miroshnik <[email-masked]>
Date: Wed, 10 Dec 2003 10:40:05 -0500

Acee,

   My concern is all about the description of ospfAreaSummary in both RFC
1850 and draft-ietf-ospf-mib-update-07:

"If it is noAreaSummary, the router will neither originate nor propagate
summary LSAs into the stub or NSSA area. It will rely entirely on its
default route."

   According to your interpretation, if I'm not mistaking, a router having,
say, two OSPF interfaces in a Totally Stubby Area would accept a non-
default Network Summary from a neighbor on one interface in this area,
install it in the LSDB, and flood it to neighbors on the other interface in
this area, abstaining merely from the originating of its own summaries. So
what does mean RFC 1850 under "not to propagate"? Haven't the router above
just propagated that summary?

Thank you,
Igor

On Wed, 10 Dec 2003 09:07:22 -0500, Acee Lindem <[email-masked]> wrote:

>Igor Miroshnik wrote:
>
>>Acee,
>>
>>   On of the OSPF postulates states that all routers attached to a common
>>area must have synchronized LS databases in that area. What if one of
those
>>routers sends a non-default Network Summary to another one, which rejects
>>it, as it was configured to neither generate nor propagate non-default
>>Network Summaries?
>>
>Hi Igor,
>
>I'm not sure I understand your concern. Why would one of the ABRs
>rejected the LSA? The no-summary
>configuration dictates what is advertised - not what is accepted.
>
>>Should the latter raise Sequence Mismatch? Then this
>>pair will unsuccessfully attempt to get adjacent forever. Otherwise,
>>accepting such a Summary by the latter router will override the policy
>>intended to reduce the LSDB and CPU overhead in it.
>>
>I think the intent of configuring no-summary on only a subset of ABRs
>would be to prefer certain
>exit points for inter-area traffic. In any case, you would still reduce
>the total number  of summaries
>in the area by configuring no-summary on some of the ABRs.
>
>
>>
>>Thank you,
>>Igor
>>
>>On Wed, 10 Dec 2003 06:19:26 -0500, Acee Lindem <[email-masked]> wrote:
>>
>>
>>
>>>Igor Miroshnik wrote:
>>>
>>>
>>>
>>>>Group,
>>>>
>>>>RFC 2328 says (listing, inter alia, StubDefaultCost):
>>>>
>>>>"   C.2 Area parameters
>>>>
>>>>   All routers belonging to an area must agree on that area's
>>>>configuration. Disagreements between two routers will lead to an
inability
>>>>for adjacencies to form between them, with a resulting hindrance to the
>>>>flow of routing protocol and data traffic."
>>>>
>>>>
>>>>
>>>Hi Igor,
>>>
>>>The general statement above applies to area type. It probably should be
>>>more explicit. The OSPF
>>>specification evolved over a number or iterations and originally the
>>>authentication type was also
>>>specified at an area level.
>>>
>>>
>>>
>>>
>>>
>>>>On the other hand,
>>>>
>>>>"   12.4.3.1. Originating summary-LSAs into stub areas
>>>>
>>>>... Note that StubDefaultCost need not be configured identically in all
of
>>>>the stub area's area border routers."
>>>>
>>>>1) Don't the quoted passages contradict?
>>>>
>>>>
>>>>
>>>Somewhat - when in doubt, match on the  more specific statement.
>>>
>>>
>>>
>>>>2) What about ospfAreaSummary: should all routers in a stub area agree
>>>>
>>>>
>>upon
>>
>>
>>>>this parameter? If so, how can they indicate that: no bit in area
options
>>>>tells about Totally Stubby Areas?
>>>>
>>>>
>>>>
>>>They don't necessarily need to agree if you want to prefer one ABR as an
>>>exit point for OSPF
>>>inter-area traffic.
>>>
>>>
>>>
>>>
>>>>Thank you,
>>>>Igor
>>>>
>>>>
>>>>
>>>>
>>>>
>>
>>
>>

---

From: Acee Lindem <[email-masked]>
Date: Wed, 10 Dec 2003 11:45:31 -0500

Igor Miroshnik wrote:

>say, two OSPF interfaces in a Totally Stubby Area
>
You mean a stub area with noAreaSummary  - "totally Stubby Area" is a
vendor term.

>would accept a non-
Nope - its simply flooded an LSA originated by the other ABR. In this
context, the term "propagate"
refers to the fact backbone inter-area routes result in summaries in an
ABRs attached areas. However,
it is confusinng and the term "originate" would suffice.

Dan - can you replace "orginate nor propagate" with simply "orginate" in
the description for
ospfAreaSummary if you haven't already refreshed the draft?

Thanks,
Acee