Subject: Does anyone has experience with operationally down interface, which can still be IP reachable?

From: Dan Dovolsky <[email-masked]>
Date: Thu, 18 Dec 2003 10:28:05 -0500

Does anyone has experience with operationally down interface, which still
can be IP reachable?

Thanks,
Dan Dovolsky.

[email-masked]

---

From: Mukesh Hira <[email-masked]>
Date: Thu, 18 Dec 2003 12:11:19 -0800

Yes, I've done this for a special purpose - management stations use the IP address of one particular interface as a handle to communicate with the node, so even if this interface is down, we've had to keep it IP reachable. I was able to do this by changing the subnet mask to /32, which tells the stack that no other node is reachable on the interface. However, the interface IP address is still exported into all the routing protocols as a /32 route (host-specific route), this keeping it IP reachable via other interfaces on the node.

- Mukesh

-----Original Message-----
From: Mailing List [mailto:[email-masked]]On Behalf Of Dan
Dovolsky
Sent: Thursday, December 18, 2003 7:28 AM
To: [email-masked]
Subject: Does anyone has experience with operationally down interface,
which can still be IP reachable?

Thanks,
Dan Dovolsky.

[email-masked]

---

From: Phanidhar Koganti <[email-masked]>
Date: Thu, 18 Dec 2003 15:35:23 -0500

Yes, we have done it in our system where the IP address assigned to the management interface is used as the router ID, so we populate that to all our neighbors which are connected through other interfaces using our custom ECC. 

So even when the management interface is operationally down, we achieve reach ability by not bringing him down administratively and also change the netmask to 32 bits. Changing netmask to 32 bits does two things, it removes the interface route which will force the return traffic to go through the other interfaces. This is needed if the routing protocol is not running on interface which went down operationally.

Hope this helps.

Phani Koganti
Internet Photonics Inc.

-----Original Message-----
From: Dan Dovolsky [mailto:[email-masked]]
Sent: Thursday, December 18, 2003 10:28 AM
To: [email-masked]
Subject: Does anyone has experience with operationally down interface,

Thanks,
Dan Dovolsky.

[email-masked]