Subject: OSPF routers with port rules question

From: Alexander Cheskis <[email-masked]>
Date: Tue, 16 Dec 2003 15:45:00 +0300

Dear Group,

I need to find routing solution for attached (PDF scheme) network configuration.

Router 192.168.20.2 can relay traffic as shown:

(port rule 1) From bottom networks (192.168.50.x) , to the bottom ports of
192.168.40.x
(port rule 2) From the top networks (192.168.20.x), to the top ports of
192.168.30.x

Obviously, when all port2port traffic is enabled on 192.168.20.2, everything is
fine. All 5 routers are OSPF enabled in the same area.
But when port rules are applied, bottom networks can't access top ones and visa
versa.

Thanks in advance,
Alexander Cheskis

---

From: Acee Lindem <[email-masked]>
Date: Tue, 16 Dec 2003 09:12:59 -0500

> But when port rules are applied, bottom networks can't access top ones and visa

Alexander,

If I understand what you are trying to do (and it ain't obvious), you can't solve
this problem with OSPF. The cost via the Blue routers is always going to be
higher than the direct path. Rather than blocking ports, you need to
something akin to policy based routing (i.e., forcing the traffic path to
be different than the routed path using some other packet selection
criteria).

Good Luck,
-- 
Acee

---

From: Erblichs <[email-masked]>
Date: Tue, 16 Dec 2003 11:15:29 -0800

Alexander Cheskis,

        The only way to favor or not favor a route in traditional
        OSPF hop by hop routing is with the link costs assigned
        to each hop of the route.

        However, even with an infinite link costs to for
        certain hops, if there is no alternate route available,
        the infinite link cost hop will still be used.

        Thus, within OSPF, I am not sure how you can enforce that
        the bottom networks not send or recieve traffic from the
        top networks. If packet policy routing is wanted, a MPLS
        OSPF network can possibly be used to achieve your results.

        Mithell Erblich
        Sr Network Software Engineer
        -----------------------------

Alexander Cheskis wrote:
>   ------------------------------------------------------------------------
>                              Name: OSPF_and_PortRules.pdf
>    OSPF_and_PortRules.pdf    Type: Acrobat (application/pdf)
>                          Encoding: base64